Linux Version Compatibility

General support for problems installing or using Deluge
Post Reply
forrest_jc
New User
New User
Posts: 1
Joined: Wed Jan 26, 2022 4:23 pm

Linux Version Compatibility

Post by forrest_jc »

For a while, I've been running Deluge 1.3.15-2, under Raspian 10 (Buster). Recently, I picked up a Chromebook and turned on the Linux VM which is running Debian 11 (Bullseye). I want to manage the RasPi daemon via Thin Client from the Chromebook, but I'm not sure it's possible.

On the Chromebook, i.e. Bullseye, v2.0.3-3.1 is the default version from APT - not compatible since the daemon and client need to be the same major version. When manually installing v1.3.15-2, it errors out with dependency issues - Python version etc.

1. Are there any "standard" steps to install Deluge 1.3.15 on Bullseye?
2. Is there a better solution for managing the RasPi from a Chromebook? (Not WebUI, since I use YaRSS2).
basher
Member
Member
Posts: 31
Joined: Wed Sep 29, 2021 8:42 am
Location: Estonia

Re: Linux Version Compatibility

Post by basher »

I'd recommend going with docker for older versions. debian:buster-slim image would install 1.3.15 by default.

If you only want the thin client to connect to your server, you can check out the dockerfile I'm using: https://github.com/laur89/deluge-gtk-1.3.15-docker
Cas
Top Bloke
Top Bloke
Posts: 3677
Joined: Mon Dec 07, 2009 6:04 am
Location: Scotland

Re: Linux Version Compatibility

Post by Cas »

It is possible to install Deluge 2.0 on Bullseye using the PPA: https://deluge.readthedocs.io/en/latest ... e-installs

Old debian instruction to help: https://dev.deluge-torrent.org/wiki/Ins ... ian/Jessie

bullseye ~= focal : https://askubuntu.com/questions/445487/ ... s-based-on
Post Reply