ETA on 2.0.3 .app

Support for Deluge on Apple Mac OS
Lord-Kamina
Member
Member
Posts: 12
Joined: Sun Dec 22, 2019 4:24 pm

Re: ETA on 2.0.3 .app

Postby Lord-Kamina » Wed Jul 01, 2020 3:58 am

https://www.dropbox.com/s/c51t7y5kh7za2 ... pp.7z?dl=1

Note, as I said previously, if you're on macOS 10.13+, this should open magnets natively, without relying on the Magnet Handler app.

skupjoe
New User
New User
Posts: 7
Joined: Mon Apr 13, 2020 6:39 am

Re: ETA on 2.0.3 .app

Postby skupjoe » Mon Jul 06, 2020 4:18 am

Hello Lord-Kamina and thank you for continuing to support us. I tried your latest release and it works well but it still doesn't seem like the magnet downloading is functioning, for me at least.

I do see the "Open in Deluge2.app" window appears after clicking on a magnet link, however, it doesn't seem to do anything. I did try on multiple sites and a few different torrents. Let me know if there are any other steps I should try or any other information/debug that I can provide. Thanks again!

Lord-Kamina
Member
Member
Posts: 12
Joined: Sun Dec 22, 2019 4:24 pm

Re: ETA on 2.0.3 .app

Postby Lord-Kamina » Mon Jul 06, 2020 5:15 am

First: You are using macOS newer than 10.13, yes?

Second, why Deluge2.app? Do you have multiple instances of Deluge running? Are you using classic mode or thinclient?

Is the Deluge UI open when you try doing this?

kalel
New User
New User
Posts: 3
Joined: Thu May 28, 2020 10:51 pm

Re: ETA on 2.0.3 .app

Postby kalel » Mon Jul 06, 2020 8:37 am

Hello and thank you for this new release!
In my experience, with the magnet handler still installed in my system, the magnet links work just fine.
On the other hand, the add torrent window is not opening when double clicking a torrent file. This happens only when the program is already opened. When there is no instance of Deluge, by double clicking a torrent file, the program is started and add torrent window is in foreground.
The only way to add torrents when the program is opened, is by manually adding the torrent file (+ -> File)
I'm on Catalina and I had this behaviour with both versions... the 2.0.3 beta and 2.0.4 beta. Unfortunately, I can't remember about the 1.3.15 version from a couple of months ago.
I did try to build deluge from macports in April, but I cleaned that installation and still, this behaviour remains.
It did not bother me very much... I just adapted.

skupjoe
New User
New User
Posts: 7
Joined: Mon Apr 13, 2020 6:39 am

Re: ETA on 2.0.3 .app

Postby skupjoe » Mon Jul 06, 2020 10:17 pm

Lord-Kamina wrote:First: You are using macOS newer than 10.13, yes?

Second, why Deluge2.app? Do you have multiple instances of Deluge running? Are you using classic mode or thinclient?

Is the Deluge UI open when you try doing this?

I am running thinclient and macOS 10.15.5. I renamed it to Deluge2.app because I was still using Deluge v1.3.15 (also thinclient) for a different server, while I transitioned to Deluge v2.

Today I fully deprecated that server, however, and I removed my old Deluge.app and I renamed this one, so only one exists now. Magnetic links still don't appear to be working, unfortunately.

Sorry for the confusion there.

Yes, the Deluge window is open while I attempt this, but nothing happens. I've got to still add it manually, like as mentioned by the commenter above me.

skupjoe
New User
New User
Posts: 7
Joined: Mon Apr 13, 2020 6:39 am

Re: ETA on 2.0.3 .app

Postby skupjoe » Mon Jul 06, 2020 10:27 pm

OK interesting- I just tried adding a magnet link with Deluge.app fully closed and it actually works. It starts the app and connects to my server (since I have it set to connect automatically) and then an "Add Queued Torrents" window appears, and then from there I can click "Add" and then an "Add Torrents" window appears where I can click "Add" again.

(I need to wait a few moments before clicking "Add" on the "Add Queued Torrents" window or else I don't get the second prompt.)

But this will not work if Deluge.app is open/minimized.

kalel
New User
New User
Posts: 3
Joined: Thu May 28, 2020 10:51 pm

Re: ETA on 2.0.3 .app

Postby kalel » Tue Jul 07, 2020 7:02 am

I've been playing arround with Info.plist in Deluge.app/Contents
I added:

Code: Select all

   <key>UTExportedTypeDeclarations</key>
   <array>
      <dict>
         <key>UTTypeConformsTo</key>
         <array>
            <string>public.data</string>
            <string>public.item</string>
            <string>com.bittorrent.torrent</string>
         </array>
         <key>UTTypeDescription</key>
         <string>BitTorrent Document</string>
         <key>UTTypeIconFile</key>
         <string>torrent</string>
         <key>UTTypeIdentifier</key>
         <string>org.bittorrent.torrent</string>
         <key>UTTypeReferenceURL</key>
         <string>http://www.bittorrent.org/beps/bep_0000.html</string>
         <key>UTTypeTagSpecification</key>
         <dict>
            <key>com.apple.ostype</key>
            <string>TORR</string>
            <key>public.filename-extension</key>
            <array>
               <string>torrent</string>
            </array>
            <key>public.mime-type</key>
            <string>application/x-bittorrent</string>
         </dict>
      </dict>
   </array>

I copied and modified it from Transmission but it seems to see now Deluge as a recommended app to work with torrent files.

Pavan355
New User
New User
Posts: 2
Joined: Wed Sep 02, 2020 5:11 pm

Re: ETA on 2.0.3 .app

Postby Pavan355 » Wed Sep 02, 2020 7:10 pm

Hey.
i cant find any 2.0.3.app for macos

ScottC
Member
Member
Posts: 11
Joined: Fri Jul 22, 2016 3:44 pm

Re: ETA on 2.0.3 .app

Postby ScottC » Mon Sep 14, 2020 5:15 pm

Pavan355 wrote:Hey.
i cant find any 2.0.3.app for macos


You just need to look a couple posts up.

Lord-Kamina wrote:https://www.dropbox.com/s/c51t7y5kh7za2kl/Deluge.app.7z?dl=1

Note, as I said previously, if you're on macOS 10.13+, this should open magnets natively, without relying on the Magnet Handler app.

User avatar
wgstarks
Member
Member
Posts: 24
Joined: Thu Jun 29, 2017 11:06 pm
Location: North Carolina USA

Re: ETA on 2.0.3 .app

Postby wgstarks » Sun Sep 27, 2020 1:16 am

I just discovered this app and really loving it. I'm using it as thin client to monitor a remote server and it's working nicely. I did notice though that I don't see the plugins that have been installed on the server. Only the core plugins. Have I missed something?


Return to “Mac OS”

Who is online

Users browsing this forum: No registered users and 0 guests