Can't connect to Deluge at all after computer reboot.

Specific support for Deluge on Microsoft Windows OS
purple24gold
New User
New User
Posts: 1
Joined: Mon Feb 27, 2017 3:16 am
OS or Distro: windows 10

Can't connect to Deluge at all after computer reboot.

Postby purple24gold » Mon Feb 27, 2017 3:33 am

So I was following this guide, start to finish to set up torrenting automation with Deluge - https://www.cuttingcords.com/home/ultim ... and-deluge

Everything worked perfectly and things were going great for a few days but once I had to restart my computer, I wasn't able to get deluge working again. The localhost:38081 that I used to access deluge stopped working and wouldn't load. If I test the client from within sonar I get an error. However I see deluge running under task manager, I just cant see any windows and it's not in the system tray. I've read something about it being off screen maybe but I only have 1 monitor so it can't be that. The guide I followed used "deluged" instead of deluge so if I open deluge program it opens but webui still does not. This has happened twice now where it just disappears and I cant figure out what's wrong. The first time, I ended up doing a complete uninstall and deleting all leftover files and re-installed it and that worked...until I had to restart my computer again. Any help would be greatly appreciated!

Cas
Top Bloke
Top Bloke
Posts: 3475
Joined: Mon Dec 07, 2009 6:04 am
OS or Distro: Ubuntu 16.04
Location: Scotland

Re: Can't connect to Deluge at all after computer reboot.

Postby Cas » Tue Feb 28, 2017 11:59 am

You need to be a bit clearer about what you are trying and what the actually question is.

A few points:
  • that is a non-default port
  • deluge-web will only work if you have the plugin enabled or running the separate deluge-web application.
  • leaving deluge running in the background is best accomplished with the deluged daemon.

Vlad_M
New User
New User
Posts: 3
Joined: Tue Apr 18, 2017 3:25 pm
OS or Distro: Windows 10

Re: Can't connect to Deluge at all after computer reboot.

Postby Vlad_M » Tue Apr 18, 2017 3:37 pm

I registered to post the exact same question, so will use this thread.

I am running 1.3.14 on a Windows 10 box. Also have it set up as a download client in Sonarr, also using port 38081 (comes from the guide OP referenced). Everything worked a treat up until a few days ago.

After a reboot, http://localhost:38081 from any browser simply returns "localhost didn’t send any data. ERR_EMPTY_RESPONSE". Trying 127.0.0.1:38081 results in the same. I can see the daemon running in the Task Manager, however neither browsers, nor Sonarr can connect.

However, firing up the GTK UI, the daemon is seen in the connection box, I can connect to it, and download/upload torrents. The port is correctly shown as 38081 in the settings (and in the connection window).

Any idea what is going on, and how I can get it back to normal? I tried to uninstall and then reinstall Deluge, and got exactly the same problem.

reagw83
New User
New User
Posts: 1
Joined: Mon Aug 13, 2018 10:11 am
OS or Distro: Windows 10

Re: Can't connect to Deluge at all after computer reboot.

Postby reagw83 » Mon Aug 13, 2018 10:17 am

Hi

I am running 1.3.15 on a Windows 10.

I have run into this exact same problem (using the same guide as both people from above).

I have tried changing the port from 38081 (as above) to other numbers, problem persist.
I have opened up the GTK UI, I can see deluge, however because the WebUI is not working, sonarr does not connect to my download client.
It seems that it may actually have something to do with the fact that I am running it as daemon, but I am not sure.

My Deluge WebUI run perfectly for 5 days, and I woke up to this today. Spent the whole day trying everything (yes, I have uninstalled and reinstalled) but nothing worked.
I am stumped, would anyone be able to help me out?


Return to “Windows OS”

Who is online

Users browsing this forum: No registered users and 1 guest