[Plugin] LabelPlus v0.3.2.2

Suggest, post, or discuss plugins for Deluge
Ratanak
Leecher
Leecher
Posts: 98
Joined: Sat Dec 22, 2012 4:47 am

Re: [Plugin] LabelPlus v0.3.0.6

Postby Ratanak » Wed May 07, 2014 1:42 am

RamboMcMutNutts wrote:I think I have a problem though...when accessing the label options the option box flickers like it's going on an off. I just noticed it is also happening in the right click context menus on Label Plus in the main torrent detail screen, if I try to select a label or filter the context box keeps disappearing and reappearing even second. Do you know what could possibly be causing this?

The label options dialog will be disabled when the plugin communicates with the daemon and is re-enabled when a response is received. Maybe this is what you are seeing?

About the strange context menu behavior, can you be more specific about what is happening? Is it happening when you mouse over the menu items or is it when you actually click a label? Which context box is flickering? Is it a submenu? Also, what operating system are you using and are you running the Deluge UI in classic mode?

RamboMcMutNutts
New User
New User
Posts: 6
Joined: Mon May 05, 2014 2:07 pm

Re: [Plugin] LabelPlus v0.3.0.6

Postby RamboMcMutNutts » Wed May 07, 2014 6:31 pm

The behavior is happening when I mouse over the menu items, I right click on an item on the torrent list to bring up the context menu, I mouse down to Label Plus to open the label plus menu which brings up the menu; Set Filter, Set Label and Label Options. When moving my mouse over one of those items it brings up the next menu but the menu only stays from a brief second before disappearing and then re appearing repeatedly. The main context menu and Label Plus context menu stay there it's just the "third" layer menu which seems to do this.

I've posted a video on youtube to give you an idea of what is happening: https://www.youtube.com/watch?v=V3x3RqZRd1Y&feature=youtu.be hopefully it will make more sense as my description is probably rubbish.

I am running Winodws 8.1 Update 1 64bit, and classic mode is not enabled.

It's not to much of a problem, as long as I select the label quick before the menu disappears. I am able to add a label on adding a torrent so that saves me a great deal of time :D



Thanks again

Ratanak wrote:
RamboMcMutNutts wrote:I think I have a problem though...when accessing the label options the option box flickers like it's going on an off. I just noticed it is also happening in the right click context menus on Label Plus in the main torrent detail screen, if I try to select a label or filter the context box keeps disappearing and reappearing even second. Do you know what could possibly be causing this?

The label options dialog will be disabled when the plugin communicates with the daemon and is re-enabled when a response is received. Maybe this is what you are seeing?

About the strange context menu behavior, can you be more specific about what is happening? Is it happening when you mouse over the menu items or is it when you actually click a label? Which context box is flickering? Is it a submenu? Also, what operating system are you using and are you running the Deluge UI in classic mode?

Ratanak
Leecher
Leecher
Posts: 98
Joined: Sat Dec 22, 2012 4:47 am

Re: [Plugin] LabelPlus v0.3.0.6

Postby Ratanak » Thu May 08, 2014 7:25 am

RamboMcMutNutts wrote:I've posted a video on youtube to give you an idea of what is happening

Yeah, that is definitely not supposed to happen. I haven't been able to reproduce it, but I'll try to get to the bottom of this. In the meantime, you could try the drag-n-drop way to set labels. Select the torrents and then drag-n-drop them over a label.

RamboMcMutNutts
New User
New User
Posts: 6
Joined: Mon May 05, 2014 2:07 pm

Re: [Plugin] LabelPlus v0.3.0.6

Postby RamboMcMutNutts » Sat May 10, 2014 12:46 pm

Trust me to have that bug :D

Drag and drop works brilliantly.

if you need anything further from me please feel free to ask.

Thanks again

Ratanak wrote:
RamboMcMutNutts wrote:I've posted a video on youtube to give you an idea of what is happening

Yeah, that is definitely not supposed to happen. I haven't been able to reproduce it, but I'll try to get to the bottom of this. In the meantime, you could try the drag-n-drop way to set labels. Select the torrents and then drag-n-drop them over a label.

zagor64
New User
New User
Posts: 9
Joined: Sun May 11, 2014 1:52 pm

Re: [Plugin] LabelPlus v0.3.0.6

Postby zagor64 » Sun May 11, 2014 2:07 pm

I am having the same problem with the options flickering (resetting). It makes creating autolabels impossible since it keeps resetting anything that is typed/created. Even adding a new label is tough because typing the label name is very difficult due to the "resetting" (had to copy and paste the name in). I was able to use the options one time by stopping and restarting deluge daemon but it started to "reset" once I clicked on apply button.

Ratanak
Leecher
Leecher
Posts: 98
Joined: Sat Dec 22, 2012 4:47 am

Re: [Plugin] LabelPlus v0.3.0.6

Postby Ratanak » Thu May 15, 2014 6:14 am

For people who are having flickering issues, I'm going to need your help. If you could provide the client log file, it might help me see just what is happening. You can enable logging by running the Deluge client from console. Open up a console window, go to the directory where Deluge is installed, and run the following:

Code: Select all

deluge-debug -L debug -l client.log

Where "client.log" is any filename you choose. Once the client is running, perform the action that shows the flickering and then shutdown the client. Then send me the log file. For your privacy, I recommend putting the log on a dropbox account or something and link me via PM. Alternatively, you can try pasting the contents in the PM, but there might be a character limit so I'm not sure that will work out.

RamboMcMutNutts
New User
New User
Posts: 6
Joined: Mon May 05, 2014 2:07 pm

Re: [Plugin] LabelPlus v0.3.0.6

Postby RamboMcMutNutts » Thu May 15, 2014 12:25 pm

I'd love to help but I don't know how to run deluge from a console...if I can learn to do that I'll be happy to post a log. I'll have to try and look this up and get back to you.


Ratanak wrote:For people who are having flickering issues, I'm going to need your help. If you could provide the client log file, it might help me see just what is happening. You can enable logging by running the Deluge client from console. Open up a console window, go to the directory where Deluge is installed, and run the following:

Code: Select all

deluge-debug -L debug -l client.log

Where "client.log" is any filename you choose. Once the client is running, perform the action that shows the flickering and then shutdown the client. Then send me the log file. For your privacy, I recommend putting the log on a dropbox account or something and link me via PM. Alternatively, you can try pasting the contents in the PM, but there might be a character limit so I'm not sure that will work out.

zagor64
New User
New User
Posts: 9
Joined: Sun May 11, 2014 1:52 pm

Re: [Plugin] LabelPlus v0.3.0.6

Postby zagor64 » Thu May 15, 2014 2:06 pm

I have pasted the log here minus some personal info:

http://pastebin.com/VSfvyXUq

Note - Enabling and disabling the plugin allows it to work normally until I apply some changes and then it starts flickering again
Last edited by zagor64 on Thu May 15, 2014 3:07 pm, edited 1 time in total.

zagor64
New User
New User
Posts: 9
Joined: Sun May 11, 2014 1:52 pm

Re: [Plugin] LabelPlus v0.3.0.6

Postby zagor64 » Thu May 15, 2014 2:26 pm

RamboMcMutNutts wrote:I'd love to help but I don't know how to run deluge from a console...if I can learn to do that I'll be happy to post a log. I'll have to try and look this up and get back to you.


Ratanak wrote:For people who are having flickering issues, I'm going to need your help. If you could provide the client log file, it might help me see just what is happening. You can enable logging by running the Deluge client from console. Open up a console window, go to the directory where Deluge is installed, and run the following:

Code: Select all

deluge-debug -L debug -l client.log

Where "client.log" is any filename you choose. Once the client is running, perform the action that shows the flickering and then shutdown the client. Then send me the log file. For your privacy, I recommend putting the log on a dropbox account or something and link me via PM. Alternatively, you can try pasting the contents in the PM, but there might be a character limit so I'm not sure that will work out.


In windows, from a "cmd" prompt, navigate to the deluge folder and copy and paste the command, deluge will run as normal. Do the actions, shut down deluge and now you will have a text file in the deluge folder. Open with notepad and delete personal stuff. Upload it to pastebin.com.

Ratanak
Leecher
Leecher
Posts: 98
Joined: Sat Dec 22, 2012 4:47 am

Re: [Plugin] LabelPlus v0.3.0.6

Postby Ratanak » Fri May 16, 2014 12:55 am

RamboMcMutNutts wrote:I'd love to help but I don't know how to run deluge from a console...if I can learn to do that I'll be happy to post a log. I'll have to try and look this up and get back to you.

Go into desktop mode and right-click on the windows icon in the bottom left. Choose "Command Prompt". Then, assuming you installed Deluge to the default location, type "cd C:\Program Files (x86)\Deluge" and press enter. Then type the command mentioned in my previous post.

zagor64 wrote:I have pasted the log here minus some personal info

Thanks for showing me the log. This seems to be an issue with timestamping. It might be caused by using a client and server with different times set up. Can you give me details in this regard?

I've also packaged a version with additional log messages to see how timestamping is being handled on your configurations. You can download the version here. In addition to the client log, I would also like to see the daemon logs which can be enabled by running the daemon as follows:

Code: Select all

deluged-debug -L debug -l daemon.log

Where "daemon.log" is any filename you choose.

Any additional help will be appreciated.


Return to “Plugins”

Who is online

Users browsing this forum: No registered users and 2 guests