[SOLVED] No module named hashlib

General support for problems installing or using Deluge

[SOLVED] No module named hashlib

Postby daozor » Sat Apr 17, 2010 8:32 pm

fedora 12.
deluge cant run after yum update python to ver. 2.6.2

Code: Select all

[ERROR   ] 00:30:33 ui:146 No module named hashlib
Traceback (most recent call last):
  File "/usr/lib64/python2.6/site-packages/deluge-1.2.3-py2.6-linux-x86_64.egg/deluge/ui/ui.py", line 127, in __init__
    from deluge.ui.gtkui.gtkui import GtkUI
  File "/usr/lib64/python2.6/site-packages/deluge-1.2.3-py2.6-linux-x86_64.egg/deluge/ui/gtkui/__init__.py", line 1, in <module>
    from gtkui import start
  File "/usr/lib64/python2.6/site-packages/deluge-1.2.3-py2.6-linux-x86_64.egg/deluge/ui/gtkui/gtkui.py", line 68, in <module>
    from deluge.ui.client import client
  File "/usr/lib64/python2.6/site-packages/deluge-1.2.3-py2.6-linux-x86_64.egg/deluge/ui/client.py", line 37, in <module>
    from twisted.internet import reactor, ssl, defer
  File "/usr/lib64/python2.6/site-packages/twisted/internet/ssl.py", line 191, in <module>
    from twisted.internet._sslverify import DistinguishedName, DN, Certificate
  File "/usr/lib64/python2.6/site-packages/twisted/internet/_sslverify.py", line 9, in <module>
    from twisted.python.hashlib import md5
ImportError: No module named hashlib
[ERROR   ] 00:30:33 ui:147 There was an error whilst launching the request UI: gtk
[ERROR   ] 00:30:33 ui:148 Look at the traceback above for more information.

please, help.

Top Bloke
Top Bloke
Posts: 3474
Joined: Mon Dec 07, 2009 6:04 am
OS or Distro: Ubuntu 16.04
Location: Scotland

Re: No module named hashlib

Postby Cas » Sun Apr 18, 2010 1:16 am

this is a fedora problem that you should inform them about

to get it working you need to downgrade either python or twisted to the previous version

Return to “Support”

Who is online

Users browsing this forum: No registered users and 2 guests