Proxy settings

General support for problems installing or using Deluge
delugewiba
New User
New User
Posts: 2
Joined: Mon Apr 15, 2019 8:36 am

Proxy settings

Postby delugewiba » Mon Apr 15, 2019 8:53 am

Hi.
I use deluge 1.3.15 on ubuntu 18.04 server as a demon and access it trough the web UI.

I use socks5 proxy with authentication. On the server when I access the demon I see the proxy's IP as client IP (both "checkmy torrentIP" and "trackmy IP" torrents), so far so good.

However when I go to uTorrent client (runs with the same proxy) on another public IP (different physical location) and I share the same torrent on both machines, the deluge shows my uTorrent client with proxy's IP but uTorrent shows my deluge's real public IP not the proxy's IP....

What possibly I did wrong???

regards;
wiba

mhertz
Seeder
Seeder
Posts: 177
Joined: Wed Jan 22, 2014 5:05 am

Re: Proxy settings

Postby mhertz » Tue Apr 16, 2019 1:53 am

No matter what, then you need ltconfig plugin and enabling 'force_proxy' and 'anonymous_mode' for using a socks5 proxy securely in deluge, so add that firstly before checking again.

Here's a shell-script you and other socks5 proxy users on linux can use/ammend to set everything up. Change path of deluge-profile if different, and add a 'connect' parameter to deluge-console command if not localhost. Copy/paste into a file and run with 'bash filename'.

Code: Select all

#!/bin/bash

ls ~/.config/deluge/plugins &>/dev/null || mkdir ~/.config/deluge/plugins
curl -sL "https://github.com/ratanakvlun/deluge-ltconfig/releases/download/v0.3.1/ltConfig-0.3.1-py2.7.egg" > ~/.config/deluge/plugins/ltConfig-0.3.1-py2.7.egg
cat << EOF > ~/.config/deluge/ltconfig.conf
{
  "file": 1,
  "format": 1
}{
  "apply_on_start": true,
  "settings": {
    "anonymous_mode": true,
    "force_proxy": true
  }
}
EOF
pgrep deluged >/dev/null || { x=1; deluged; }
deluge-console plugin -e ltConfig
[[ $x == 1 ]] && pkill deluged

delugewiba
New User
New User
Posts: 2
Joined: Mon Apr 15, 2019 8:36 am

Re: Proxy settings

Postby delugewiba » Thu Apr 18, 2019 11:07 am

Hi;
Just did as you suggest.
I run the shell-script but there are some issues with passwords... does not mater i run bash xx or sudo bash xx the outcome is the same

any idea what this can be about??


[ERROR ] 12:49:16 client:391 RPCError Message Received!
--------------------------------------------------------------------------------
RPCRequest: daemon.login(localclient, 991bd4bbe0f6fa2a679fda43efd40062f2806b5d)
--------------------------------------------------------------------------------
File "/usr/lib/python2.7/dist-packages/deluge/core/rpcserver.py", line 262, in dispatch
ret = component.get("AuthManager").authorize(*args, **kwargs)
File "/usr/lib/python2.7/dist-packages/deluge/core/authmanager.py", line 95, in authorize
raise BadLoginError("Password does not match")

BadLoginError: Password does not match
--------------------------------------------------------------------------------
Failed to connect to 127.0.0.1:58846 with reason: Password does not match

mhertz
Seeder
Seeder
Posts: 177
Joined: Wed Jan 22, 2014 5:05 am

Re: Proxy settings

Postby mhertz » Thu Apr 18, 2019 1:54 pm

Sorry, nothing wrong with what you've done, as the script was just a quick one modelled after my setup I.e. standard localhost setup without other user or passwords etc.

Instead of asking several questions about your setup and then ammending the script, it would be easier to do it manually, but at least the script before falling did download the plugin and the configuration needed for it, which is in your users homedir as .config/deluge/plugins/ltConfig-* and .config/deluge/ltconfig.conf, so copy them to correct place or let them be if already under correct deluge user, and then just enable the plugin from either the gtk-ui or console.

Or simply do everything manually if easier for you and so in plugin options just tick start automatically and force_proxy and anonymous_mode.


Return to “Support”

Who is online

Users browsing this forum: Google [Bot], jeraisel and 5 guests