Issues with libboost packages

General support for problems installing or using Deluge
Nott
New User
New User
Posts: 1
Joined: Thu Apr 04, 2019 12:13 pm

Issues with libboost packages

Postby Nott » Thu Apr 04, 2019 12:49 pm

I'm the owner of a deluge docker and I'm trying to keep file sizes small. The image is super big atm. I'm using deluge PPA + libtorrent 1.1.5.0. I tried to update my docker to a cleaner version but the same things I did in old version gives me libboost errors in my dev builds...why?

Example of error:

Code: Select all

ImportError: libboost_chrono.so.1.58.0: cannot open shared object file: No such file or directory


This is my repo as it is, working just fine, but very bloated: https://github.com/Nottt/easy-deluge

I have been using it for years with no issues. So I thought if I did the same thing but outside of the dockerfile it would work the same but it doesn't and I can't find the reason!

This is my new docker code to download the libtorrent 1.1.5.0 compiled file, and install deluge

Code: Select all

#!/usr/bin/with-contenv bash
source /etc/env

apt-get update && apt install -y build-essential checkinstall libboost-system-dev libboost-python-dev libboost-chrono-dev libboost-random-dev libssl-dev

# Install libtorrent if not installed already

if [ $(dpkg-query -W -f='${Status}' libtorrent-rasterbar 2>/dev/null | grep -c "ok installed") -eq 0 ]; then
  wget -q https://github.com/Nottt/easy-deluge/raw/master/files/libtorrent-1.1.5-1_amd64.deb -O /tmp/libtorrent.deb 
  dpkg -i /tmp/libtorrent.deb > /dev/null 2>&1 && apt-get install -f && ldconfig
fi

# Install necessary packages

add-apt-repository ppa:deluge-team/ppa -y > /dev/null 2>&1 && apt-get update > /dev/null 2>&1

apt-get install -y deluged deluge-web deluge-console > /dev/null 2>&1


I run this code after container boot...but It doesn't work, even if I'm doing the same things and in the same order as my current dockerfile? It feels like deluged installation is not completed because there isn't any folders like ssl, state, or deluged.pid which my working docker has...

EDIT:

Just found out that for some reason, my current docker is ubuntu 16.04 and the one I'm trying to rebuild is 18.04, and on 16.04 the libboost version is 1.58 (same as error messages) while on ubuntu 18.04 libbost package is like 1.65 so I think this may be related?

EDIT2:

The issue is really related to ubuntu 16.04 packages being 1.58 and 18.04 1.65 but I'd really like to use 18.04 as the image is much smaller...anyone can help me achieve that? I have already compiled the libtorrent file, all I want to do is to install deluge with it

EDIT3:

I discovered that on ubuntu 18.04 the deluge ppa already uses libtorrent 1.1.5 so I wasted hours for nothing lol. Is there any benefit in compiling a newer version of libtorrent?

https://github.com/arvidn/libtorrent/releases

It seems libtorrent is on version 1.2 now, with lots of fixes since 1.1.5...is it worth upgrading?

Cas
Top Bloke
Top Bloke
Posts: 3570
Joined: Mon Dec 07, 2009 6:04 am
Location: Scotland

Re: Issues with libboost packages

Postby Cas » Fri Apr 05, 2019 3:33 pm

Might want to checkout the libtorrent daily build PPAs

https://launchpad.net/~libtorrent.org/+ ... /1.1-daily
https://launchpad.net/~libtorrent.org/+ ... /1.2-daily

Although 1.2 is released I have no idea how stable it is, not tested it yet myself


Return to “Support”

Who is online

Users browsing this forum: No registered users and 4 guests