Updating 3rd party plugins for Deluge 2.0

Suggest, post, or discuss plugins for Deluge
Cas
Top Bloke
Top Bloke
Posts: 3640
Joined: Mon Dec 07, 2009 6:04 am
Location: Scotland

Updating 3rd party plugins for Deluge 2.0

Postby Cas » Sat Nov 17, 2018 9:18 am

With Deluge 2.0 we have moved to GTK3 and Python 3 so Deluge 1.3 plugins will need updating to support these changes. I have created a document to help with this process.

https://deluge.readthedocs.io/en/develo ... lugin.html

galneon
Member
Member
Posts: 29
Joined: Mon May 18, 2015 3:24 pm

Re: Updating 3rd party plugins for Deluge 2.0

Postby galneon » Sun Jun 16, 2019 9:58 pm

The Plugins page could probably use an additional column to denote 2.0.x compatibility. I'm hesitant to update without a working RSS plugin and ltconfig.

Here's an updated link to the updating guide: https://deluge.readthedocs.io/en/latest ... lugin.html

ben2talk
New User
New User
Posts: 9
Joined: Tue Oct 26, 2010 12:06 am

Re: Updating 3rd party plugins for Deluge 2.0

Postby ben2talk » Mon Jul 22, 2019 1:33 am

I'm going back now - I love the improvements, but my plugins are essential to my workflow. I am sad that I don't have the skills to update plugins.
Is it considered possible by Deluge devs that certain plugins should be regarded as basic functionality... Hopefully other superheros might find time to help out.

Certainly YaRSS2 and Seedtime, then upgrade with LabelPlus.

YaRSS2 certainly holds me back - I would need to switch client before losing this easy tool.


Return to “Plugins”

Who is online

Users browsing this forum: No registered users and 3 guests