how to stop from deluge from loading at boot

General support for problems installing or using Deluge
fred44nl
Member
Member
Posts: 18
Joined: Mon Feb 20, 2017 10:59 am
OS or Distro: Raspbian

how to stop from deluge from loading at boot

Postby fred44nl » Thu Aug 02, 2018 8:47 am

hi,
I have installed Deluge successfully on my Debian machine.
but I do not use it all the time, so I would like is not to start automatically, after re-booting.
when I do "sudo systemctl status deluged" it says:
"Loaded: loaded (/etc/systemd/system/deluged.service; disabled; vendor preset: enabled)"

so, how do I stop Deluge from starting automatically ??

mhertz
Seeder
Seeder
Posts: 158
Joined: Wed Jan 22, 2014 5:05 am
OS or Distro: Arch Linux

Re: how to stop from deluge from loading at boot

Postby mhertz » Thu Aug 02, 2018 9:35 am

sudo systemctl disable deluged

Start/stop on demand: sudo systemctl start/stop deluged (or simply deluged/deluge-console halt(or pkill deluged))

man systemctl ;)

fred44nl
Member
Member
Posts: 18
Joined: Mon Feb 20, 2017 10:59 am
OS or Distro: Raspbian

Re: how to stop from deluge from loading at boot

Postby fred44nl » Thu Aug 02, 2018 9:45 am

mhertz wrote:sudo systemctl disable deluged


yes, ok, but deluged was never enabled with systemctl
and doing a systemctl disable did not help.
could this come from deluge-web.service starting at boot ??

mhertz
Seeder
Seeder
Posts: 158
Joined: Wed Jan 22, 2014 5:05 am
OS or Distro: Arch Linux

Re: how to stop from deluge from loading at boot

Postby mhertz » Thu Aug 02, 2018 12:33 pm

Sorry, I thought debian like most distros(thankfully not mine) always enables all services of the apps you install, so would be enabled by default. There are two services with deluge; deluged and deluge-web and if both these are disabled by you and still restart at next boot, then sorry I don't know how they could? ('disable' doesn't stop a service from current running session and needs 'stop' for that additionally)

You can check all set to start at boot with:

systemctl list-unit-files --state=enabled

fred44nl
Member
Member
Posts: 18
Joined: Mon Feb 20, 2017 10:59 am
OS or Distro: Raspbian

Re: how to stop from deluge from loading at boot

Postby fred44nl » Thu Aug 02, 2018 4:07 pm

"systemctl list-unit-files --state=enabled" says:
deluge-web.service enabled
"systemctl list-unit-files --state=disabled" says:
deluged.service disabled

mhertz
Seeder
Seeder
Posts: 158
Joined: Wed Jan 22, 2014 5:05 am
OS or Distro: Arch Linux

Re: how to stop from deluge from loading at boot

Postby mhertz » Thu Aug 02, 2018 5:11 pm

Yes, deluge-web is enabled and needs disabling by you manually. It has a 'wants' directive of 'deluged.service' so will run that as dependency even though that(deluged-service) isn't specifically enabled.

Code: Select all

sudo systemctl disable deluge-web


If wanting it also stopped from current session:

Code: Select all

sudo systemctl stop deluge-web
Last edited by mhertz on Thu Aug 02, 2018 5:19 pm, edited 1 time in total.

fred44nl
Member
Member
Posts: 18
Joined: Mon Feb 20, 2017 10:59 am
OS or Distro: Raspbian

Re: how to stop from deluge from loading at boot

Postby fred44nl » Thu Aug 02, 2018 5:18 pm

ok, thank you


Return to “Support”

Who is online

Users browsing this forum: No registered users and 3 guests