Deluge not working after PIA update

Specific support for Deluge on Microsoft Windows OS
guyinasuit
New User
New User
Posts: 3
Joined: Sat Jun 23, 2018 8:48 pm
OS or Distro: Windows 7

Deluge not working after PIA update

Postby guyinasuit » Sat Jun 23, 2018 8:54 pm

Hi, I just updated PIA to the newest version (81, I think), and all of a sudden nothing in Deluge will download. Anything I add to Deluge refuses to make any connections. This happened immediately after updating to the new version of PIA, but since everything else is working fine, PIA wouldn't help at all with the issue. I've tried several different PIA servers, reinstalling both Deluge and PIA, and nothing works. I also tried using Qbittorrent, and it works just fine with the new PIA. Deluge is the only client having the issue. Any idea why this is happening? I'm on Windows 7.
Last edited by guyinasuit on Sun Jun 24, 2018 6:15 pm, edited 1 time in total.

mhertz
Seeder
Seeder
Posts: 158
Joined: Wed Jan 22, 2014 5:05 am
OS or Distro: Arch Linux

Re: Deluge not working after PIA update

Postby mhertz » Sun Jun 24, 2018 3:16 pm

I'm not 100% sure, but I just googled a little, and PIA's v81 client has some new special changes, so possibly try if this fixes your issue:

1. Go into advanced settings
2. Toggle the 'Allow LAN' switch to on.

guyinasuit
New User
New User
Posts: 3
Joined: Sat Jun 23, 2018 8:48 pm
OS or Distro: Windows 7

Re: Deluge not working after PIA update

Postby guyinasuit » Sun Jun 24, 2018 6:14 pm

mhertz wrote:I'm not 100% sure, but I just googled a little, and PIA's v81 client has some new special changes, so possibly try if this fixes your issue:

1. Go into advanced settings
2. Toggle the 'Allow LAN' switch to on.


Thanks. I did try this, but nothing changed.

mhertz
Seeder
Seeder
Posts: 158
Joined: Wed Jan 22, 2014 5:05 am
OS or Distro: Arch Linux

Re: Deluge not working after PIA update

Postby mhertz » Sun Jun 24, 2018 9:06 pm

Oh, i'm sorry, never mind me then, and sorry for meddling :) Unfortunately you'll have to either revert to previous working version, or you could also e.g. change over to using the openvpn client instead, which I personally prefer to use, as it's much lighter and faster starting-up.

guyinasuit
New User
New User
Posts: 3
Joined: Sat Jun 23, 2018 8:48 pm
OS or Distro: Windows 7

Re: Deluge not working after PIA update

Postby guyinasuit » Mon Jun 25, 2018 9:56 pm

mhertz wrote:Oh, i'm sorry, never mind me then, and sorry for meddling :) Unfortunately you'll have to either revert to previous working version, or you could also e.g. change over to using the openvpn client instead, which I personally prefer to use, as it's much lighter and faster starting-up.


No worries at all! Thanks for the help. I'm going to try the openvpn client and see if that does anything to help.

Wilsondrake
New User
New User
Posts: 3
Joined: Fri Jul 20, 2018 1:35 pm
OS or Distro: Distro

Re: Deluge not working after PIA update

Postby Wilsondrake » Fri Jul 20, 2018 1:41 pm

PIA is just pulling a lot of glitches for Windows and Distro both!


Return to “Windows OS”

Who is online

Users browsing this forum: Google [Bot] and 1 guest