libtorrent not in deluge-team ubuntu ppa for armhf

General support for problems installing or using Deluge
Post Reply
voltairine

libtorrent not in deluge-team ubuntu ppa for armhf

Post by voltairine »

Code: Select all

$ awk '$1 == "Package:" { print $2 }' /var/lib/apt/lists/ppa*deluge*armhf_Packages
deluge-torrent
libtorrent-rasterbar-doc
deluge-common
deluge-console
deluge-webui
deluge
deluge-web
deluged
deluge-gtk
In at least deluge-team's Xenial source, libtorrent-rasterbar8 is in the i386 ppa but not the armhf ppa, so when I go to update packages, I only see the official Ubuntu release and not the deluge-team ppa
huntman_day
New User
New User
Posts: 8
Joined: Sun Jul 03, 2016 7:35 pm

Re: libtorrent not in deluge-team ubuntu ppa for armhf

Post by huntman_day »

Yup, same issue. I'm needing to upgrade libtorrent and the highest version available for armhf is 1.0.7.

I've already tried compiling libtorrent from source, but it doesn't do anything since deluge uses the package from the repo's, not my source install. Help!
shamael
Compulsive Poster
Compulsive Poster
Posts: 643
Joined: Sat Oct 08, 2016 9:28 am

Re: libtorrent not in deluge-team ubuntu ppa for armhf

Post by shamael »

Report it to PPA or by a ticket here. I used to compile it myself, no error with the binding using the wiki on this site (even with multiple version installed). I'm currently using the trusty branch on a Debian and all are present for armhf, you can maybe give it a try for the libtorrent package.
huntman_day
New User
New User
Posts: 8
Joined: Sun Jul 03, 2016 7:35 pm

Re: libtorrent not in deluge-team ubuntu ppa for armhf

Post by huntman_day »

shamael wrote:Report it to PPA or by a ticket here. I used to compile it myself, no error with the binding using the wiki on this site (even with multiple version installed). I'm currently using the trusty branch on a Debian and all are present for armhf, you can maybe give it a try for the libtorrent package.
When I compiled it, it appeared to be clashing with the Ubuntu repository release and caused Deluge to be stuck in a constant "Queued" state for torrents. Uninstalling my compiled libtorrent fixed that issue, but I'm still in the same place right now. I used http://dev.deluge-torrent.org/wiki/Building/libtorrent wiki, which binding wiki did you use? Mind pointing me to the trusty branch PPA you mentioned that has armhf present? Thank you!

EDIT: Where can I report the issue to the PPA itself, or open a ticket here? New forum user, apologies. Thanks.
shamael
Compulsive Poster
Compulsive Poster
Posts: 643
Joined: Sat Oct 08, 2016 9:28 am

Re: libtorrent not in deluge-team ubuntu ppa for armhf

Post by shamael »

I used the same, last compiled Libtorrent was the one associated with Deluge. You can always try to first remove+purge all libtorrent version prior building the new one.

Concerning the PPA: you can force the version used by following the Debian wiki http://dev.deluge-torrent.org/wiki/Inst ... ian/Jessie. I cannot guarantee it will work so test it first or wait for a ticket answer about the lack of armhf version in PPA.

Maybe useful: as I compiled Deluge/libtorrent prior relying on trusty PPA for my Debian I made a script removing all trace of compiled Deluge. Check the last part of my post http://forum.deluge-torrent.org/viewtop ... =7&t=54430.

Ticket creation: http://dev.deluge-torrent.org/report/1 (login needed to have the 'create ticket' tab)
Cas
Top Bloke
Top Bloke
Posts: 3643
Joined: Mon Dec 07, 2009 6:04 am
Location: Scotland

Re: libtorrent not in deluge-team ubuntu ppa for armhf

Post by Cas »

Trusty in PPA is built for armhf

Edit: At somepoint later today the rest of the releases will be updated too.
shamael
Compulsive Poster
Compulsive Poster
Posts: 643
Joined: Sat Oct 08, 2016 9:28 am

Re: libtorrent not in deluge-team ubuntu ppa for armhf

Post by shamael »

thx @Cas :)
huntman_day
New User
New User
Posts: 8
Joined: Sun Jul 03, 2016 7:35 pm

Re: libtorrent not in deluge-team ubuntu ppa for armhf

Post by huntman_day »

Fixed for me! Thanks a ton!
Post Reply