Autoconnect web UI to daemon

General support for problems installing or using Deluge
Xi0N
Member
Member
Posts: 48
Joined: Mon Oct 06, 2008 7:23 am

Autoconnect web UI to daemon

Postby Xi0N » Fri Sep 03, 2010 11:24 pm

Hi!
The thing is that i am using transdroid on android, to connect to my deluge server....

The point is that transdroid connects to the web UI, but, if the Web UI is not connected previously to the local daemon, you cannot see the transfer list....

My question is: Is there any way so the Web UI does not ask anymore for the daemon to connect to, and directly connect to the local one (Supossing there is only one running daemon in the local machine)?

Thanks!!!


EDIT: BTW Ubuntu LINUX headless server....

gazpachoking
Super Seeder
Super Seeder
Posts: 315
Joined: Sat Aug 18, 2007 2:28 pm
OS or Distro: WHS
Location: Pittsburgh, USA
Contact:

Re: Autoconnect web UI to daemon

Postby gazpachoking » Fri Sep 03, 2010 11:47 pm

Xi0N wrote:The point is that transdroid connects to the web UI, but, if the Web UI is not connected previously to the local daemon, you cannot see the transfer list....
My question is: Is there any way so the Web UI does not ask anymore for the daemon to connect to, and directly connect to the local one (Supossing there is only one running daemon in the local machine)?

Yep, I was having the same trouble for a while, but it turns out there is an option called "default daemon" in the web.conf file. Set it to "127.0.0.1:58846", (or whatever daemon you need,) and it will autoconnect.

Xi0N
Member
Member
Posts: 48
Joined: Mon Oct 06, 2008 7:23 am

Re: Autoconnect web UI to daemon

Postby Xi0N » Sat Sep 04, 2010 2:05 am

Looks like my ~/.config/deluge/web-ui.conf file gets overwritten everytime i restart------

I changed the option you said me, and upon the restart, it was back to default.... no default daemon...... why can this be?

Pavouk106
New User
New User
Posts: 4
Joined: Fri Dec 03, 2010 2:46 pm

Re: Autoconnect web UI to daemon

Postby Pavouk106 » Fri Dec 03, 2010 2:53 pm

Hello. Sorry to dig this thread, but I was also looking for solution of this problem. It is very simple. Just edit your web.conf as you wish (127.0.0.1:58846 as default daemon here) and then

Code: Select all

chmod 444 ~.config/deluge/web.conf


And voila - your configuration won't get overwritten everytime you start Deluged :-) At least it works on my Gentoo amd_64 system.

I came to this "solution" myself, never saw that in other thread on web (was searching for it for some time). I was thinking about everyrthing I could and it is so simple :-D Hope it helps to someone

Cas
Top Bloke
Top Bloke
Posts: 3557
Joined: Mon Dec 07, 2009 6:04 am
OS or Distro: Ubuntu 16.04
Location: Scotland

Re: Autoconnect web UI to daemon

Postby Cas » Fri Dec 03, 2010 3:10 pm

Did you shutdown Deluge before editing the conf files? Deluge will update the conf files on restart or shutdown.

Pavouk106
New User
New User
Posts: 4
Joined: Fri Dec 03, 2010 2:46 pm

Re: Autoconnect web UI to daemon

Postby Pavouk106 » Fri Dec 03, 2010 4:32 pm

Edit: Simple answer to your question - Deluge will not update my web.conf anymore, because it doesn't have permissions to do it. Earlier post right under this

Editted, chmodded, restarted deluged (/etc/init.d/deluged restart) -> worked fine -> rebooted PC -> works fine. Permissions for web.conf are still 444 and default daemon remained set on 127.0.0.1:58846 (no automatic rewrite).

I suppose 444 permissions won't let Deluge to rewrite entire file with new one or to edit any options. At least it should work that way and it works for me. I can reboot my PC and connect to it using Transdroid and no "Client isn't connected to daemon" message anymore - normal torrent listing just like as it should be.

Cas
Top Bloke
Top Bloke
Posts: 3557
Joined: Mon Dec 07, 2009 6:04 am
OS or Distro: Ubuntu 16.04
Location: Scotland

Re: Autoconnect web UI to daemon

Postby Cas » Fri Dec 03, 2010 7:24 pm

I am well aware of how permissions work. My point is that this it is all unnecessary.

Simply stop deluge-web, edit the conf file and restart deluge-web. The settings will not be overwritten.

Pavouk106
New User
New User
Posts: 4
Joined: Fri Dec 03, 2010 2:46 pm

Re: Autoconnect web UI to daemon

Postby Pavouk106 » Mon Dec 06, 2010 10:21 am

Ah, I see the point now. I should try it that way ;-) Thanks for tip

webaake
Member
Member
Posts: 16
Joined: Wed May 30, 2007 6:58 am

Re: Autoconnect web UI to daemon

Postby webaake » Sat Apr 02, 2011 7:26 am

Seems to work fine here with transdroid and deluge 1.3.1. I stopped the daemon and killed the web ui manually since the init script doesn't. Then restarted the init script and all was ok!

Thx!

3miell

Re: Autoconnect web UI to daemon

Postby 3miell » Fri Feb 15, 2013 8:02 am

hi
my problem is when i change default port deluged daemon from 58846 to 58845 ( or other else try with 58844 an give up ) Web UI don't wanna auto-connect to deluged daemon

from "http://dev.deluge-torrent.org/wiki/Faq#HowdoIauto-connecttoaspecificdaemon"
i edit in file "web.conf" when deluged daemon and deluge web is not running

Code: Select all

from
"default_daemon": ""
to
"default_daemon": "127.0.0.1:58845",

it doesn't work with transdroid :( always have notice " Web UI is not connected with service daemon " " error during connection with server " ( this 2 quotes i translate from polish cos i'm polish user so my default android language is also polish , cant find to change it in transdroid )

at standard port its working fantastic so i go back to it, but where is the problem when i chagne port :( ?
I WANNA USE NOT DEFAULT PORT DELUGED DAEMON and I WANNA USE AUTO CONNECT in/at WebUI at MY SPECIFIC PORT

PS. sorry for my English , spelling should be good cos i use auto spelling check in chrome/chromium

here is my deluge-daemon init.d script if u need http://wklej.org/id/956367/?hl=bash ( polish site like paste bin )


Return to “Support”

Who is online

Users browsing this forum: No registered users and 4 guests