Raspberry Pi 5 >> Deluge >> Port Issue >> Test Active Port .!.

General support for problems installing or using Deluge
Post Reply
User avatar
mogabyte
New User
New User
Posts: 4
Joined: Sun Feb 11, 2024 8:27 pm

Raspberry Pi 5 >> Deluge >> Port Issue >> Test Active Port .!.

Post by mogabyte »

Hello everybody

I bought a Raspberry Pi 5 and the installation of Pi OS Ver. 12 Bookworm went well.

But after installing Deluge I can't add torrents, in the bottom right corner the following message "Port Issue" appears. :o

By clicking "Port Issue". Go to the "Network" menu where a "Test Active Port" button appears and an exclamation mark :!: .

I have a Raspberry Pi 400 the same installation with Deluge and it works 100% :D

Any solution :?: :?: :?:
User avatar
ambipro
Moderator
Moderator
Posts: 405
Joined: Thu May 19, 2022 3:33 am
Contact:

Re: Raspberry Pi 5 >> Deluge >> Port Issue >> Test Active Port .!.

Post by ambipro »

You need to configure your network (router most likely) to be forwarded.

This isn't a Deluge thing....it's a network thing.

Im not sure from your description of "I can't add torrents" if this is related to the Port Issue though....you don't really give any details
User avatar
mogabyte
New User
New User
Posts: 4
Joined: Sun Feb 11, 2024 8:27 pm

Re: Raspberry Pi 5 >> Deluge >> Port Issue >> Test Active Port .!.

Post by mogabyte »

Hi, ambipro

As said above, I have a Raspberry Pi 400 on the same network, same configuration and with the same installation and it is working 100%.

When I add the torrents the following message appears: "Please wait for files..." after "Unable to download files for this magnet".

I click on "add", the torrent appears but does not add seeds or start the download.

I've tried with several torrents, same problem.
shinger
Leecher
Leecher
Posts: 82
Joined: Sat Jun 05, 2010 1:02 pm

Re: Raspberry Pi 5 >> Deluge >> Port Issue >> Test Active Port .!.

Post by shinger »

Hi mogabyte,

It is ALWAYS important to see what the reality is and not what you think how reality is. Even though you see a setting in a configuration has been turned on, look at the reality if it is indeed turned on. I speak with experience as an Linux Engineer in my corporate life.

Could you do a ss -tulpn | grep deluged. This is to determine what kind of ports deluged is listening on.

It will look something like this.

Code: Select all

<USER>@<SYSTEM>:# ss -tulpn | grep deluged
udp   UNCONN 0      0                <IPADDRESS>:54988      0.0.0.0:*    users:(("deluged",pid=282459,fd=23))                                                     
udp   UNCONN 0      0                      0.0.0.0:6771       0.0.0.0:*    users:(("deluged",pid=282459,fd=18))                                                     
udp   UNCONN 0      0                      0.0.0.0:6771       0.0.0.0:*    users:(("deluged",pid=282459,fd=17))                                                     
udp   UNCONN 0      0                <IPADDRESS>:1900       0.0.0.0:*    users:(("deluged",pid=282459,fd=20))                                                     
udp   UNCONN 0      5888   <IPADDRESS>%enP4p65s0:60407      0.0.0.0:*    users:(("deluged",pid=282459,fd=14))                                                     
udp   UNCONN 0      0                 127.0.0.1%lo:60407      0.0.0.0:*    users:(("deluged",pid=282459,fd=12))                                                     
udp   UNCONN 0      0                <IPADDRESS>:45431      0.0.0.0:*    users:(("deluged",pid=282459,fd=19))                                                     
tcp   LISTEN 0      50                     0.0.0.0:58846      0.0.0.0:*    users:(("deluged",pid=282459,fd=22))                                                     
tcp   LISTEN 0      3000   <IPADDRESS>%enP4p65s0:60407      0.0.0.0:*    users:(("deluged",pid=282459,fd=13))                                                     
tcp   LISTEN 0      3000              127.0.0.1%lo:60407      0.0.0.0:*    users:(("deluged",pid=282459,fd=10))
From here on, are you sure on the router side portforwarding has been enabled? Or are you using UPNP? In my case for example i use upnp.

This is on my router (i use OpenWRT with miniupnp as the OS for my Router)

Active UPnP Redirects

Code: Select all

<USER>@<ROUTER>:~# cat /tmp/run/miniupnpd.leases 
TCP:60407:<IPADDRESS DELUGE SYSTEM>:60407:1707758209:Deluge/2.1.1 libtorrent/2.0.5.0
UDP:60407:<IPADDRESS DELUGE SYSTEM>:60407:1707758209:Deluge/2.1.1 libtorrent/2.0.5.0
So now you can see the clear process of traffic coming through my router on port 60407 and being send to my deluge system with port 60407 and my deluge system is listening on that ipadress with interface and port 60407 with both protocols (udp & tcp)
===============================================================
Server: Rock 5B 8 Cores (ARM), 16 GB RAM, 2 TB 970 Evo +
OS: Linux Ubuntu 22.04 LTS
Deluge: v2.1.1
Plugins: Blocklist, LabelPlus, ItConfig, MyScheduler, Stats, Notifications, YaRSS2
User avatar
ambipro
Moderator
Moderator
Posts: 405
Joined: Thu May 19, 2022 3:33 am
Contact:

Re: Raspberry Pi 5 >> Deluge >> Port Issue >> Test Active Port .!.

Post by ambipro »

For verification that the port is open, if you think you have forwarded the port you can use https://portchecker.io to verify this.

If it say it is not open, it is not open.
User avatar
mogabyte
New User
New User
Posts: 4
Joined: Sun Feb 11, 2024 8:27 pm

Re: Raspberry Pi 5 >> Deluge >> Port Issue >> Test Active Port .!.

Post by mogabyte »

in my router the portforwarding enabled

https://files.fm/u/74d7n8phev

in my Raspberry Pi 5

Code: Select all

pi@raspberrypi5:~ $ ss -tulpn | grep deluge 
udp   UNCONN 0      0                        127.0.0.1:54679      0.0.0.0:*    users:(("deluge-gtk",pid=4219,fd=24))      
udp   UNCONN 0      0                          0.0.0.0:6771       0.0.0.0:*    users:(("deluge-gtk",pid=4219,fd=25))      
tcp   LISTEN 0      5                     127.0.0.1%lo:54679      0.0.0.0:*    users:(("deluge-gtk",pid=4219,fd=22))      
Not work
shinger
Leecher
Leecher
Posts: 82
Joined: Sat Jun 05, 2010 1:02 pm

Re: Raspberry Pi 5 >> Deluge >> Port Issue >> Test Active Port .!.

Post by shinger »

A few questions

- So you have installed a GUI (Desktop Enviornment) on your Raspberry Pi 5? In other words it is not headless.
- Does it have a firewall that is active? do a sudo ufw status in the terminal.

And from the output i dont see deluge-gtk listening on your raspberry pi 5 external ipaddress 192.168.1.40 on port 54679 or even 0.0.0.0:54679. Which would mean it will accept connections from all ipaddresses as long as it is on port 54679. Instead you see this 0.0.0.0:6771

Do you understand what i am trying to say?
===============================================================
Server: Rock 5B 8 Cores (ARM), 16 GB RAM, 2 TB 970 Evo +
OS: Linux Ubuntu 22.04 LTS
Deluge: v2.1.1
Plugins: Blocklist, LabelPlus, ItConfig, MyScheduler, Stats, Notifications, YaRSS2
User avatar
mogabyte
New User
New User
Posts: 4
Joined: Sun Feb 11, 2024 8:27 pm

Re: Raspberry Pi 5 >> Deluge >> Port Issue >> Test Active Port .!.

Post by mogabyte »

Code: Select all

pi@raspberrypi5:~ $ sudo ufw status
Status: active

To                         Action      From
--                         ------      ----
54679                      ALLOW       Anywhere                  
54679 (v6)                 ALLOW       Anywhere (v6)             
shinger
Leecher
Leecher
Posts: 82
Joined: Sat Jun 05, 2010 1:02 pm

Re: Raspberry Pi 5 >> Deluge >> Port Issue >> Test Active Port .!.

Post by shinger »

Can you see and understand that deluge is not listening on 192.168.1.40:54679. Even though the firewall is good, but you dont see the external ipaddress that is being listened to.

In my cause you do see. Every part that i removed that is called <IP ADDRESS> that is my 192.168..etc with even the name of the network interface enP4p65s0. So the problem lies with deluge and the configuration of it. Could you fill the Outgoing interface in the settings of deluge.

You can find the Outgoing interface by typing sudo ip -c a. The interface which the ipaddress 192.168.1.40 is visible under, that is your Outgoing interface.
===============================================================
Server: Rock 5B 8 Cores (ARM), 16 GB RAM, 2 TB 970 Evo +
OS: Linux Ubuntu 22.04 LTS
Deluge: v2.1.1
Plugins: Blocklist, LabelPlus, ItConfig, MyScheduler, Stats, Notifications, YaRSS2
Post Reply