Can't connected from client to server

General support for problems installing or using Deluge
sealse
New User
New User
Posts: 8
Joined: Fri Feb 07, 2020 9:47 pm

Can't connected from client to server

Postby sealse » Fri Feb 07, 2020 9:57 pm

I have on NAS D-Link DSL-320L deluge server
site-packages/1/deluge-1.3.900.dev0-py2.7.egg/deluge
Previously, there was a client on windows that worked perfectly through 58846 port
Now I have ubuntu version 5.3.18 and the client from repository does not see this server by the internal IP admin@192.168.1.104:58846
but

Code: Select all

nc -vz 192.168.1.104 58846
Connection to 192.168.1.104 58846 port [tcp/*] succeeded!

help plz?

sealse
New User
New User
Posts: 8
Joined: Fri Feb 07, 2020 9:47 pm

Re: Can't connected from client to server

Postby sealse » Mon Jan 25, 2021 11:06 am

Now I have ubuntu 20.10
I installed the PPA repository version 2.0.3 and still can't see the server on version 1.3
Maybe I should use version 1.3 for the client too. But tell me where to get it for ubuntu?

mhertz
Compulsive Poster
Compulsive Poster
Posts: 1065
Joined: Wed Jan 22, 2014 5:05 am
Location: Denmark

Re: Can't connected from client to server

Postby mhertz » Mon Jan 25, 2021 11:21 am

Yes, daemon and client needs be same major version number. A quick google search reveals instructions for this(getting deluge 1.3.15 on ubuntu's offering only deluge 2.0.3), and little further down in thread, verified instructions specifically for ubuntu 20.04: https://askubuntu.com/questions/1184176/how-to-install-specific-older-version-of-deluge-with-all-the-dependencies
Edit: Sorry, reread your post and mistook ubuntu 20.04 for 20.10 before, though try anyway as probably same instructions, or atleast very close to, as is just wget'ing old packages from bionic repo and apt installing them, and/or google it, e.g my posted link was second result where first was a reddit poster asking same question but unanswered(and I as said mistook your ubuntu version so searched for "ubuntu 20.04 how get deluge 1.3.15").
Last edited by mhertz on Mon Jan 25, 2021 2:28 pm, edited 2 times in total.

sealse
New User
New User
Posts: 8
Joined: Fri Feb 07, 2020 9:47 pm

Re: Can't connected from client to server

Postby sealse » Mon Jan 25, 2021 12:49 pm

Thanks for your answer, but by 20.10 this method unfortunately did not work. There are a lot of dependencies and not all of them can be found

Code: Select all

The following packages have unmet dependencies:
 deluge-common : Depends: python-openssl but it is not installable
                 Depends: python-chardet but it is not installable
                 Depends: python-xdg but it is not installable
 python-gtk2 : Depends: python-cairo (>= 1.0.2-1.1) but it is not installable
               Depends: python-gobject-2 (>= 2.21.3) but it is not installable
 python-twisted-core : Depends: python-zope.interface (>= 4.0.2) but it is not installable
                       Depends: python-automat (>= 0.6.0) but it is not installable
                       Depends: python-constantly but it is not installable
                       Depends: python-hyperlink but it is not installable
                       Depends: python-openssl but it is not installable
                       Depends: python-service-identity but it is not installable
                       Recommends: python-pam but it is not going to be installed
                       Recommends: python-serial but it is not installable


sealse
New User
New User
Posts: 8
Joined: Fri Feb 07, 2020 9:47 pm

Re: Can't connected from client to server

Postby sealse » Mon Jan 25, 2021 2:37 pm

after download

Code: Select all

sudo apt-get install ./*.deb
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'deluge-common' instead of './deluge-common_1.3.15-2_all.deb'
Note, selecting 'deluge-gtk' instead of './deluge-gtk_1.3.15-2_all.deb'
Note, selecting 'deluge' instead of './deluge_1.3.15-2_all.deb'
Note, selecting 'libboost-python1.65.1' instead of './libboost-python1.65.1_1.65.1+dfsg-0ubuntu5_amd64.deb'
Note, selecting 'libboost-system1.65.1' instead of './libboost-system1.65.1_1.65.1+dfsg-0ubuntu5_amd64.deb'
Note, selecting 'libtorrent-rasterbar9' instead of './libtorrent-rasterbar9_1.1.5-1build1_amd64.deb'
Note, selecting 'python-automat' instead of './python-automat_0.6.0-1_all.deb'
Note, selecting 'python-cairo' instead of './python-cairo_1.16.2-1_amd64.deb'
Note, selecting 'python-chardet' instead of './python-chardet_3.0.4-1_all.deb'
Note, selecting 'python-constantly' instead of './python-constantly_15.1.0-1_all.deb'
Note, selecting 'python-glade2' instead of './python-glade2_2.24.0-5.1ubuntu2_amd64.deb'
Note, selecting 'python-gobject-2' instead of './python-gobject-2_2.28.6-12ubuntu3_amd64.deb'
Note, selecting 'python-gtk2' instead of './python-gtk2_2.24.0-5.1ubuntu2_amd64.deb'
Note, selecting 'python-hyperlink' instead of './python-hyperlink_17.3.1-2_all.deb'
Note, selecting 'python-incremental' instead of './python-incremental_16.10.1-3_all.deb'
Note, selecting 'python-libtorrent' instead of './python-libtorrent_1.1.5-1build1_amd64.deb'
Note, selecting 'python-notify' instead of './python-notify_0.1.1-4_amd64.deb'
Note, selecting 'python-openssl' instead of './python-openssl_17.5.0-1ubuntu1_all.deb'
Note, selecting 'python-pam' instead of './python-pam_0.4.2-13.2ubuntu4_amd64.deb'
Note, selecting 'python-serial' instead of './python-serial_3.4-2_all.deb'
Note, selecting 'python-service-identity' instead of './python-service-identity_16.0.0-2_all.deb'
Note, selecting 'python-twisted-bin' instead of './python-twisted-bin_17.9.0-2ubuntu0.1_amd64.deb'
Note, selecting 'python-twisted-core' instead of './python-twisted-core_17.9.0-2ubuntu0.1_all.deb'
Note, selecting 'python-xdg' instead of './python-xdg_0.25-4ubuntu1.1_all.deb'
Note, selecting 'python-zope.interface' instead of './python-zope.interface_4.3.2-1build2_amd64.deb'
libboost-python1.65.1 is already the newest version (1.65.1+dfsg-0ubuntu5).
libboost-system1.65.1 is already the newest version (1.65.1+dfsg-0ubuntu5).
libtorrent-rasterbar9 is already the newest version (1.1.5-1build1).
python-incremental is already the newest version (16.10.1-3).
python-libtorrent is already the newest version (1.1.5-1build1).
python-twisted-bin is already the newest version (17.9.0-2ubuntu0.1).
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 python-automat : Depends: python-attr but it is not installable
 python-gobject-2 : Depends: libffi6 (>= 3.0.4) but it is not installable
 python-openssl : Depends: python-cryptography (>= 2.1.4) but it is not installable
 python-service-identity : Depends: python-attr but it is not installable
                           Depends: python-pyasn1 but it is not installable
                           Depends: python-pyasn1-modules but it is not installable
                           Recommends: python-idna but it is not installable
E: Unable to correct problems, you have held broken packages.

mhertz
Compulsive Poster
Compulsive Poster
Posts: 1065
Joined: Wed Jan 22, 2014 5:05 am
Location: Denmark

Re: Can't connected from client to server

Postby mhertz » Mon Jan 25, 2021 3:13 pm

I'm no ubuntu user, but quick search, and original instructions, states to use apt, or dpkg, not apt-get., reason being apt-get insists installing from net/cache, atleast with that flag. Maybe that's why your original attempt from my initial posted link with instructions, didn't work either, if using apt-get there also.

sealse
New User
New User
Posts: 8
Joined: Fri Feb 07, 2020 9:47 pm

Re: Can't connected from client to server

Postby sealse » Mon Jan 25, 2021 3:45 pm

sudo apt install ./*.deb
produces the same result

sealse
New User
New User
Posts: 8
Joined: Fri Feb 07, 2020 9:47 pm

Re: Can't connected from client to server

Postby sealse » Mon Jan 25, 2021 4:26 pm

@mhertz Thank's!!! I do it. Nex all need files for ubuntu 20.10

Code: Select all

  742654 Aug  1  2017 deluge-common_1.3.15-2_all.deb                         
  221688 Aug  1  2017 deluge-gtk_1.3.15-2_all.deb                             
   21042 Aug  1  2017 deluge_1.3.15-2_all.deb                                 
  100532 Mar  6  2018 libboost-python1.65.1_1.65.1+dfsg-0ubuntu5_amd64.deb   
   10520 Mar  6  2018 libboost-system1.65.1_1.65.1+dfsg-0ubuntu5_amd64.deb   
   17948 Jan 11  2018 libffi6_3.2.1-8_amd64.deb                               
   19688 Mar 24  2020 libffi7_3.3-4_amd64.deb                                 
 1258428 Feb  5  2018 libtorrent-rasterbar9_1.1.5-1build1_amd64.deb           
   72700 Dec 24  2017 python-asn1crypto_0.24.0-1_all.deb                     
   33796 Mar 29  2020 python-attr_19.3.0-2_all.deb                           
   25062 Sep  1  2017 python-automat_0.6.0-1_all.deb                         
   56392 Feb 21  2018 python-cairo_1.16.2-1_amd64.deb                         
   63436 Feb 28  2018 python-cffi-backend_1.11.5-1_amd64.deb                 
   80292 Jun 20  2017 python-chardet_3.0.4-1_all.deb                         
    7960 Nov  9  2016 python-constantly_15.1.0-1_all.deb                     
  197996 Jan 25 19:06 python-cryptography_1.2.3-1_amd64.deb                   
  219980 Mar  8  2018 python-cryptography_2.1.4-1ubuntu1.1_amd64.deb         
   34832 Nov 22  2017 python-enum34_1.1.6-2_all.deb                           
    8872 Nov 23  2017 python-glade2_2.24.0-5.1ubuntu2_amd64.deb               
  180000 Nov 23  2017 python-gobject-2_2.28.6-12ubuntu3_amd64.deb             
  181516 Feb 18  2020 python-gobject-2_2.28.6-14ubuntu1_amd64.deb             
  619344 Nov 23  2017 python-gtk2_2.24.0-5.1ubuntu2_amd64.deb                 
   27508 Sep  1  2017 python-hyperlink_17.3.1-2_all.deb                       
   32360 Jan 11  2018 python-idna_2.6-1_all.deb                               
   14434 Nov  4  2016 python-incremental_16.10.1-3_all.deb                   
   18182 Nov  2  2016 python-ipaddress_1.0.17-1_all.deb                       
  310776 Feb  5  2018 python-libtorrent_1.1.5-1build1_amd64.deb               
   15576 Oct 28  2014 python-notify_0.1.1-4_amd64.deb                         
   41332 Apr 12  2018 python-openssl_17.5.0-1ubuntu1_all.deb                 
    9856 Aug  4  2017 python-pam_0.4.2-13.2ubuntu4_amd64.deb                 
   20514 Oct  2  2015 python-pyasn1-modules_0.0.7-0.1_all.deb                 
   45072 Oct 24  2015 python-pyasn1_0.1.9-1_all.deb                           
   71908 Apr  9  2018 python-serial_3.4-2_all.deb                             
    9318 Feb 22  2016 python-service-identity_16.0.0-2_all.deb               
   14836 Mar 19  2020 python-twisted-bin_17.9.0-2ubuntu0.1_amd64.deb         
 2009172 Mar 19  2020 python-twisted-core_17.9.0-2ubuntu0.1_all.deb           
   31228 Jan 19 17:13 python-xdg_0.25-4ubuntu1.1_all.deb                     
   82226 Aug  5  2017 python-zope.interface_4.3.2-1build2_amd64.deb           
  220380 Nov  3 16:03 python3-cryptography_2.1.4-1ubuntu1.4_amd64.deb         

mhertz
Compulsive Poster
Compulsive Poster
Posts: 1065
Joined: Wed Jan 22, 2014 5:05 am
Location: Denmark

Re: Can't connected from client to server

Postby mhertz » Mon Jan 25, 2021 4:49 pm

Thank you too, for posting the full list of needed files, plus saving me some time firering up a ubuntu 20.10 livecd up for troubleshooting this :D


Return to “Support”

Who is online

Users browsing this forum: Bing [Bot] and 10 guests