v2 under FreeBSD: lookin' GOOD!

General support for problems installing or using Deluge
cbrace
Member
Member
Posts: 35
Joined: Thu Jan 31, 2019 4:09 pm
Location: Amsterdam

Re: v2 under FreeBSD: lookin' GOOD!

Postby cbrace » Mon May 18, 2020 3:58 am

Thanks for the update. Specifying an incoming port should work there. I have an instance of 2.0.3 running under Fedora and that works fine. It is, ah... kinda indispensable for using deluge with a VPN. Will experiment here...

cross
Member
Member
Posts: 17
Joined: Fri May 08, 2015 3:15 am

Re: v2 under FreeBSD: lookin' GOOD!

Postby cross » Tue May 26, 2020 10:50 pm

Yeah. To be fair, though, it seems that UPNP works, so as long as I configure my router to allow for that, it seems functional.

cbrace
Member
Member
Posts: 35
Joined: Thu Jan 31, 2019 4:09 pm
Location: Amsterdam

Re: v2 under FreeBSD: lookin' GOOD!

Postby cbrace » Sat Aug 15, 2020 2:47 pm

After some delay, I can now report that I have just now upgrade an v1 instance to v2 running under FreeBSD simply by upgrading the port. All existing torrents were automatically migrated. Many thanks to whoever implemented this functionality.

antking
Member
Member
Posts: 10
Joined: Sat Oct 08, 2016 1:36 pm

Re: v2 under FreeBSD: lookin' GOOD!

Postby antking » Mon Oct 12, 2020 3:28 am

Sorry to come in on this late but I'm having trouble getting this working.
I selected random incoming ports however is still won't connect to the outside world.
Everything else in my Jail is working but I just can't get Deluge to connect to DL a torrent.
Ask me anything and I'll try to answer I not the best at this.

Please Help!!!!
Last edited by antking on Mon Oct 12, 2020 6:37 pm, edited 1 time in total.

cbrace
Member
Member
Posts: 35
Joined: Thu Jan 31, 2019 4:09 pm
Location: Amsterdam

Re: v2 under FreeBSD: lookin' GOOD!

Postby cbrace » Mon Oct 12, 2020 5:32 am

First, try to get deluge working outside the jail. (Disclaimer: I have no experience with FreeBSD jails and I don't understand why one would be needed for deluge)

Second, unless you are connected directly to the Internet (no router, no firewall), you need to deactivate "random incoming ports" and use a fixed port number, with the corresponding port-forwarding rule configured in your router or firewall (or VPN).

antking
Member
Member
Posts: 10
Joined: Sat Oct 08, 2016 1:36 pm

Re: v2 under FreeBSD: lookin' GOOD!

Postby antking » Mon Oct 12, 2020 3:32 pm

Thank you for responding,
I have deluge in a jail so if something goes wrong I would not lose my whole system.
I unchecked the use random ports and made sure that the ports on my router are forwarded.
There is no firewall that I'm aware of between my NAS (my FreeBSD system) and the router and internet.
I'm able to ping google from with in the jail and all other programs Sonarr, Radarr and Jackett are able to connect to the internet and pull any information needed. I'm completely stomped on this.

cbrace
Member
Member
Posts: 35
Joined: Thu Jan 31, 2019 4:09 pm
Location: Amsterdam

Re: v2 under FreeBSD: lookin' GOOD!

Postby cbrace » Mon Oct 12, 2020 3:59 pm

One thing comes to mind: make sure deluge is listening on the correct network interface. By default this is any or all (I think) but deluge can be instructed to listen only to one specific interface; this is useful for those of us using a VPN. This can be configured both in the settings notebook as well as in the config file (.config/deluge/core.conf). The line in the latter is:

Code: Select all

"listen_interface": "xxx.xxx.xxx.xxx",

If an IP number is displayed there, make sure it is the IP number assigned to the active network interface, however exactly that may work in a jail. I believe you can leave it empty if you are not using a VPN or doing anything else special.

HTH

antking
Member
Member
Posts: 10
Joined: Sat Oct 08, 2016 1:36 pm

Re: v2 under FreeBSD: lookin' GOOD!

Postby antking » Mon Oct 12, 2020 4:56 pm

Okay I just did that and added the IP address for the jail and where it would normally say
Tracker Status: Error: No route to host it now says
Tracker Status: Announce OK
I'm going to recheck the ports again and report back this is the most movement I've seen since I had to upgrade 2 weeks ago.

cbrace
Member
Member
Posts: 35
Joined: Thu Jan 31, 2019 4:09 pm
Location: Amsterdam

Re: v2 under FreeBSD: lookin' GOOD!

Postby cbrace » Mon Oct 12, 2020 5:13 pm

You probably know this already, but just in case: in the GTK version (not the web interface) go to Preferences --> Network, you should see a button: Test active port. Click on it and it will let you know whether port forwarding is working OK. If so you should now be good to go.

antking
Member
Member
Posts: 10
Joined: Sat Oct 08, 2016 1:36 pm

Re: v2 under FreeBSD: lookin' GOOD!

Postby antking » Mon Oct 12, 2020 5:38 pm

IT WORKED!!!
I tried to do a port check but it still says the port is closed but it did connect to the tracker and finish a DL. I'm going to try another one and see if I can find out whats happening.


Return to “Support”

Who is online

Users browsing this forum: No registered users and 12 guests