IP issue?

General support for problems installing or using Deluge
slvrdragn
Member
Member
Posts: 36
Joined: Tue Dec 12, 2017 4:50 pm

Re: IP issue?

Postby slvrdragn » Mon Mar 16, 2020 6:43 pm

Annnd i got borked again by tumbleweed.
Py3 went to 3.8, so 1.2.3 breaks stuff now as it looks for 3.7
I'll keep poking at it, just wanted to update the thread.

slvrdragn
Member
Member
Posts: 36
Joined: Tue Dec 12, 2017 4:50 pm

Re: IP issue?

Postby slvrdragn » Fri Apr 24, 2020 7:39 pm

I'm still having this issue, and seems like until 1.2.5 is released and built, i'm stuck :(
downgrading broke when tumbleweed went to 3.8.2 for pythong.

slvrdragn
Member
Member
Posts: 36
Joined: Tue Dec 12, 2017 4:50 pm

Re: IP issue?

Postby slvrdragn » Sun Jul 05, 2020 10:14 pm

so once the python package updated and broke the packages I downgrade, I've been waiting for 1.2.5 or higher to release and it seems that the software for 1.2.7 released but no one has built a libtorrent package for opensuse against it yet.

deluge is dead on my system until that happens I guess lol

mhertz
Compulsive Poster
Compulsive Poster
Posts: 865
Joined: Wed Jan 22, 2014 5:05 am
Location: Denmark

Re: IP issue?

Postby mhertz » Mon Jul 06, 2020 12:02 am

Sorry to hear you're still struggling with this.

Only thing I will add, is that in meantime maybe you could use this: https://github.com/userdocs/python-libt ... repository

Granted it's for Debian, but should be a static build of the libtorrent bindings, with libtorrent 1.2.7 and boost included, used with deluge2 from pypi(pip install deluge) so would only need python3 as dep, but don't know if it's somehow incompatible with non-debian installs, but sound like a viable workaround in-meantime, at-least to me.

Alternatively, then higher up in that link there's also a script for building this from scratch, though still Debian focused, but should be adaptable to your platform pretty easily(only thing i'm thinking is that it checks for missing deps with apt, so delete that part, and just install deps first before running it), but might as well firstly test out the pre-built versions, as per link provided.

Just a thought :)

Edit: For GTK-UI working with above, you need python-cairo and python-gobject installed, or whatever called on your distro, or alternatively, you could download and use the wheels I built little time ago of these, and install with 'pip install PathToWheel'(add '--user' after 'install' if having used '--user' also when installing 'deluge') and wheels available for both python 3.7 and 3.8: http://s000.tinyupload.com/index.php?fi ... 1773264450

Edit2: BTW, do you have any noticeable detrimental effects from your current libtorrent in deluge, other than UIs stating n/a for IP and lots UDP traffic when monitoring? I ask because I see often also n/a for IP in UIs(both with and without namespace tun0 lockdown), but works fine, so don't think that is a problem except cosmetically, and uTP and UDP trackers are preferred over TCP in libtorrent by default, plus DHT shows alot UDP traffic too, so was just thinking if there actually is an issue with your current setup? E.g can you successfully run the ipmagnet test to show announce IP, as that is specifically using TCP for tracker announcing: https://ipmagnet.tap3.eu


Return to “Support”

Who is online

Users browsing this forum: No registered users and 14 guests