Page 1 of 1

python installed but missing?

Posted: Sun Oct 04, 2020 1:28 am
by tstuart
I'm trying to use plugins with deluge(auto-remove and/or auto-extractors). I believe I have the python 3 versions but I cannot get them to even show up in the webUI.
Tried importing useing webUI's plugin install and tried just dropping the .egg file into the .config folder and restarting the deluge daemon.
I think my issue is around python. In the plugins wiki it says run python --version.
When I do this I get:
Command 'python' not found, did you mean:

command 'python3' from deb python3
command 'python' from deb python-is-python3

I'm guessing my issue is something around python3 not being setup with a shortcut to the proper name. but am wondering how I should be setting this up to be done properly? With the end goal being I can add new plugins

Re: python installed but missing?

Posted: Fri Nov 06, 2020 8:32 am
by benba
run

Code: Select all

python3 --version


And then rename your plugins according the python version displayed