Can't activate Deluge WebAPI plug-in for Organizr integration

Suggest, post, or discuss plugins for Deluge
kiwitech62
New User
New User
Posts: 3
Joined: Wed Apr 29, 2020 1:10 pm

Can't activate Deluge WebAPI plug-in for Organizr integration

Postby kiwitech62 » Wed Apr 29, 2020 1:16 pm

Hi. I am trying to integrate Deluge into Organizr so it shows the download queue on the Organizr Home Page. Unfortunately I'm having a problem as I am unable to activate the WebAPI plugin in Deluge which is needed by Organizr in order to display on the Home Page. It displays fine in a tab. I have NZBGet displaying fine for NZB downloads and would like to display torrents as well.

I'm running Plex and the other usual support apps, eg. Radarr, Sonarr, Lidarr, etc. on a Windows 10 computer, and have the following versions installed:

Organizr: 2.0.408
Deluge: 1.3.15
Python: 2.7

I have tried installing the following plug-in versions and they show in the list of available plugins, but when I tick it to try and enable it, nothing happens, and after going OK then checking again it's unticked and not activated.

Versions:
deluge_webapi-0.2.1-py2.7.egg
deluge_webapi-0.3.1-py2.7.egg
deluge_webapi-0.3.2-py2.7.egg
deluge_webapi-0.4.0-py3.6.egg
WebAPI-0.3.1-py2.7.egg
WebAPI-0.3.2-py2.7.egg
WebAPI-0.4.0-py3.6.egg
WebAPI-0.4.0-py3.7.egg

I realise some of them are for different versions of Python but the ones I had hoped would work didn't so I just tried them anyway. I also tried installing Python v3.6 and v3.7 to see if that might've helped, but no luck.

I do have the AutoRemovePlus-0.6.1-py2.7.egg plugin installed and working OK.

I also tried downloading deluge-2.0.3 and deluge-2.0.4.dev24 and they installed fine but I couldn't get any of the plugin versions to install on them, and also couldn't get any version of the AutoRemovePlus plug-in to install.

I could change to one of the other torrent downloaders but I've been happy with Deluge so far and it's working fine connected to Radarr, Sonarr and Lidarr so would be happy to continue using it. However if I can't resolve the integration into Organizr I may re-evaluate things.

Hopefully someone can provide some help to resolve my issue.

mhertz
Compulsive Poster
Compulsive Poster
Posts: 783
Joined: Wed Jan 22, 2014 5:05 am
Location: Denmark

Re: Can't activate Deluge WebAPI plug-in for Organizr integration

Postby mhertz » Wed Apr 29, 2020 5:31 pm

I just tested your issue of getting the two plugins to enable, and so here's the links for working versions, and I included links for unofficial deluge 2.0.x, since you mentioned also it didn't work there.

Deluge 1.3.15 (py2.7, the first/top installer in the list of windows installers):

Webapi:
https://github.com/idlesign/deluge-weba ... -py2.7.egg

Autoremoveplus:
https://github.com/omaralvarez/deluge-a ... -py2.7.egg

Unofficial Deluge 2.0.x (needs new'ish install as autoremoveplus support was added about 2 weeks ago only):

Webapi (needs renaming filename from ending in "py3.7.egg" to "py3.8.egg"):
https://github.com/idlesign/deluge-weba ... -py3.7.egg

Autoremoveplus (fork supporting deluge2, but not supporting configuration from GTKUI yet, and currently needs be configured in webUI or directly in config-file, but should work still in all UIs after being configured or config-file available, and can be enabled in all UIs also):
https://github.com/springjools/deluge-a ... -py3.8.egg

kiwitech62
New User
New User
Posts: 3
Joined: Wed Apr 29, 2020 1:10 pm

Re: Can't activate Deluge WebAPI plug-in for Organizr integration

Postby kiwitech62 » Thu Apr 30, 2020 8:16 am

Thanks for your helpful response. Unfortunatly I still haven't been able to get the webapi installed and enabled on either the Deluge 1.3.15 version or the 2.0 version.

I downloaded the Deluge 1.3.15 from the link you provided, along with the two plug-in .egg files and tried installing them. The AutoRemovePlus one was the same as the one I had been using so it works OK, but the WebAPI one doesn't show up after installing it so unable to be enabled.

I notice there is a webapi.cof file in the %appdata%\deluge folder which has the following content:

{
"file": 1,
"format": 1
}{
"enable_cors": false,
"allowed_origin": []
}

Thought I'd try the Deluge 2.0 version again, so after backing up the %appdata%\deluge folder, I downloaded the latest version I could find (deluge-2.0.4.dev37.exe) and installed that over my existing Deluge installation. I also installed both the 32-bit and 64-bit version of Python 3.8.2 as I wasn't sure which version is required. Deluge 2.0 recognized the partially downloaded files I had running and seems to run OK so I tried installing the Autoremoveplus and Webapi plug-ins, and renamed the Webapi file as specified ,with the 'py3.8.egg' ending on the filename.

Autoremoveplus installed OK, and I see the difference between using the WebUI and the GTKUI - can only access the configuration page through the WebUI. However the Webapi plugin didn't install and does the same as it did for the older Deluge version - both through the GTKUI and WebUI. When I try and install it using the WebUI it shows [object FileList] in the file select field. In the GTKUI it does nothing. In both UI's it doesn't show up in the list of plug-ins so can't be selected.

I also tried clean installations of both versions on a different computer with the same results.

Appreciate any further help you can offer.

mhertz
Compulsive Poster
Compulsive Poster
Posts: 783
Joined: Wed Jan 22, 2014 5:05 am
Location: Denmark

Re: Can't activate Deluge WebAPI plug-in for Organizr integration

Postby mhertz » Thu Apr 30, 2020 8:39 am

Sorry, install plugins by manually moving the egg files into the plugins folder in your deluge profile folder and (re-)start deluge(d/-web) and select to enable them(plugins). In my test of getting this working, then I only used GTKUI to enable the plugins, and no other UI, though should be the same presumably.

I've seen that issue reported before with [object FileList] or whatever, so seemingly theres sometimes issues with using the plugin install mechanism in some(/all?) UIs, so therefore might as well subtract that part from the equation and install plugins manually imho(also I've always done that anyways regardless).

If still a no-go for webapi plugin, then as a test, rename your deluge profile folder to e.g have a '-bak' ending, and make a new folder there, named deluge, and make another subfolder in there named 'plugins' and copy your webapi plugin into that, and then start deluge and see if you can select to enable the webapi plugin now, just as test to rule out anything in your profile folder disturbing something. Delete the test profile folder afterwards, and rename back original profile folder.

Note, always make sure everything is closed and restarted when testing above i.e the ones you have running of deluge, deluged and/or deluge-web, needs be stopped and restarted when testing to enable a plugin.

BTW, you don't need installing python with either the official or unofficial installers, as own private copy included/embedded already.

kiwitech62
New User
New User
Posts: 3
Joined: Wed Apr 29, 2020 1:10 pm

Re: Can't activate Deluge WebAPI plug-in for Organizr integration

Postby kiwitech62 » Thu Apr 30, 2020 11:49 pm

Hi again. Thought I'd try your suggestion of starting with a clean profile first, just to make sure there wasn't anything in the profile causing problems, so I stopped deluge from running, renamed the deluge profile folder and created a 'plugins' folder containing the two files 'AutoRemovePlus-0.6.15-py3.8.egg' and 'WebAPI-0.4.0-py3.8.egg' then started deluge again. The AutoRemovePlus plugin showed up but the WebAPI still doesn't.

I has a closer look at the 'WebAPI-0.4.0-py3.8.egg' file. I assume it's supposed to be a compiled binary file. When I try viewing the file in Notepad++ it shows as an HTML file whereas all the other .egg files I tried opening look like binary files. I wasn't expecting to have to compile the .egg file myself.

I did some more googling and found a downloadable zip file https://github.com/idlesign/deluge-webapi/files/4458994/WebAPI-0.4.0-py3.8.zip on this web page https://github.com/idlesign/deluge-webapi/issues/27 which had a compiled version of the plugin so tried that and it installed and I was able to enable it successfully.

I now have Deluge 2.0 integrated fully into Organizr. Appreciate all the assistance you've provided.

With regard to the [object FileList] showing up it looks like it happens when installing through the WebUI. Doing it that way creates a file with that name in the plugins folder that is a copy of the plugin that was selected to install.

mhertz
Compulsive Poster
Compulsive Poster
Posts: 783
Joined: Wed Jan 22, 2014 5:05 am
Location: Denmark

Re: Can't activate Deluge WebAPI plug-in for Organizr integration

Postby mhertz » Fri May 01, 2020 12:49 am

Sorry, I now see that the link I gave you to webapi plugin, wasent a direct link, but if you press it, there comes a page up that has a download button and clicking that would give you the plugin(though meaning that if you downloaded it by right clicking link and select to save it, then wouldn't work, as would be http web page, like you stated), but I was little to quick in copy/pasting initially I see. Good you figured it out yourself regardless :)


Return to “Plugins”

Who is online

Users browsing this forum: No registered users and 2 guests