v2.0.3 create_plugin.py looking for config.glade?

Suggest, post, or discuss plugins for Deluge
Tod
New User
New User
Posts: 1
Joined: Wed Oct 09, 2019 8:43 pm

v2.0.3 create_plugin.py looking for config.glade?

Postby Tod » Wed Oct 09, 2019 8:52 pm

Hi Deluged people.

I've used create_plugin.py as suggested in the wiki.

Is the generated plugin supposed to work out of the box?

It has the below code which tries to load config.glade - but this file does not exist (only config.ui).

Code: Select all

class Gtk3UI(Gtk3PluginBase):
    def enable(self):
        self.builder = Gtk.Builder()
        self.builder.add_from_file(get_resource('config.glade'))


I thought Glade was v1.3 legacy stuff anyway?

Any suggestions to get it working?

bro
Top Bloke
Top Bloke
Posts: 360
Joined: Sun Aug 28, 2011 6:46 pm
Location: Norway

Re: v2.0.3 create_plugin.py looking for config.glade?

Postby bro » Thu Oct 10, 2019 5:03 pm

I thought Glade was v1.3 legacy stuff anyway?

It is, so it's problably just a mistake not replacing 'config.glade' in the script.

Have you tried replacing 'config.glade' with 'config.ui'?
When reporting issues, please include any relevant information such as OS (and version), python version (for Windows users this depends on which Deluge installer was used), Deluge version and plugin version.


Return to “Plugins”

Who is online

Users browsing this forum: Google [Bot] and 6 guests