Page 2 of 2

Re: Deluge 2.0+ Compatible plugins list please post the ones that are working

Posted: Thu Jan 09, 2020 10:15 am
by mhertz
Lol, no worries mate, but thanks anyways :) Ohh, I see, I didn't thought of that honestly, though should have as do remember you using a headless RPI3 thinclient setup. I was making screenshots for you to see better, but deleted them again, because unfortunently it's like you suspected and local only :( I have fixed a few plugins to deluge2, but honestly never did it with plugins including gtk2 xml glade code, which usually needs a converter tool and things i've never used before to work, so I don't think I can update that old plugin(+ shorter of time now than previously), so hopefully another will release an updated fork or alternative at a time, as indeed sounds usefull. Thanks again for reply mate, appreciated :)

Edit: I see the plugin was updated just a few month ago on github repo, though still no deluge2 support. No open or closed tickets asking for deluge2 support, so probably a good idea to post request there, seeing the development still is active and all.

Re: Deluge 2.0+ Compatible plugins list please post the ones that are working

Posted: Sat Jan 11, 2020 6:22 pm
by Labbz0re
nvm

Re: Deluge 2.0+ Compatible plugins list please post the ones that are working

Posted: Sat Jan 11, 2020 6:26 pm
by mhertz
Correct. Me/us neither :) I'd suggest adding a request to the dev here: https://github.com/dredkin/deluge-rbb/issues

Re: Deluge 2.0+ Compatible plugins list please post the ones that are working

Posted: Tue Jan 14, 2020 11:49 am
by bro
dopedangel wrote:Labelplus port for 2.0 is working is also working

Added to wiki

Re: Deluge 2.0+ Compatible plugins list please post the ones that are working

Posted: Sat Feb 01, 2020 11:12 am
by mhertz
Shamael, sorry if you already know, but just in case you hadn't seen, then the dev of deluge-rbb has started development of deluge 2.x support and an alpha version is released, found in issues section here: https://github.com/dredkin/deluge-rbb/issues/21

(I myself have tried before to update it, also after stating to you that I had given up on it, but I didn't succeed, I suspect because there where some direct legacy glade code functions used in the py files, which the update doc don't state how to translate to gtkbuilder, but atleast I learned to translate glade files to gtkbuilder using conversion tool gtk-builder-convert, to convert the 3 glade files to gtkbuilder files in addition to the other gtk3 changes needed.)

Anyway, just wanted to make sure you'd aware :)

labbz0re, I suspect it was you who made the initial request on github for the update ;) Atleast the first 3 chars are the same in username, though could be a coincidence of course, but as I also suggested you to open a report there, then I'm guessing was you. If correct, then god job initiating this :)

Edit: googled alittle and yes my suspicion was correct :)

Edit2: Shamael, tested just quickly the alpha plugin in thinclient mode between windows-client and linux-server, by selecting a torrent and using browsebutton to change download-dir, which showed the server-side dir-list now instead of client-side(default) i.e. working(also checked dir actually changed afterwards during download) :)

Re: Deluge 2.0+ Compatible plugins list please post the ones that are working

Posted: Wed Jul 22, 2020 8:59 pm
by tote94
I've started a new fork from the last version of AutoRemovePlus by Omar Alvarez. It is for Deluge 2 and as far as I know, it is fully functional. The Gtk3UI works too. I'm sure it has some bugs, but definitely worth a try.

Topic: https://forum.deluge-torrent.org/viewtopic.php?f=9&t=55733

Re: Deluge 2.0+ Compatible plugins list please post the ones that are working

Posted: Fri Sep 04, 2020 3:19 pm
by badwar
Hi, I'm running Deluge 2.0.4dev23 in a docker container running Arch Linux, and I'm unable to get the LabelPlus plugin to install for Python 3.8 either by manually copying the .egg file into the /config/plugins folder, or by installing it via the webUI. I don't see any errors, the plugin simply doesn't show up in the list. This is what Deluge reports when I login to the container and run the --version command:

deluged 2.0.4.dev23
libtorrent: 1.2.6.0
Python: 3.8.2
OS: Linux Arch Linux

and the file I'm trying to install:

LabelPlus-0.3.2.4-py3.8.egg

Am I doing something wrong, or is there somewhere else I can look to try and troubleshoot why I can't get LabelPlus to work? Thanks for the help.