Page 1 of 1

Missing “included” plugins

Posted: Thu Apr 18, 2019 1:33 am
by mcar91
Hi folks. I’m new-ish to the Linux world, so please excuse any silly questions and let me know what additional info I could provide.

I installed Deluge on a Raspberry Pi running Raspbian and am using the ThinClient daemon to do the download work. When I access the daemon via web UI and try to configure some of the included plugins, I’m getting a pop up asking for the .egg file to install the plugin.

How can I install these default plugins if they weren’t installed with the deluge package?

Thank you!!

Re: Missing “included” plugins

Posted: Thu Apr 18, 2019 7:56 am
by Cas
Please provide a screenshot of plugin page

Re: Missing “included” plugins

Posted: Fri Apr 19, 2019 10:03 pm
by mcar91
I’m not sure what changed, but I was able to turn on the plugin easily when I tried again. It had been about a week since I last tried. Perhaps something changed.

I’m getting this error when it tries to trigger. Any ideas?

Code: Select all

ERROR   ] 17:57:50 client:391 RPCError Message Received!
RPCRequest: notifications.set_config({u'smtp_port': u'', u'smtp_recipients': [], u'smtp_tls': False, u'smtp_enabled': False, u'subscriptions': {u'email': []}})
  File "/usr/lib/python2.7/dist-packages/deluge/core/", line 301, in dispatch
    ret = self.factory.methods[method](*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/deluge/plugins/Notifications-0.2.egg/notifications/", line 235, in set_config
    self.config[key] = config[key]
  File "/usr/lib/python2.7/dist-packages/deluge/", line 171, in __setitem__
    return self.set_item(key, value)
  File "/usr/lib/python2.7/dist-packages/deluge/", line 213, in set_item
    value = oldtype(value)

ValueError: invalid literal for int() with base 10: ''