[Plugin][Extractor] Extract successful, no extracted files can be found

Suggest, post, or discuss plugins for Deluge
Cas
Top Bloke
Top Bloke
Posts: 3642
Joined: Mon Dec 07, 2009 6:04 am
Location: Scotland

Re: [Plugin][Extractor] Extract successful, no extracted files can be found

Postby Cas » Mon Jun 13, 2016 10:37 pm

See previous post and include logs!

FlyGuy94
New User
New User
Posts: 2
Joined: Mon Jun 13, 2016 9:33 am

Re: [Plugin][Extractor] Extract successful, no extracted files can be found

Postby FlyGuy94 » Wed Jun 15, 2016 6:27 pm

I did delete the old extractor plugin and I'm using phyton 2.7.6 I just can't figure out how to enable debug logs -_-

User avatar
Geth
Member
Member
Posts: 12
Joined: Sun May 08, 2016 3:04 pm
Location: Budapest, Hungary

Re: [Plugin][Extractor] Extract successful, no extracted files can be found

Postby Geth » Thu Jun 16, 2016 5:44 am


wilson
Member
Member
Posts: 23
Joined: Sat Dec 12, 2015 4:10 pm
Location: US

Re: [Plugin][Extractor] Extract successful, no extracted files can be found

Postby wilson » Sat Jul 30, 2016 7:33 pm

I've finally resolved my other issue: viewtopic.php?f=13&t=54067

However, same as last time, I now know that deluge is finding and using unrar.

Code: Select all

[INFO    ] 13:44:42 core:168 EXTRACTOR: Extract successful: /path/to/extracted/folder/file.rar (63829e1942ea8814597afa5a6421556497073182)


when I go to /path/to/extracted/folder/ there is no file to be found. As instructed the last time I ran into this, I have only Extractor v0.5a1. I wish I knew how Geth resolved this issue. I have followed all of the steps from earlier in this thread, to no avail.

Additional help is greatly appreciated.

Cas
Top Bloke
Top Bloke
Posts: 3642
Joined: Mon Dec 07, 2009 6:04 am
Location: Scotland

Re: [Plugin][Extractor] Extract successful, no extracted files can be found

Postby Cas » Sat Jul 30, 2016 9:11 pm

wilson wrote:

Code: Select all

[INFO    ] 13:44:42 core:168 EXTRACTOR: Extract successful: /path/to/extracted/folder/file.rar (63829e1942ea8814597afa5a6421556497073182)


when I go to /path/to/extracted/folder/ there is no file to be found. As instructed the last time I ran into this, I have only Extractor v0.5a1.


That log line reveals you are not utilising the newer version of the plugin, it's still using the bundled one. Please use Deluge 1.3.13 as the plugin is fixed there.

wilson
Member
Member
Posts: 23
Joined: Sat Dec 12, 2015 4:10 pm
Location: US

Re: [Plugin][Extractor] Extract successful, no extracted files can be found

Postby wilson » Sun Jul 31, 2016 1:54 am

OK.

So after updating I still have no file however I think I have a usable error from the log that will help troubleshoot what's happening. Does this log help?

Code: Select all

[ERROR   ] 20:43:58 core:172 EXTRACTOR: Extract failed: /path/to/file/folder/file.rar (5191160676451c2f470af6fe4a515096d118e78c) Upon execvpe unrar ['unrar', 'x', '-o+', '-y', '/path/to/file/folder/file.rar] in environment id 4477164632
:Traceback (most recent call last):
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/twisted/internet/process.py", line 403, in _fork
    path, uid, gid, executable, args, environment)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/twisted/internet/process.py", line 453, in _execChild
    os.execvpe(executable, args, environment)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/os.py", line 355, in execvpe
    _execvpe(file, args, env)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/os.py", line 382, in _execvpe
    func(fullname, *argrest)
OSError: [Errno 8] Exec format error


I'm optimistic that this will give you what you need to help me resolve my final issue. Thanks in advance.


Return to “Plugins”

Who is online

Users browsing this forum: No registered users and 2 guests