[Plugin][Extractor] Extract successful, no extracted files can be found

Suggest, post, or discuss plugins for Deluge
Cas
Top Bloke
Top Bloke
Posts: 3642
Joined: Mon Dec 07, 2009 6:04 am
Location: Scotland

Re: [Plugin][Extractor] Extract successful, no extracted files can be found

Postby Cas » Tue May 31, 2016 6:30 pm

Ah I did mean to add os.environ to be passed to command. I have attached another version with that change so can rule that out :)

I'm at a bit of a loss to explain the issue and would have to start considering libtorrent being involved somehow.
Attachments
Extractor-0.5a1-py2.7.egg
(16.65 KiB) Downloaded 327 times

User avatar
Geth
Member
Member
Posts: 12
Joined: Sun May 08, 2016 3:04 pm
Location: Budapest, Hungary

Re: [Plugin][Extractor] Extract successful, no extracted files can be found

Postby Geth » Wed Jun 01, 2016 6:09 am

Ok, another test (0.5a1), I think you'll get there :)

Now the extracted files are there, minor issue is that the log says extract failed.

EDIT: on_extract if-else swapped (0 - success evaluates to false)? That would explain why we saw "successful" in the log the whole time :)

wilson
Member
Member
Posts: 23
Joined: Sat Dec 12, 2015 4:10 pm
Location: US

Re: [Plugin][Extractor] Extract successful, no extracted files can be found

Postby wilson » Sun Jun 05, 2016 3:23 pm

Unfortunately, the second new version (v0.5a1) still is not working for me. The log still says SUCCESSFUL, but no file is in the destination directory.

Code: Select all

[DEBUG   ] 09:58:04 core:175 EXTRACTOR: Extracting /PATH/TO/RAR/ARCHIVE/file.rar with unrar x -o+ -y to /PATH/TO/DESTINATIONDIR

[INFO    ] 09:58:04 core:168 EXTRACTOR: Extract successful: /PATH/TO/RAR/ARCHIVE/file.rar (1c603551e3c5e5c824adbef2c9e2c4ecc4bcf129)


I have tested unrar independently and it works fine:

Code: Select all

ID:~ USER$ unrar x -o+ -y /PATH/TO/RAR/ARCHIVE/file.rar /PATH/TO/DESTINATIONDIR

UNRAR 5.40 beta 1 freeware      Copyright (c) 1993-2016 Alexander Roshal

Extracting from /PATH/TO/RAR/ARCHIVE/file.rar
Extracting  /PATH/TO/DESTINATIONDIR/file.mp4     15%
Extracting from /PATH/TO/RAR/ARCHIVE/file.r00
...         /PATH/TO/DESTINATIONDIR/file.mp4                   30%
Extracting from /PATH/TO/RAR/ARCHIVE/file.r01
...         /PATH/TO/DESTINATIONDIR/file.mp4                  45%
Extracting from /PATH/TO/RAR/ARCHIVE/file.r02
...         /PATH/TO/DESTINATIONDIR/file.mp4                   60%
Extracting from /PATH/TO/RAR/ARCHIVE/file.r03
...         /PATH/TO/DESTINATIONDIR/file.mp4                  75%
Extracting from /PATH/TO/RAR/ARCHIVE/file.r04
...         /PATH/TO/DESTINATIONDIR/file.mp4                  91%
Extracting from /PATH/TO/RAR/ARCHIVE/file.r05
...        /PATH/TO/DESTINATIONDIR/file.mp4                   OK
All OK


This completed successfully, ultimately placing the file.mp4 in the destination directory.

Cas
Top Bloke
Top Bloke
Posts: 3642
Joined: Mon Dec 07, 2009 6:04 am
Location: Scotland

Re: [Plugin][Extractor] Extract successful, no extracted files can be found

Postby Cas » Sun Jun 05, 2016 6:08 pm

wilson wrote:

Code: Select all

[DEBUG   ] 09:58:04 core:175 EXTRACTOR: Extracting ...

[INFO    ] 09:58:04 core:168 EXTRACTOR: Extract successful: ...


That indicates you are running the old version

wilson
Member
Member
Posts: 23
Joined: Sat Dec 12, 2015 4:10 pm
Location: US

Re: [Plugin][Extractor] Extract successful, no extracted files can be found

Postby wilson » Mon Jun 06, 2016 3:12 am

Please help me figure out where I'm going wrong. I attached a screenshot of my plugins, which says v0.5a1. I've checked the ~/.config/plugins directory, it previously had the old and new version of Extractor, but I have verified there is only Extractor-0.5a1-py2.7.egg. This is the result after stopping and restarting the daemon. The resulting logs look the same.

Code: Select all

[DEBUG   ] 22:01:57 core:175 EXTRACTOR: Extracting /PATH/TO/RAR/ARCHIVE/file.rar with unrar x -o+ -y to /PATH/TO/DESTINATIONDIR

[INFO    ] 22:01:57 core:168 EXTRACTOR: Extract successful: /PATH/TO/RAR/ARCHIVE/file.rar (b7a27d0b6690ada08d252de2dab8fcbb953e3df9)


Thanks for all the help, it's greatly appreciated.
Attachments
Screen Shot 2016-06-05 at 9.54.39 PM.png
Screen Shot 2016-06-05 at 9.54.39 PM.png (87.93 KiB) Viewed 4240 times

Cas
Top Bloke
Top Bloke
Posts: 3642
Joined: Mon Dec 07, 2009 6:04 am
Location: Scotland

Re: [Plugin][Extractor] Extract successful, no extracted files can be found

Postby Cas » Mon Jun 06, 2016 9:39 am

If you are using a daemon it needs the plugin installed and to be restarted too.

Cas
Top Bloke
Top Bloke
Posts: 3642
Joined: Mon Dec 07, 2009 6:04 am
Location: Scotland

Re: [Plugin][Extractor] Extract successful, no extracted files can be found

Postby Cas » Fri Jun 10, 2016 3:08 pm

I have updated the ticket as Fixed and attached the updated plugin to it: http://dev.deluge-torrent.org/ticket/2785

FlyGuy94
New User
New User
Posts: 2
Joined: Mon Jun 13, 2016 9:33 am

Re: [Plugin][Extractor] Extract successful, no extracted files can be found

Postby FlyGuy94 » Mon Jun 13, 2016 9:35 am

wilson wrote:Please help me figure out where I'm going wrong. I attached a screenshot of my plugins, which says v0.5a1. I've checked the ~/.config/plugins directory, it previously had the old and new version of Extractor, but I have verified there is only Extractor-0.5a1-py2.7.egg.


He is right I'm suffering from the exact same problem please help its not fixed yet updating the plugin and restarting the deamon on the server and client multiple times did not help at all.

Cas
Top Bloke
Top Bloke
Posts: 3642
Joined: Mon Dec 07, 2009 6:04 am
Location: Scotland

Re: [Plugin][Extractor] Extract successful, no extracted files can be found

Postby Cas » Mon Jun 13, 2016 11:16 am

He is right I'm suffering from the exact same problem please help its not fixed yet updating the plugin and restarting the deamon on the server and client multiple times did not help at all.

Except that it is working fine for geth?

Is it perhaps that you need the python 2.6 version as detailed in plugin install wiki: http://dev.deluge-torrent.org/wiki/Plug ... honVersion

Failing that you can manually delete the old Extractor egg from Deluge source so it will have to only use new version.

mono

Re: [Plugin][Extractor] Extract successful, no extracted files can be found

Postby mono » Mon Jun 13, 2016 9:36 pm

Hi there

Im having the same problem. I installed the new plugin and I still encounter the same behavior.

I did some tests though.

If i download a file with multiple rars Deluge creates the folder for the uncompressed file but there are no files in there.
If i download a file with only one rar file, everything works. Deluge creates the folder and the extractor extracts the files.


Return to “Plugins”

Who is online

Users browsing this forum: No registered users and 3 guests