[Plugin] CopyMagnetURI v0.2

Suggest, post, or discuss plugins for Deluge
SeriousHoax
Member
Member
Posts: 19
Joined: Sat May 27, 2017 10:40 am

Re: [Plugin] CopyMagnetURI v0.2

Postby SeriousHoax » Fri Nov 24, 2017 8:51 am

Doesn't it work anymore? Tried it on the latest 1.3.15 version. Not showing up in the plugins menu. Tried both automatically & manually, python 2.6 & 2.7 but same result.

pawamoy
New User
New User
Posts: 1
Joined: Sun Dec 09, 2018 1:50 pm

Re: [Plugin] CopyMagnetURI v0.2

Postby pawamoy » Sun Dec 09, 2018 1:59 pm

I am SO uninstalling Deluge...

First it was such a pain to configure it in daemon mode to be able to use both GTK and console. Had to read pages of tutorials/manuals. Had to edit a file in /etc. Then the service file itself to point to the right config location. Then modify auth files to set another user:password. Damn. You don't make it easy.

Then Deluge made my whole system lag/freeze with ONLY 100 torrents, 92% of them queued (not seeding, not downloading). What the hell is that?

Now I'm trying to switch to something less problematic, so I want to copy the torrents files or magnets. I CAN'T. Oh there is a plugin. IT DOES NOT WORK. The ticket about this feature for the webui points to this non-working plugin. Tried both 2.6 and 2.7 versions. My system Python is 2.7 so it should work. It does not. Maybe the plugin is too old? I don't know. All I know is that in the end I will have to manually re-create the magnets URI from the hashes and list of trackers...

Bye bye Deluge.

PS: had to express myself. I'm feeling better now. My apologies.

EDIT: found a partial solution: grep "^S'magnet" ~/.config/deluge/state/torrents.state.

Cumva
New User
New User
Posts: 1
Joined: Sat Aug 31, 2019 1:56 am

Re: [Plugin] CopyMagnetURI v0.2

Postby Cumva » Sat Aug 31, 2019 1:59 am

tlm wrote:For anyone desperate to get this working, the fix for 0.2 is actually really simple, but it took me a while to figure out just because I'm not very familiar with the whole Python development thing and these "eggs" and whatnot. Since the developer has since abandoned the plugin, here's the steps to get it working...

viewtopic.php?f=9&t=47501&start=10#p226013

Works like a charm on Windows 10 v1903!
Thanks!

KosherKingOfIsrael
New User
New User
Posts: 1
Joined: Thu Oct 01, 2020 4:40 pm

Re: [Plugin] CopyMagnetURI v0.2

Postby KosherKingOfIsrael » Thu Oct 01, 2020 4:49 pm

tlm wrote:For anyone desperate to get this working, the fix for 0.2 is actually really simple, but it took me a while to figure out just because I'm not very familiar with the whole Python development thing and these "eggs" and whatnot. Since the developer has since abandoned the plugin, here's the steps to get it working...


It appears in the plugins list but I can't actually enable it.


Return to “Plugins”

Who is online

Users browsing this forum: No registered users and 5 guests