Page 19 of 22

Re: [Plugin] Auto Remove Plus v0.6.1

Posted: Sat Apr 18, 2020 4:15 pm
by mhertz
Yeah, sorry I've only ever tried doing it manually, so copying it into plugins folder of deluge config folder and enabling it thereafter in an UI. I seem to remember that error you described reported on github, so needed to either do it manually, or use GTKUI, I cannot remember, but i'd just do it manually as you can then exclude any possible issues with the install-mechanism itself.

Re: [Plugin] Auto Remove Plus v0.6.1

Posted: Sat Apr 18, 2020 4:20 pm
by kevindd992002
Ok, got it. I also see the new Media Server tab which I assume is the feature why we need python3-requests.

So how does that work? As I understand in the text there, it says:

"If the corresponding server is enabled, removing a torrent from deluge will also blacklist it from the upstream server, so that it's not downloaded again"

So when Sonarr/Radarr successfully completes a download it doesn't remove it from Deluge for seeding. Once autoremoveplus removes it, it blacklists it from Sonarr? Even though it technically is a valid download and that the only reason it was removed from Deluge is because it already met the criteria set in the autoremoveplus settings? I'm confused with this new feature.

Re: [Plugin] Auto Remove Plus v0.6.1

Posted: Sat Apr 18, 2020 4:36 pm
by kevindd992002
Also, I have these additional questions:

1. What happens when you have the "remove torrents" and "pause torrents" both checked? Why can you check them in the first place? Aren't they contradictory to each other? It should only be one or the other.
2. How do you disable "pause after seedtime"? It doesn't accept the 0 value. What if I don't want to ever pause my torrents?
3. There is a "remove after seedtime" checkbox now but you can also set the Seed Time parameter in the conditions. Why? This is redundant, the way I see it.
4. What is the difference between "remove torrent data" and "remove torrent data also for completed downloads"? What is the use case of using one vs the other?

Re: [Plugin] Auto Remove Plus v0.6.1

Posted: Sat Apr 18, 2020 5:08 pm
by mhertz
Sorry, I should probably have mentioned before that I actually don't use this plugin myself, and only wen't into figuring out what was needed to enable it and such, because I stumbled on a github ticket where one reported that he had issues with enabling this plugin in the unofficial deluge2 installer for windows, and as which I wanted fixed then, and so only have tested it working for being enabled and to confirm it's functionality working by having it delete a few files with a very quick config, that's all.

Hopefully springjools or someone else in the know will be able to help you out with your questions, which i'm sure also will be helpfull for others reading this thread, as good questions raised.

Re: [Plugin] Auto Remove Plus v0.6.1

Posted: Sun Apr 19, 2020 1:54 am
by sp00kie
jools772 wrote:It should work on Ubuntu with web-ui. Try here: ... s/releases

Thanks! I got it instslled. Here is my procedure.

1. Shut down deluge
2. Remove old plugin from ~/.config/deluge/plugins folder.
3. Delete old autoremoveplus.conf and autoremoveplusstates.conf files from ~/.config/deluge
4. Start deluge
5. Enable plugin in deluge. (Yes, it sees the plugin. WOOHOO!)
6. Use webui to configure it.
7. WIN!

Thank you jools and others for your help!

EDIT: ok spoke too soon. It is installed but it's not actually removing any torrents or even pausing them.

For example, I have a specific tracker set to pause after a min. ratio of 1 is reached. My check time is set to 0.05 That should be every 3 minutes, right? But I have a torrent from that tracker with a ratio of over 1.8 and it isn't removing or pausing or doing anything with it. Same with the general rules. I set a general rule to remove all torrents with a ratio over 1. Nothing.

EDIT 2: Ok I think I found the error.

05:40:37 [ERROR ][deluge.pluginmanagerbase :154 ] Unable to instantiate plugin 'AutoRemovePlus' from '/home/dave/.config/deluge/plugins/AutoRemovePlus-0.6.14.egg'!
05:40:37 [ERROR ][deluge.pluginmanagerbase :1343] No module named 'gtkui'
Traceback (most recent call last):
File "/usr/lib/python3/dist-packages/deluge/", line 148, in enable_plugin
instance = cls(plugin_name.replace('-', '_'))
File "/home/dave/.config/deluge/plugins/AutoRemovePlus-0.6.14.egg/autoremoveplus/", line 55, in __init__
from gtkui import GtkUI as _plugin_cls
ModuleNotFoundError: No module named 'gtkui'

Re: [Plugin] Auto Remove Plus v0.6.1

Posted: Sun Apr 19, 2020 9:14 am
by psycholyzern
Hi guys. I think I am lost. I put the

Code: Select all

file in

Code: Select all

, then enabled the plugin in webui. But somehow there is no setings for it showing up anywhere.

Re: [Plugin] Auto Remove Plus v0.6.1

Posted: Sun Apr 19, 2020 9:45 am
by mhertz
Sp00kie, there are some errors in log, like you showed, for the initialization for the gtk part i.e that part should be gtk3ui, but other issues too, when I previously spent a little time seeing if I could fix the gtk part, but I believe can be ignored as the daemon does have it initialized you also can see from log and when shutting down the log states the plugin shuts down too for daemon part, I believe remember it listed in my log when testing it. I can't help you with your issue, unfortunetly, but several months ago, a ticket was made on github stating that deletion only worked when opening the webui and into preferences selecting apply and ok. Springjools posted a link to a deluge ticket stating deluge not deleting torrents whenever the webui wasent open, and didn't mention autoremoveplus, but I don't know if was related. I'm not in front of computer now, so cannot test this myself. I'd suggest making ticket about it on springjools github, or repost in the old ticker I referred to above, it's called something with not deleting or removing in title and 3 or 4 months old.

(Edit: Sorry was an old very long ticket on the original authors github, started long ago, and where springjools announced his fork and got reported said issue around 6 months ago and responded the above mentioned, so make new ticket on springjools github I'd suggest. Old ticket where mentioned a few times in, here: ... /issues/50)

Psycholyzern, so you're on deluge2 and having installed python3-requests, and not seeing a preferences menu for autoremoveplus in the preferences menu of webui? If so, then sorry I don't know issue if you're on springjools latest release linked previously. I'd suggest running with debug-logging and examine/post for further troubleshooting.

Edit2: You mentioned wrong path, you do have it under plugins folder right, under your mentioned path, but you should have, as else couldn't see it and enable it, as wouldn't show. Use manual install as just stated, and don't select to install it, only enable it, to exclude all other issues, as have read about such failing before. If you start deluge from e.g systemd or whatever, then keep in mind it often starts deluge daemons under a deluge user, so should have plugin under that config dir and not your regular account.

It was suggested to restart webui daemon and page too for your issue I just read and was stated to work.

Re: [Plugin] Auto Remove Plus v0.6.1

Posted: Sun Apr 19, 2020 4:36 pm
by jools772
I think I found the error:

Code: Select all

from autoremoveplus.gtkui import GtkUI as _plugin_cls

Should be like this, because python3 requires explicit imports. Hold on and I make a new release. No idea why it worked for me before.

Re: [Plugin] Auto Remove Plus v0.6.1

Posted: Sun Apr 19, 2020 4:36 pm
by jools772
Btw, step 3 above should not be needed. But I guess there is no harm from it either.

Re: [Plugin] Auto Remove Plus v0.6.1

Posted: Sun Apr 19, 2020 8:16 pm
by sp00kie
So I installed the latest version. I had to change the name of the egg to version 3.6 for it to show up in my list so I could activate it and for it to show up in my webui. After that it still doesn't pause or remove any torrents that have met the criteria.

Also, can someone tell me how to start deluge without using the daemon. I started the daemon up once to see if that would make the plugin work and now both the local deluge app and the remote webui keep giving me the connection manager dialog every time I start them up.