[Plugin] Auto Remove Plus v0.6.1

Suggest, post, or discuss plugins for Deluge
sp00kie
New User
New User
Posts: 8
Joined: Sun Apr 12, 2020 2:23 pm

Re: [Plugin] Auto Remove Plus v0.6.1

Postby sp00kie » Tue Apr 14, 2020 5:16 am

I have tried every version out there of this plugin with deluge version 2.0.3-2-201906121747-ubuntu18.04.1

Literally nothing works. Even if you can get it to show up by changing the python version to 3.6 in the filename, it doesn't show up in the list. Can someone please please please make a version of this that works with the current stable version of deluge in the ppa repo for ubuntu 18.04. Or if there is a way to make it work, can someone please suggest some instructions?

jools772
Member
Member
Posts: 20
Joined: Fri Oct 25, 2019 8:07 am

Re: [Plugin] Auto Remove Plus v0.6.1

Postby jools772 » Fri Apr 17, 2020 1:00 pm

It should work on Ubuntu with web-ui. Try here: https://github.com/springjools/deluge-a ... s/releases

mhertz
Compulsive Poster
Compulsive Poster
Posts: 865
Joined: Wed Jan 22, 2014 5:05 am
Location: Denmark

Re: [Plugin] Auto Remove Plus v0.6.1

Postby mhertz » Fri Apr 17, 2020 7:03 pm

sp00kie and others interested, If you cannot enable it in an UI on deluge2, then make sure you use springjools fork as posted above, which doesn't need to be renamed as doesn't contain python version in name, and you need the python3 requests module, often named python3-requests(or python-requests on arch-linux).

Btw, it should work everywhere(as works through the daemon), but can only be configured and interacted with from webUI currently(as springjools stated above), though as said works fine from all UIs, internally, from config-file, and can also be enabled from all UIs.

kevindd992002
Member
Member
Posts: 41
Joined: Thu Jun 13, 2019 2:56 pm

Re: [Plugin] Auto Remove Plus v0.6.1

Postby kevindd992002 » Sat Apr 18, 2020 12:55 am

I'm using the linuxserver/deluge container which already contains the pyhton3-requests module. Do I also need the python3-future module as mentioned in this post https://github.com/omaralvarez/deluge-autoremoveplus/issues/50#issuecomment-612796442? So it should easily be installed through the webUI, correct?

mhertz
Compulsive Poster
Compulsive Poster
Posts: 865
Joined: Wed Jan 22, 2014 5:05 am
Location: Denmark

Re: [Plugin] Auto Remove Plus v0.6.1

Postby mhertz » Sat Apr 18, 2020 2:50 am

From v0.6.11 of springjools fork(currently v0.6.14), then python3 'future'('past' specifically) isn't needed anymore, so only extra python3 module needed is 'requests', so you should be fine.

kevindd992002
Member
Member
Posts: 41
Joined: Thu Jun 13, 2019 2:56 pm

Re: [Plugin] Auto Remove Plus v0.6.1

Postby kevindd992002 » Sat Apr 18, 2020 3:33 am

Oops, sorry, I'm still missing the requests module, I was checking another container. The weird thing is that my autoremove plus module (not sure which version I'm using, but it's probably 0.6.12 of springjools' fork) is working just fine. I installed it manually by putting in the plugins folder though because it was not working in the web-ui. What does the requests module really do anyway? What am I missing without it?

kevindd992002
Member
Member
Posts: 41
Joined: Thu Jun 13, 2019 2:56 pm

Re: [Plugin] Auto Remove Plus v0.6.1

Postby kevindd992002 » Sat Apr 18, 2020 3:33 am

Also, what did you mean by python3-future (past specifically)?

mhertz
Compulsive Poster
Compulsive Poster
Posts: 865
Joined: Wed Jan 22, 2014 5:05 am
Location: Denmark

Re: [Plugin] Auto Remove Plus v0.6.1

Postby mhertz » Sat Apr 18, 2020 3:48 am

The request module is used in springjools fork for the mediaserver part, e.g communicate with sonar etc.

The future package contains several modules, past is used specifically on py3 to get py2 support(hence name), and future is for py3 support on p2, so past module of future package was the needed module on python3 deluge2 installs using autoremoveplus springjools fork before v0.6.11(deluge2 has legacy py2 support, or atleast had previously in older times).

kevindd992002
Member
Member
Posts: 41
Joined: Thu Jun 13, 2019 2:56 pm

Re: [Plugin] Auto Remove Plus v0.6.1

Postby kevindd992002 » Sat Apr 18, 2020 4:20 am

Yeah, that's what I read about requests too. I don't understand though why my deluge container can communicate with my Sonarr/Radarr container just fine even without the requests module?

Ok, that makes sense on the future package.

kevindd992002
Member
Member
Posts: 41
Joined: Thu Jun 13, 2019 2:56 pm

Re: [Plugin] Auto Remove Plus v0.6.1

Postby kevindd992002 » Sat Apr 18, 2020 4:03 pm

@mhertz, so I have the python3-requests installed on my linuxserver/deluge container already but still when I try to install 0.6.14 using the webUI, I get the [object FileList] name when I choose the egg. What is wrong with this? Do I have to manually install again by copying the egg to the plugins folder (this worked for me before)? I just want to understand why this egg can't be installed using the webUI.


Return to “Plugins”

Who is online

Users browsing this forum: No registered users and 4 guests