[Plugin] ltConfig v2.0.0

Suggest, post, or discuss plugins for Deluge
idiocracy
Leecher
Leecher
Posts: 63
Joined: Tue Jul 23, 2019 11:04 am

Re: [Plugin] ltConfig v2.0.0

Postby idiocracy » Wed Nov 13, 2019 7:02 pm

But does the updated 0.3 fully work with deluge 2 and libtorrent 1.2?
It's not a problem switching.

mhertz
Compulsive Poster
Compulsive Poster
Posts: 864
Joined: Wed Jan 22, 2014 5:05 am
Location: Denmark

Re: [Plugin] ltConfig v2.0.0

Postby mhertz » Wed Nov 13, 2019 7:07 pm

You should use v2, not v0.3, as v2 is official, newest and contain better fixes, though just isn't 100% yet in the GTKUI, but works seemingly behind-the-scene anyways, as seen in the log file.

idiocracy
Leecher
Leecher
Posts: 63
Joined: Tue Jul 23, 2019 11:04 am

Re: [Plugin] ltConfig v2.0.0

Postby idiocracy » Wed Nov 13, 2019 7:40 pm

Ok, so updated 0.3 that works with deluge 2 is not more stable than v2.

mhertz
Compulsive Poster
Compulsive Poster
Posts: 864
Joined: Wed Jan 22, 2014 5:05 am
Location: Denmark

Re: [Plugin] ltConfig v2.0.0

Postby mhertz » Wed Nov 13, 2019 8:52 pm

Correct :) Initially, ltconfig didn't support deluge2, and then JoshDi and labor4 updated it to work in unofficial updates to latest released v0.3, and it worked mostly, with a few issues,, and then the official author, ratanakvlun, released an official new release(v2) which used the previous changes made by JoshDi and labor4 but fixed some non-working parts of there code-changes that didn't work right. It's not perfect still though, as seen by me and another ones tickets posted, but I think it's mostly GUI bugs and not anything affecting true operation, I.e I cannot enable announcing to all trackers and tiers in the GTKUI, but if setting the option in the config-file then it works fine i've checked several times.

idiocracy
Leecher
Leecher
Posts: 63
Joined: Tue Jul 23, 2019 11:04 am

Re: [Plugin] ltConfig v2.0.0

Postby idiocracy » Wed Nov 13, 2019 9:03 pm

I see. Makes sense now.

psisis
New User
New User
Posts: 7
Joined: Wed Nov 20, 2019 11:34 pm

Re: [Plugin] ltConfig v2.0.0

Postby psisis » Wed Dec 04, 2019 10:19 pm

I noticed that every option is tweakable in the webui :)

In the app tho, only field values are changeable, the checkbox "boolean" values don't work at all.. But they do work by changing the conf

Are they different interfaces? Like GTK3 vs, HTML/PHP or something?

mhertz
Compulsive Poster
Compulsive Poster
Posts: 864
Joined: Wed Jan 22, 2014 5:05 am
Location: Denmark

Re: [Plugin] ltConfig v2.0.0

Postby mhertz » Wed Dec 04, 2019 11:49 pm

Correct. I've reported this a few months ago, but nothings happened yet. Personally, I don't really care, as so long it's possible through work-arounds as you stated, then fine by me, but just reported it nonetheless to help future development, and others out.

negge
Member
Member
Posts: 32
Joined: Tue Jul 29, 2008 5:35 am

Re: [Plugin] ltConfig v2.0.0

Postby negge » Sat Dec 07, 2019 7:34 pm

For the longest time I thought something else was wrong since I was only getting 30-50 MB/s download speeds. After moving to another ISP, defragmenting my XFS filesystem as well as fiddling with connection settings I discovered this plugin. Enabled it and download speeds jumped to 108 MB/s immediately.

What can I say, holy ****! Thanks for this one!

ostiniatoze
New User
New User
Posts: 2
Joined: Sat Dec 07, 2019 11:11 pm

Re: [Plugin] ltConfig v2.0.0

Postby ostiniatoze » Sat Dec 07, 2019 11:40 pm

I can't get this plugin to install, I've tried through the gui and dong it manually. It just does nothing, I get no error message or anything. I'm using the latest linuxserver docker image of deluge2 on Raspbian Buster. I've tried using python 2.7 and 3.7 and nothing.

Any help would be appreciated.
Last edited by ostiniatoze on Sun Dec 08, 2019 1:04 am, edited 1 time in total.

mhertz
Compulsive Poster
Compulsive Poster
Posts: 864
Joined: Wed Jan 22, 2014 5:05 am
Location: Denmark

Re: [Plugin] ltConfig v2.0.0

Postby mhertz » Sun Dec 08, 2019 12:06 am

If you're using deluge2, then you should use ltconfig-2.0 and py3.x, and if using deluge1, then use ltconfig-0.3.1 and py2.7.


Return to “Plugins”

Who is online

Users browsing this forum: No registered users and 7 guests