[Plugin] ltConfig v2.0.0

Suggest, post, or discuss plugins for Deluge
idiocracy
Leecher
Leecher
Posts: 60
Joined: Tue Jul 23, 2019 11:04 am

Re: [Plugin] ltConfig v0.3.1

Postby idiocracy » Thu Jul 25, 2019 11:01 pm

mhertz wrote:The modified settings are saved in your deluge profile-dir as 'ltconfig.conf' , so copy that file as a backup and you can have several different of these with special settings, like I have several, some with just barebones needed stuff and others also including many of the settings from the high-performance-seed preset etc. Just make sure to have 'deluged' killed before backing up the file or replacing it with another version, just like with 'core.conf' as you main deluge settings).


Just wondering, why does deluged needs to be killed to do a ctrl+c of the file, does it write stuff to the file on shutdown?

mhertz
Compulsive Poster
Compulsive Poster
Posts: 828
Joined: Wed Jan 22, 2014 5:05 am
Location: Denmark

Re: [Plugin] ltConfig v0.3.1

Postby mhertz » Thu Jul 25, 2019 11:36 pm

Yes I believe it does, and it's a known issue that cause problems when forgetting this beforehand.

Btw, taking your question literally, then if the file in question is fully updated, then copy/pasting the contents into a backup file would indeed not need deluged to specifically be killed/closed, you're correct, though I was here referring to copying the actual file over as a backup(and then renaming it if keeping several versions), e.g. I have backups named ltconfig.conf1 and up to 4 I believe and then to restore I copy back/overwrite e.g. ltconfig.conf2 as ltconfig.conf in Deluge's profile-dir.

mhertz
Compulsive Poster
Compulsive Poster
Posts: 828
Joined: Wed Jan 22, 2014 5:05 am
Location: Denmark

Re: [Plugin] ltConfig v2.0.0

Postby mhertz » Thu Aug 15, 2019 12:24 am

Still not 100% yet, but labor4 has sent a pull-request to JoshDi which has improved the supported functionality, so thanks alot labor4 for your time and efforts and we're almost there it seems :)

Anyway, i've just built and tested it, and now you can see all the libtorrent-settings in the GTK-GUI's preferences-dialog and can select presets(e.g. high-performance-seed) and can also enable/change options that needs values, either numbers or letters, but unfortunately the only thing still lacking is enabling options which just are either enabled or disabled with a checkbox, as you can select the option in first row, but not enable the option in the "selection-row". In short, everything works, except configuring boolean-options(yes/no-type ones).

Also, there used to be a ltconfig-plugin related error displayed on terminal when starting deluge from terminal, even though the plugin still worked, but now there's no errors shown.

I have uploaded the built plugin from labor4's fork here: http://s000.tinyupload.com/index.php?fi ... 5889759453

Here is labor4's fork's relevant branch: https://github.com/labor4/deluge-ltconf ... gtk3_py3.7

Edit: JoshDi has accepted and integrated the pull-request from labor4, so now we can focus on JoshDi's fork and repo again - I haven't rebuilt and uploaded the plugin, because the code is identical to my previous build and upload above.
Last edited by mhertz on Fri Oct 18, 2019 1:52 pm, edited 1 time in total.

Werner
New User
New User
Posts: 2
Joined: Sat May 20, 2017 7:50 am

Re: [Plugin] ltConfig v2.0.0

Postby Werner » Fri Oct 18, 2019 12:27 pm

I can't install this plugin in deluge 2.0 webui, anyone knows why?

mhertz
Compulsive Poster
Compulsive Poster
Posts: 828
Joined: Wed Jan 22, 2014 5:05 am
Location: Denmark

Re: [Plugin] ltConfig v2.0.0

Postby mhertz » Fri Oct 18, 2019 1:49 pm

I don't think it has ever worked in webUI(to enable it, I mean, as works otherwise), so use the GTK-UI to enable/install it, or the consoleUI, or manually edit core.conf to enable it, and remember to use my built plugin posted in previous post, as there's no release with latest code elsewhere, or you'd have to build it yourself from JoshDi's repo, as his releases aren't the newest. Also, as stated, boolean settings don't work in GTK-UI so you have to reuse an old config-file with such options in it, or manually add the entries to it, for those type of settings(yes/no type), though presets work still which include such options. Lastly, depending on python version, you'd possibly have to rename the plugin to match(e.g. 3.6 instead of 3.7) for it to enable properly.

highvoltage
Member
Member
Posts: 29
Joined: Mon Apr 11, 2016 11:11 pm
Location: Brazil

Re: [Plugin] ltConfig v2.0.0

Postby highvoltage » Fri Oct 18, 2019 5:02 pm


mhertz
Compulsive Poster
Compulsive Poster
Posts: 828
Joined: Wed Jan 22, 2014 5:05 am
Location: Denmark

Re: [Plugin] ltConfig v2.0.0

Postby mhertz » Fri Oct 18, 2019 5:35 pm

Damn, thanks alot mate for letting us know, that's awesome, and I can't believe I didn't even noticed that, but there where so long without reply from him in the deluge2-ticket at his repo, so I had focused instead on the other devs work, and forgot to check back :)

What's more, I now see theres also a pull-request for deluge2-support of labelplus, which I also missed, doh :)

Thanks again and sorry Werner for my previous wrong post.

Great news indeed! :)

mhertz
Compulsive Poster
Compulsive Poster
Posts: 828
Joined: Wed Jan 22, 2014 5:05 am
Location: Denmark

Re: [Plugin] ltConfig v2.0.0

Postby mhertz » Thu Oct 24, 2019 2:33 pm

Hmm, to me then boolean settings aren't supported, I mean for configuration from GTKUI, still in this new release also, so I'll make a ticket for that on ratanakvlun's github shortly.

Edit: Ticket to follow: https://github.com/ratanakvlun/deluge-l ... /issues/19

idiocracy
Leecher
Leecher
Posts: 60
Joined: Tue Jul 23, 2019 11:04 am

Re: [Plugin] ltConfig v2.0.0

Postby idiocracy » Wed Nov 13, 2019 5:31 pm

Have noticed ltconfig 2 often throws it's config. Like i'll open settings after a day or so and the ltconfig UI has no settings, i open the conf and all settings are gone. Reset to default. Have to load a profile, exit deluge, copy config over and restart deluge and everything is fine.
Also, why spend time on updating 0.3 instead of 2.0?

mhertz
Compulsive Poster
Compulsive Poster
Posts: 828
Joined: Wed Jan 22, 2014 5:05 am
Location: Denmark

Re: [Plugin] ltConfig v2.0.0

Postby mhertz » Wed Nov 13, 2019 6:56 pm

0.3 updates where before ratanakvlun's official v2 release. There are issues in the GTKUI for me as stated above, though I have never seen your issue, but only use GTKUI for testing so not in depth and only shortly. You can check the log to see if the settings are applied when this happens, as I remember that I saw in log it worked in previous 0.3 updated versions still, while GTKUI wasent showing any ltconfig menus or settings.

The development is little slow after the v2 release, you can see from the changelog and unanswered tickets, but hopefully it will be revisited soon again.


Return to “Plugins”

Who is online

Users browsing this forum: No registered users and 4 guests