Page 67 of 67

Re: [Plugin] YaRSS2 - RSS plugin with GTKUI support

Posted: Wed May 27, 2020 9:25 am
by mhertz
burny,

The author(bendikro/bro), has it on his ToDo-list for if ever finding time for him to implement it(see notion on first page, plus has been requested many times from 2012 to now - Note, no diss to bro whatsoever, obviously, and so wasent meant in any negative way; Thank you bro for all your awesome work and time volunteered, both in vital 3rd party plugins like this, and upstream development! :) ).

DragonNick,

If using py3.8.x as installed py3 version(to check, run: 'python3 --version', or 'python --version', sorry, never used Ubuntu myself, so not sure, as varies between distros, or atleast used to), then rename the '3.7' part in plugin filename to instead '3.8'. I don't know why not working when reverting python version back again though, but remember you need restart all deluge daemons and UIs also, after changing something.

I don't know why this is still needed, as said many times, as Cas stated in docs that it's not anymore, but that is clearly not the case. Though obviously I should just have submitted a ticket for that then, which I only first come to think about now honestly. BTW, python docs state that field is optional and is for defining working version when there is compatibility problems between versions. I think it would be great if common concensus would be made among plugin devs to simply omit that field all together, well unless actually specifically needing it of-course, and some select few(one?) already omit it i.e ltconfig latest version, as far as I've seen/noticed, but again, simply just my humble opinion on this :)

Re: [Plugin] YaRSS2 - RSS plugin with GTKUI support

Posted: Wed May 27, 2020 5:14 pm
by DragooNick
Thanks mhertz!

I didnt roll back since different python versions can coexist and I had problems in the past trying to temper with getting rid of another since there were other dependencies i didnt know of.

I never tempered with egg files or anything but I found 1 entry of python3.7 in "yarss2/include/dateutil/tox.ini:basepython = python3.7". Changed that to 3.8 and added on the top to env 38 since there were 2x...,36,37 so I guess it might belong there and of right now it works again.

Re: [Plugin] YaRSS2 - RSS plugin with GTKUI support

Posted: Wed May 27, 2020 5:28 pm
by mhertz
You're welcome and glad to hear you fixed it yourself :) Sorry if confusingly worded before, but if you ever get that issue again with whatever plugin, then I meant that it's enough simply to rename the plugin egg file located under your deluge config-dir i.e under the user's dir that deluge is running under, in '.config/deluge/plugins/plugin-name.egg', so in this example here, rename 'YaRSS2-2.1.4-py3.7.egg' into 'YaRSS2-2.1.4-py3.8.egg'.

Re: [Plugin] YaRSS2 - RSS plugin with GTKUI support

Posted: Thu May 28, 2020 8:50 am
by DragooNick
Oh lol I didnt get that, but still instinctively also did this aswell. xD So thanks again I will remember it.

Re: [Plugin] YaRSS2 - RSS plugin with GTKUI support

Posted: Fri May 29, 2020 1:20 am
by Xh77XXL00
bro wrote:
vertigo wrote:hi, i know this question been asked before, but i didn't find any answer how can this be done

the minimum TTL time is set to 15 minutes. i'm using yarss with deluge for downloads on hdbits, and they allow rss check every 5 minutes. i'm totally cool with 5 minutes, but not 15. with 15 minutes it very often happens to have results like this
http://i50.tinypic.com/2dj2d6r.jpg

so would like to see if it possible to change that
thanks for advice

I see. You can change the interval by editing the yarss2.conf file with a text editor (shut down deluge first). If you edit the RSS feed it will be reset to 15. Maybe setting the minimum limit to 5 min won't be a problem. Will consider that for the next version.

Edit: Will change this to 5 minutes in the next version.


Thanks, this helped me change it to 1 minute so I can get into the swarm.

Re: [Plugin] YaRSS2 - RSS plugin with GTKUI support

Posted: Fri Jun 26, 2020 12:17 am
by lovestha
I'm having trouble getting this plugin to show up in ubuntu 20.04.

client:
gareth@gareth-desktop:~/.config/deluge/plugins$ md5sum YaRSS2-2.1.3-py3.6.egg
5f6b65e9d44ae3e19ca55776e4a8a004 YaRSS2-2.1.3-py3.6.egg
gareth@gareth-desktop:~/.config/deluge/plugins$ python --version
Python 3.8.2
gareth@gareth-desktop:~/.config/deluge/plugins$ deluge-gtk --version
Unable to initialize gettext/locale!
'ngettext'
Traceback (most recent call last):
File "/usr/lib/python3/dist-packages/deluge/i18n/util.py", line 118, in setup_translation
builtins.__dict__['_n'] = builtins.__dict__['ngettext']
KeyError: 'ngettext'
deluge-gtk 2.0.3
Python: 3.8.2
OS: Linux Ubuntu 20.04 focal

server:
av@media:~/.config/deluge/plugins$ md5sum YaRSS2-2.1.3-py3.6.egg
5f6b65e9d44ae3e19ca55776e4a8a004 YaRSS2-2.1.3-py3.6.egg
av@media:~/.config/deluge/plugins$ python --version
Python 3.8.2
av@media:~/.config/deluge/plugins$ deluged --version
deluged 2.0.3
libtorrent: 1.1.13.0
Python: 3.8.2
OS: Linux Ubuntu 20.04 focal

I would hope that locale error is unrelated (only just seen that now). Everything is working as expected other than no YaRSS2 in the plugin list in the gtk gui. Any ideas?

Re: [Plugin] YaRSS2 - RSS plugin with GTKUI support

Posted: Fri Jun 26, 2020 8:45 am
by mhertz
Rename plugin-filename's 3.6 part to 3.8 and restart deluge. If not working, then download the plugin with 3.7 in filename(as there's no 3.8 build of this plugin provided), and rename to 3.8.

Generally, whenever a plugin isn't available in your python version, then always just download the closest one to it, and rename to match, which then usually works(3.x to 3.x, though not 2.x to 3.x or vice-versa i.e minor versions and not major versions can usually be successfully renamed. Failing that, manual rebuild from source is then needed).

Gettext/locale error isn't related or important and can be ignored. I believe only comes when using py3.8, and is fixed in deluge's develop branch.

Re: [Plugin] YaRSS2 - RSS plugin with GTKUI support

Posted: Sat Jun 27, 2020 12:52 am
by lovestha
Woah, I looked at those version so many times and was sure it was the same number......

Edit: went straight to the newer release with the higher python version, and renamed the files and everything is happy.