Python3 or changing python-notify requirement

Suggestions and discussion of future versions
mooninite
New User
New User
Posts: 8
Joined: Sat Aug 22, 2015 4:05 am

Python3 or changing python-notify requirement

Postby mooninite » Wed Sep 26, 2018 2:16 pm

Hi Cas,

Is Python 3 support on the roadmap? Fedora is going to drop Python 2 in about a year. I see the wiki page has some brainstorming on it, but are you going to complete this?

Is using a different library other than python-notify possible? The Fedora maintainer for this library has just retired it because it no longer compiles and they don't wish to maintain it. Upstream has also not released anything new in over 10 years. I see your python 3 trac ticket mentions a replacement, but are you ready to switch to it?

Cas
Top Bloke
Top Bloke
Posts: 3643
Joined: Mon Dec 07, 2009 6:04 am
Location: Scotland

Re: Python3 or changing python-notify requirement

Postby Cas » Thu Sep 27, 2018 8:33 am

Python 3 support is in progress, about 90% there and on my roadmap.

For python-notify, it is optional (for Notifications plugin) but afaik we can trivially replace it with pygi calls to libnotify or with notify2.

mooninite
New User
New User
Posts: 8
Joined: Sat Aug 22, 2015 4:05 am

Re: Python3 or changing python-notify requirement

Postby mooninite » Thu Sep 27, 2018 1:28 pm

Thanks for the update.

If you need any testing feel free to reach out. There are a good amount of users on Fedora that could provide feedback.


Return to “Development”

Who is online

Users browsing this forum: No registered users and 7 guests