Page 21 of 21

Re: Deluge 2.0 Beta 1

Posted: Tue Jun 11, 2019 2:46 pm
by Cas
jeps wrote:When trying to install U get this:
Depends: deluge-common (= 2.0.0-0~201906082034~ubuntu18.04.1) but 2.0.0.dev7437+bd4a3cb+201905231502~ubuntu18.04.1 is to be installed


Ah a mistake with debian versioning. I have fixed this by bumping the version to 2.0.2

jeps wrote:I am out of luck, no build for Ubuntu 16.04?
Would you consider adding this version too?


I could but it requires Twisted 17 which is not available and would require installing separately...

Feriman wrote:I tried it, but the deluge-webui package is not available.


deluge-web is the name of the package (deluge-webui was dropped long ago)

Re: Deluge 2.0 Beta 1

Posted: Tue Jun 11, 2019 3:37 pm
by Feriman
@Cas, if I'm using Raspbian, which repository should I use to install Deluge 2.0.2?

Re: Deluge 2.0 Beta 1

Posted: Tue Jun 11, 2019 6:53 pm
by jeps
Hi again,

Wasn't aware of the "Twisted 17 issue", just thought that, as the dev version has been available for version 16.04, the release version would be as well.
Doesn't the dev version require Twisted 17?

Re: Deluge 2.0 Beta 1

Posted: Tue Jun 11, 2019 8:50 pm
by Cas
Feriman wrote:@Cas, if I'm using Raspbian, which repository should I use to install Deluge 2.0.2?

You might be better installing from https://pypi.org/project/deluge/

There are two options for daily libtorrent PPAs:

https://launchpad.net/~libtorrent.org/+ ... /1.2-daily
https://launchpad.net/~libtorrent.org/+ ... -1.1-daily

jeps wrote:Doesn't the dev version require Twisted 17?

Yes but if you have installed Twisted with python pip it would not be an issue. I only noticed recently that 16.04 has Twisted 16 and Deluge code requires 17. I could add it to the PPA but would need instructions for users to install Twisted 17 or I provide all the required packages in the PPA...

Re: Deluge 2.0 Beta 1

Posted: Thu Jun 13, 2019 5:06 am
by jeps
Hi Cas.

So, can I hope for a 16.04 build or is that off the table.
Unfortunately my "live environment" cannot upgrade to 18.04, so I am stuck on 16.04.

Is it okay to install the latest version (available) of Twisted or does it have to be version 17.xx

Re: Deluge 2.0 Beta 1

Posted: Thu Jun 13, 2019 9:27 am
by Cas
I have updated the stable PPA for Xenial and you can install twisted >=17 via pip.

Code: Select all

sudo pip install twisted

Re: Deluge 2.0 Beta 1

Posted: Thu Jun 13, 2019 11:20 am
by Cas
I shall lock this thread since it is get long and is outdated. Please use the support section of the forum or create an ticket for any further issues.