Please fix this: TCP: request_sock_TCP: Possible SYN flooding on port X. Sending cookies. Check SNMP counters.

Suggestions and discussion of future versions
Post Reply
kjY5bxJ6suLcdJfr
New User
New User
Posts: 2
Joined: Mon Jul 26, 2021 5:05 am

Please fix this: TCP: request_sock_TCP: Possible SYN flooding on port X. Sending cookies. Check SNMP counters.

Post by kjY5bxJ6suLcdJfr »

Hi,

I'm running deluge 2.1.1 on Manjaro. I get this message for the incoming port. It causes extreme slow upload speeds.
If I turn off syncookies requests get dropped. It must be a hardcoded value in deluge (TCP Listen Backlog, see https://access.redhat.com/solutions/30453). Changing parameters in sysctl has no effect.

I get this error with another python 3 based program (pyload). In this case, it's the web ui port. It doesn't cause any problems.

Testet qb and I don't get this error.

Code: Select all

ss -ntlp | more 
shows Send-Q 5 for deluged and pyload. For example, qb has 30.

Please fix this since it causes slow upload speed. Thank you!
Cas
Top Bloke
Top Bloke
Posts: 3683
Joined: Mon Dec 07, 2009 6:04 am
Location: Scotland

Re: Please fix this: TCP: request_sock_TCP: Possible SYN flooding on port X. Sending cookies. Check SNMP counters.

Post by Cas »

Which port are you getting the SYN flooding messages for?

What version of libtorrent are you using? libtorrent handles the bittorrent listen sockets so that it could be a setting or bug that needs resolved there.
kjY5bxJ6suLcdJfr
New User
New User
Posts: 2
Joined: Mon Jul 26, 2021 5:05 am

Re: Please fix this: TCP: request_sock_TCP: Possible SYN flooding on port X. Sending cookies. Check SNMP counters.

Post by kjY5bxJ6suLcdJfr »

Thanks for reply.

Port 54979 and libtorrent-rasterbar-1:2.0.7-1.

I just found the setting in libtorrent:

Code: Select all

listen_queue_size
The default value is 5. Same in pyload's web server cheroot. I increased the value there and the kernel messages disappeared.

Under

Code: Select all

  # Increase the alert queue size so that alerts don't get lost.
        self.alert_queue_size = 10000
        self.set_alert_queue_size(self.alert_queue_size)
in alertmanager.py I added

Code: Select all

        component.get('Core').apply_session_setting(
                 'listen_queue_size', 512
        )
The message does not appear anymore.
Post Reply