Thin Client on 2.x

Suggestions and discussion of future versions
Post Reply
tugurlann
Member
Member
Posts: 26
Joined: Sun Dec 14, 2014 1:01 am

Thin Client on 2.x

Post by tugurlann »

Hello,

Has anyone tried to set up 2.x as a thin client / headless daemon?

If so, what should one look out for, compared with the guide for 1.x at https://dev.deluge-torrent.org/wiki/Use ... ThinClient

Thank you.
papagoejoe
New User
New User
Posts: 2
Joined: Thu Jul 04, 2019 11:27 pm

Re: Thin Client on 2.x

Post by papagoejoe »

I use it like that. I run the docker image, and it is really easy.

You can just fire up the container and visit the webui in a browser. From there you can change the password and enable remote connections.

Then configure your client as described in Client Setup. Use localclient as username or you can add a new user like described in Add User to the authentication file but make sure you edit the auth file that is found in the location you have mounted as the /config folder of your docker container.
tugurlann
Member
Member
Posts: 26
Joined: Sun Dec 14, 2014 1:01 am

Re: Thin Client on 2.x

Post by tugurlann »

Hello,

I'm unable to connect with the thin client on 2.x

The stable version does not see the daemon on the remote machine

The unofficial windows installer does not seem to like the credentials, even though it sees the daemon online.

Anybody else tried this?

Thanks.
Cas
Top Bloke
Top Bloke
Posts: 3650
Joined: Mon Dec 07, 2009 6:04 am
Location: Scotland

Re: Thin Client on 2.x

Post by Cas »

Can you more specific about what version client and server and any errors?
tugurlann
Member
Member
Posts: 26
Joined: Sun Dec 14, 2014 1:01 am

Re: Thin Client on 2.x

Post by tugurlann »

Thin Client 2.0.4.dev38 - windows 10 - inside the LAN

Server: 2.0.3 - ubuntu - remote machine inside the LAN
libtorrent: 1.2.15.0

I suspect it's a question of some auth file somewhere, since the thin-client does actually talk to the daemon as the connection has the available icon status

Here's the current listing of

Code: Select all

/var/lib/deluge/.config/deluge/auth
:

Code: Select all

localclient:[hash1]:10
[username]:[plaintext]:10
[username]:[hash2]:10
[username]:[hash1]:10
(square brackets hide the actual content for privacy)

If I were to add a complete new user to use for the thin client <-> remote daemon connection, how would I go about it?
mhertz
Moderator
Moderator
Posts: 1325
Joined: Wed Jan 22, 2014 5:05 am
Location: Denmark

Re: Thin Client on 2.x

Post by mhertz »

There's a thinclient guide on main site btw. In short, copy auth over, or add same user/pass:10 lines, to your windows auth file under %appdata%\deluge, and enable allow_remote e.g just edit core.conf of server deluge profile(ubuntu), with deluged closed. Restart deluged and the windows deluge client to connect. I'm not 100% sure honestly if actually helps anything to have the auth entries under both server and client, but atleast server is required, and then add new host in deluge connection manager on windows client with the credentials just added to said auth file(s).

Edit: Reread your question, and so to add new user, then add new user:pass:10 line to auth of server deluge profile dir, and add same line to auth file in %appdata%\deluge just in case, and restart client/server - add new host to deluge connection manager on windows client, using newly added user credentials of auth file.
tugurlann
Member
Member
Posts: 26
Joined: Sun Dec 14, 2014 1:01 am

Re: Thin Client on 2.x

Post by tugurlann »

Yeah, I just had to add a brand new user to make this work.

None of the ones already present, including the one I've used for the 1.x thin client didn't work.

I guess there's some magic related to how passwords are stored that happens behind the scenes.

The only concern is that password is stored in "clear" in the auth file, but I guess that's neither here nor there.

Cheers.

I have a new problem now: connection settings are not saved between sessions: I have to manually reconnect to the remote daemon every time I start the thin-client as the server entry is removed from the connection list.
Post Reply