Deluge not connecting to peers !

General support for problems installing or using Deluge
bonamin
New User
New User
Posts: 3
Joined: Thu Mar 18, 2021 12:52 pm

Deluge not connecting to peers !

Postby bonamin » Fri Mar 26, 2021 12:43 am

Hello everyone.

I am having a bit of trouble with deluge and I'd like your input on it.

I have Deluge setup in a Docker container on my Unraid Server. Specifically, I had the latest version installed but I couldn't get some Plugins to work, so now I have 1.3.15 (if I'm not mistaken). Everything was working fine for a couple of days. I had some minor issues which I resolved by searching online. This forum helped a lot as well.

The problem (big one) I'm having now is this:

My torrents, download very VERY slowly, or just stop downloading all-together, and I see almost no peers on both Seeds and Peers column. Maybe less than 10 peers max.
The weird thing is that the same exact torrents, download just fine, actually at full-speed (or as much as my Internet allows) on uTorrent on my PC for example.
Another weird thing as well, is that CERTAIN torrents, actually download fine on Deluge too. I tried a torrent of Ubuntu for example, and it downloads just fine.


Can you guide me on what I need to look for ?
I'd much appreciate your input, and your help.

Have a nice day, and thanks in advance.

(PS. I'm not entirely new to computers, but dockers, and command lines are kinda new to me at this point. So maybe I won't fully understand a possible solution, but I hope we can figure something out. Thanks again guys.)

shamael
Compulsive Poster
Compulsive Poster
Posts: 638
Joined: Sat Oct 08, 2016 9:28 am

Re: Deluge not connecting to peers !

Postby shamael » Fri Mar 26, 2021 10:03 am

Hi,

First thing to check:
- libtorrent version binded with Deluge: Version 1.3.15 work with libtorrent 1.0.x and 1.1.x but not 1.2.x
- port binding well configured, port forwarding on the router, such things
- setting: have a look at ltconfig to tweak libotorrent value. It should help about performance but not erratic behaviour however

The docker setup is unknown but may be involved too of course (some topic on this forum)

bonamin
New User
New User
Posts: 3
Joined: Thu Mar 18, 2021 12:52 pm

Re: Deluge not connecting to peers !

Postby bonamin » Fri Mar 26, 2021 1:09 pm

Hello Shamael and thank you for your input !

I upgraded again to the latest version of Deluge, because I had the binhex repo version. Now I installed from Linuxserver repository, in hope of maybe fixing the issue.

Currently:

- my libtorrent version is 1.1.5.0 !
- The ports are configured in my Routers port forwarding control panel. Spcifically 58846 & 58946.
- I have already tried all 4 settings of Itconfig in the oldest (binhex-deluge) version. No results.

I actually downgraded only to install Itconfig as I read by many that it might fix the problem. It did not, sadly.

Any other ideas ? Someone ? :(

User avatar
gderf
Seeder
Seeder
Posts: 155
Joined: Sat Jun 18, 2016 1:32 am

Re: Deluge not connecting to peers !

Postby gderf » Fri Mar 26, 2021 3:32 pm

bonamin wrote:
- The ports are configured in my Routers port forwarding control panel. Spcifically 58846 & 58946.


Can you explain the purpose of these router port forwards?

bonamin
New User
New User
Posts: 3
Joined: Thu Mar 18, 2021 12:52 pm

Re: Deluge not connecting to peers !

Postby bonamin » Fri Mar 26, 2021 4:11 pm

I don't understand your question. :(

Do you mean

- "Why we port-forward in general?"
- "Why I port-forwarded these SPECIFIC ports?"
- "Why I port-forwarded at all?"

Well, I am not an expert to answer the first possible question, but I think we port-forward so that computers outside out network, can talk to specific computers inside our network. If I'm not mistaken.

If the question is No.2, I port-forwarded these specific ports, as these ports are what my Docker says that Deluge uses.

If its the third question, I tried to port-forward as I thought that needs to be done ?


I might be wrong. If I was right I wouldn't ask for advice anyway :D.
But I honestly think I didn't need to do this anyway, since the program does that for me by talking to the router using UPnP. Right ?

I REALLY don't know almost anything about networking to make assumptions. Only what I'm reading online.

User avatar
gderf
Seeder
Seeder
Posts: 155
Joined: Sat Jun 18, 2016 1:32 am

Re: Deluge not connecting to peers !

Postby gderf » Fri Mar 26, 2021 9:20 pm

Post the full name and tag of the docker image you are using and exactly how you configured it to run. This is important, as you can't get meaningful help with a docker instance without revealing this fully.

Port 58846 has nothing to do with peer connections and you should never expose that port to the internet unless you know exactly what you are doing. It is the default daemon listening port for the gtk client to connect to.

Use of port 58946 is questionable and if you cannot find a technical explanation of its purpose you shouldn't use it and shouldn't expose it to the internet.

Don't rely on UPnP to reliably work with dockers, especially if you don't know what network configuration it even has a chance of working with.


Return to “Support”

Who is online

Users browsing this forum: No registered users and 11 guests