High CPU usage when downloading

General support for problems installing or using Deluge
jabbarwack
New User
New User
Posts: 2
Joined: Fri Mar 05, 2021 2:50 am

High CPU usage when downloading

Postby jabbarwack » Fri Mar 05, 2021 2:53 am

Hello, I get very high CPU usage (80-90%) when downloading a single torrent. I'm using the container linuxserver/deluge. Is there a solution to this? thanks

shamael
Compulsive Poster
Compulsive Poster
Posts: 636
Joined: Sat Oct 08, 2016 9:28 am

Re: High CPU usage when downloading

Postby shamael » Fri Mar 05, 2021 9:19 am

Hi,

It may be linked to the filesystem used on the destination disk. Example: using ntfs on a Linux box drastically raise the CPU usage for any disk operation. The container maybe part of the picture but I'm not using it so cannot tell.

jabbarwack
New User
New User
Posts: 2
Joined: Fri Mar 05, 2021 2:50 am

Re: High CPU usage when downloading

Postby jabbarwack » Fri Mar 05, 2021 10:30 pm

thanks for your response shamael. I'm using ubuntu and formatted my drives with ext4, using RAID1. Do you think there might be a problem there? If so, do you know how I can resolve it? thanks for your time.

shamael
Compulsive Poster
Compulsive Poster
Posts: 636
Joined: Sat Oct 08, 2016 9:28 am

Re: High CPU usage when downloading

Postby shamael » Mon Mar 08, 2021 11:47 am

EXT4 is perfect, I'm using it too on an RPI...It not the root cause. The RAID1 driver maybe?
Restricting to 1 the number of download is the good way to start troubleshooting, you're right at this level.
I'm not experienced with container but as a basic:
- the download folder is well on the R1 directly?
- if you do a DD test to output your disk performance, nothing specific?
- do you preallocate torrent space in the Deluge setting? Give it a try if not
- In the past I troubleshooted some issue on my setup with "iostat -x1", from systat package. The high CPU usage can we wait CPU cycle either from disk queuing or network. This helped me tracking the root cause. May you give it a try to at least pinpoint the high cpu usage root cause.


Return to “Support”

Who is online

Users browsing this forum: Google [Bot] and 21 guests