move storage not working

General support for problems installing or using Deluge
DannyB
New User
New User
Posts: 5
Joined: Tue Mar 02, 2021 2:30 pm

move storage not working

Postby DannyB » Tue Mar 02, 2021 2:39 pm

Hello,

I have been trying to use the "move storage" features for a fews days without success :/
I thought it was a permissions problem but even by putting my whole disk in 777 (i know it is bad ^^ ) it still doesn't work.
I ony succeed when moving the files in my download folder to a subfolder (like download/music ) but not when i try to move them in the same disk but in a parent folder

Is there anything i missed?

Thanks a lot for your help and work

ashmandias
Member
Member
Posts: 20
Joined: Thu Feb 11, 2021 7:12 pm

Re: move storage not working

Postby ashmandias » Tue Mar 02, 2021 3:19 pm

Are you using selinux, apparmor, or anything similar?

DannyB
New User
New User
Posts: 5
Joined: Tue Mar 02, 2021 2:30 pm

Re: move storage not working

Postby DannyB » Tue Mar 02, 2021 3:29 pm

I am using OpenMediaVault

ashmandias
Member
Member
Posts: 20
Joined: Thu Feb 11, 2021 7:12 pm

Re: move storage not working

Postby ashmandias » Tue Mar 02, 2021 3:46 pm

Ok, does openmediavault use selinux, apparmor, or anything similar? If so, that is likely the issue.

DannyB
New User
New User
Posts: 5
Joined: Tue Mar 02, 2021 2:30 pm

Re: move storage not working

Postby DannyB » Tue Mar 02, 2021 3:52 pm

No it doesn't :/

shamael
Compulsive Poster
Compulsive Poster
Posts: 636
Joined: Sat Oct 08, 2016 9:28 am

Re: move storage not working

Postby shamael » Wed Mar 03, 2021 9:50 am

Define a specific folder and check the permission of this folder: can you output the permission for the user/group used by Deluge?

ashmandias
Member
Member
Posts: 20
Joined: Thu Feb 11, 2021 7:12 pm

Re: move storage not working

Postby ashmandias » Wed Mar 03, 2021 1:12 pm

use the command 'namei -l' to validate the permissions on the location (use the full path to the location, not a relative one) that fails, and contrast that to one that works.

DannyB
New User
New User
Posts: 5
Joined: Tue Mar 02, 2021 2:30 pm

Re: move storage not working

Postby DannyB » Wed Mar 03, 2021 10:16 pm

The folder i am using to download, and that works :
/srv/dev-disk-by-uuid-bd903e25-65c9-420a-9af8-51c87b194ac1/Download/

i get following rights for it usin namei command (thanks for this tips) :
drwxrwxr-x root root /
drwxr-xr-x root root srv
drwxrwxrwx root root dev-disk-by-uuid-bd903e25-65c9-420a-9af8-51c87b194ac1
drwxrwsrwx root users Download

The foltre where i try for move some of my torrent is
/srv/dev-disk-by-uuid-bd903e25-65c9-420a-9af8-51c87b194ac1/Series/
with basically same rights :
drwxrwxr-x root root /
drwxr-xr-x root root srv
drwxrwxrwx root root dev-disk-by-uuid-bd903e25-65c9-420a-9af8-51c87b194ac1
drwxrwsrwx root users Series

@shamael : i assumed that the user used by Deluge is deluge, and i already added him to users group


Is there any way/where to read why a torrent files aren't moved?

shamael
Compulsive Poster
Compulsive Poster
Posts: 636
Joined: Sat Oct 08, 2016 9:28 am

Re: move storage not working

Postby shamael » Thu Mar 04, 2021 9:19 am

It depends how your launch deluge and which tutorial you followed (by hand, cron, systemD unit).
If you followed the tutorial on this site the user and group should be deluge indeed
You can simply check with

Code: Select all

ps aux|grep deluged


We can see your folder is owned by root:root, and deluge is certainly not part of the root group. From your output that's the catch.
Change the owner of your destination folder (and all subfolders) to deluge:deluge will solve your issue, below command should do it (confirm first the user and group are well good ones)

Code: Select all

sudo chown -R deluge:deluge /srv/dev-disk-by-uuid-bd903e25-65c9-420a-9af8-51c87b194ac1

DannyB
New User
New User
Posts: 5
Joined: Tue Mar 02, 2021 2:30 pm

Re: move storage not working

Postby DannyB » Thu Mar 04, 2021 8:12 pm

Hey!
It dit it indeed :)
Thanks a lot!!!

I didn't know the parent folder had to belong (or at leaset to the group) to the user


Return to “Support”

Who is online

Users browsing this forum: No registered users and 11 guests