deluge does not start anymore

General support for problems installing or using Deluge
Posts: 14
Joined: Tue Sep 19, 2017 8:39 am

deluge does not start anymore

Postby 247 » Sun Jan 10, 2021 5:50 pm

hello, i was having some problems with deluge so decided to wipe everything and do a clean install. Now the app is not starting at all, any help?

the terminal output is

Code: Select all

Traceback (most recent call last):
  File "/usr/bin/deluge", line 33, in <module>
    sys.exit(load_entry_point('deluge==2.0.3', 'gui_scripts', 'deluge')())
  File "/usr/bin/deluge", line 22, in importlib_load_entry_point
    for entry_point in distribution(dist_name).entry_points
  File "/usr/lib64/python3.9/importlib/", line 524, in distribution
    return Distribution.from_name(distribution_name)
  File "/usr/lib64/python3.9/importlib/", line 187, in from_name
    raise PackageNotFoundError(name)
importlib.metadata.PackageNotFoundError: deluge

i'm on fedora workstation 33, if that's helpful...

New User
New User
Posts: 2
Joined: Sun Aug 30, 2020 11:23 am

Re: deluge does not start anymore

Postby megaksa » Sat Feb 27, 2021 10:34 am

Echo this. Just tried to upgrade to the latest available on Arch:

Code: Select all

Deluge version: 2.0.4.dev38+g23a48dd01-3
Distro: 5.9.10-arch1-1

Seeing the same error:

Code: Select all

$ journalctl -u deluged
deluged[252]: Traceback (most recent call last):
deluged[252]:   File "/usr/bin/deluged", line 33, in <module>
deluged[252]:     sys.exit(load_entry_point('deluge==2.0.4.dev38', 'console_scripts', 'deluged')())
deluged[252]:   File "/usr/bin/deluged", line 22, in importlib_load_entry_point
deluged[252]:     for entry_point in distribution(dist_name).entry_points
deluged[252]:   File "/usr/lib/python3.8/importlib/", line 504, in distribution
deluged[252]:     return Distribution.from_name(distribution_name)
deluged[252]:   File "/usr/lib/python3.8/importlib/", line 177, in from_name
deluged[252]:     raise PackageNotFoundError(name)
deluged[252]: importlib.metadata.PackageNotFoundError: deluge
systemd[1]: deluged.service: Main process exited, code=exited, status=1/FAILURE

Had to roll back to `2.0.4.dev38+g23a48dd01-2`

Compulsive Poster
Compulsive Poster
Posts: 1065
Joined: Wed Jan 22, 2014 5:05 am
Location: Denmark

Re: deluge does not start anymore

Postby mhertz » Sat Feb 27, 2021 4:27 pm

megaksa, deluge's latest version in [extra] is "built" with/for py3.9(.2) likewise in [extra], and you're using py3.8 your logging shows. Previous version that you downgraded to, where py3.8.

247, so if typing python in a terminal and running import deluge, then that fails? Btw, deluge can be startet manually from python through 'from deluge.ui.ui_entry import start_ui; start_ui()'. Hmm, there's maybe an issue with the lib64 vs regular lib, e.g. you have it maybe in regular lib. Sorry don't know anything about Fedora. Edit: lol, that's just a symlink I forgot, so probably not that. Edit2: Hmm, sorry that is my distro, which is x64 only, but maybe not a symlink on Fedora, dunno as said.

New User
New User
Posts: 1
Joined: Mon Mar 08, 2021 8:12 am

Re: deluge does not start anymore

Postby aaimaai » Mon Mar 08, 2021 8:23 am

I've attached the stack traces I ran into. I was able to start deluge after installing these pip packages:
sudo pip install appdirs attrs twisted
(4.83 KiB) Downloaded 7 times

Return to “Support”

Who is online

Users browsing this forum: No registered users and 13 guests