Deluge Port Forwarding Issue

General support for problems installing or using Deluge
New User
New User
Posts: 1
Joined: Thu Dec 24, 2020 2:49 am

Deluge Port Forwarding Issue

Postby cobolsam » Thu Dec 24, 2020 2:56 am

I am running Deluge 2.0.3 with libtorrent on ubuntu 20.04. When I run deluge I receive the "port issue" error message in the lower right corner and I don't appear to have any incoming connections and deluge reports my external IP as n/a.

I am certain that my port is forwarded correctly and have verified that shows the port open and have tried transmission and am able to receive incoming connections with that client.

Can anyone offer guidance on what I could try to do to resolve this? I am not sure what logs are helpful with troubleshooting this.

New User
New User
Posts: 1
Joined: Sat Dec 26, 2020 9:42 pm

Re: Deluge Port Forwarding Issue

Postby arielCo » Sat Dec 26, 2020 9:48 pm

Same here. Deluge 2.0.3, libtorrent on Windows 10. Using UPnP.

The router shows two forwardings (TCP,UDP), helpfully named “Deluge/2.0.3 libtorrent/”. confirms my port is open.

And I do have inbound connections:

Code: Select all

> Get-NetTCPConnection -OwningProcess $(Get-Process -name deluged).id  -LocalPort 63097 | ?{ $_.LocalAddress -like "192.*" }

LocalAddress  LocalPort RemoteAddress   RemotePort State       AppliedSetting
------------  --------- -------------   ---------- -----       --------------  63097         0          Listen   63097   64835      Established Internet   63097     54252      LastAck     Internet   63097   53517      FinWait1    Internet   63097         0          Listen

But the built-in port test displays a big ⚠.

So, it's no biggie but maybe worth looking into at some point.

Return to “Support”

Who is online

Users browsing this forum: No registered users and 14 guests