Deluged Crashes on Startup post python3-libtorrent 1.2.10_git20201018

General support for problems installing or using Deluge
guy_montag
New User
New User
Posts: 1
Joined: Mon Oct 26, 2020 12:59 pm

Deluged Crashes on Startup post python3-libtorrent 1.2.10_git20201018

Postby guy_montag » Mon Oct 26, 2020 1:13 pm

Running on Ubuntu x64 20.04 LTS fully updated.

I'm not an expert and this may be more of an FYI but it seems deluged 2.0.3-2 is not yet compatible with the latest version of python3-libtorrent.

After upgrading python3-libtorrent to 1.2.10_git20201018 (which comes with qBittorrent 4.3.0.1 out of their PPA repository), deluged 2.0.3-2 crashes on startup with error

$ Traceback (most recent call last):
File "/usr/lib/python3/dist-packages/deluge/_libtorrent.py", line 23, in <module>
import deluge.libtorrent as lt
ModuleNotFoundError: No module named 'deluge.libtorrent'

This happened after installing / upgrading qBittorrent to 4.3.0.1 from their PPA repository as it seems there is now a dependency from the latest version of qBittorrent to a later version of python3-libtorrent.

Reverting to qBittorrent 4.2.5 clears the problem - as would reverting to the much older version in the Ubuntu repository.

So I'm not saying it's a deluge problem - but it would be good if you could run the latest versions of both programs in parallel.

Is there a way of making different versions of python3-libtorrent available to the two programs ?

taysix
New User
New User
Posts: 4
Joined: Thu Nov 05, 2020 9:09 pm

Re: Deluged Crashes on Startup post python3-libtorrent 1.2.10_git20201018

Postby taysix » Thu Nov 05, 2020 9:23 pm

I just ran into this issue as well. I'm on Ubuntu 18.04.
I'd add this to the bug tracker but I don't know how.

I'm not very familiar with how package management is supposed to work, but how can I downgrade python3-libtorrent or install an older version of qbittorrent?? I can't figure out how to do this with apt-get. I can only install the latest version because that's all I see available on https://launchpad.net/~qbittorrent-team ... ent-stable

Are old packages not archived and reachable from somewhere? Thanks for any help/pointers anyone can provide!

taysix
New User
New User
Posts: 4
Joined: Thu Nov 05, 2020 9:09 pm

Re: Deluged Crashes on Startup post python3-libtorrent 1.2.10_git20201018

Postby taysix » Thu Nov 05, 2020 9:37 pm

Figured it out. Not ideal but meh

Code: Select all

sudo apt-get install python3-libtorrent=1.1.5-1build1 libtorrent-rasterbar9=1.1.5-1build1


and then put both on hold to avoid upgrading

Code: Select all

sudo apt-mark hold python3-libtorrent
sudo apt-mark hold libtorrent-rasterbar9


Return to “Support”

Who is online

Users browsing this forum: No registered users and 9 guests