No incoming connections/Test Active Port

General support for problems installing or using Deluge
bmcelvan
New User
New User
Posts: 3
Joined: Fri Oct 16, 2020 1:47 am

No incoming connections/Test Active Port

Postby bmcelvan » Fri Oct 16, 2020 2:07 am

I've been struggling with this for a while now and am hoping someone can help me out.

I have the red error No Incoming Connections on the bottom of the screen and have for a while. Also, in the preferences-->Network section, when I click the Test Active Port it never tests successfully. Also, when I load that page it always says Active Port 0.

Can someone help me set this up properly and possibly help me with the port forwarding.

Currently, in my netgear router I have these settings set up in port forwarding (See images below):
I'm using TDP/UDP, should I only be using one or the other?
I am trying to use ports 50000-51000 open on the current IP of my PC 192.168.1.3

On the deluge side, in preferences-->network
I do not have random ports selected, I have both incoming and outgoing set to 50000 to 51000.
I don't have anythign listed for Interface (should this have an IP listed here?)
and I have everything encrypted. What else should I do? I have a VPN but for these tests I have kept it off and have disabled the proxy in Deluge also just to see if I can get an active port?

Any help would be much appreciated!!

Thanks
Attachments
Netgear.jpg
Netgear.jpg (186.46 KiB) Viewed 99 times
Deluge.jpg
Deluge.jpg (192.69 KiB) Viewed 100 times

shamael
Compulsive Poster
Compulsive Poster
Posts: 591
Joined: Sat Oct 08, 2016 9:28 am

Re: No incoming connections/Test Active Port

Postby shamael » Tue Oct 20, 2020 1:56 pm

Hi,

From what I remember the test failed with VPN and possibly proxy, but you stated they are off. I never limit the internal port, just external. You can make the test this way to confirm at least it works. An alert will be present upon the first inbound connection.

- computer: static IP mandatory
- Deluge:
incoming port range 50000-51000
outgoing port random
disable uPNP, al lthe others too if you are on private trackers
Encryption: do not force for the moment, it won't help you anyway for privacy matter.
- router: configure external port only, TCP and UDP
- computer: no internal firewall (Windows or Linux iptable)?

Deluge will only use a single port in your range, so the active port "0" is an issue. It should tell your the one it picked up.
Test external reachability with something like https://www.yougetsignal.com/tools/open-ports/


Return to “Support”

Who is online

Users browsing this forum: Ouroboruss and 15 guests