No longer downloading on 2.0.3-12

General support for problems installing or using Deluge
drj555
New User
New User
Posts: 2
Joined: Fri Aug 28, 2020 8:47 am

No longer downloading on 2.0.3-12

Postby drj555 » Fri Aug 28, 2020 8:56 am

Hi, can you help?

I have Deluge running on Synology NAS using the Deluge package (not through Docker). It has been working flawlessly for more than a year. I have the 2 ports correctly forwarded (8112 and 6881). I use Socks5 through PIA.

Recently I had a notification through synology that there was a Deluge update, so I did this and am now on 2.0.3-12.

I can still contact the deluge daemon using the web interface. However, all active torrents are now marked as "queued" even though I can see how many peers are available. I can't seem to activate the torrent.

Also, when I attempt to connect to the daemon using the windows app (version 1.3.15) the server is marked with a red circle under status and I can't connect.

Finally, when I add a new torrent I note they are assigned to another user on the left hand panel. All old torrents are assigned to "localclient" and new torrents are assigned to my username. I have not seen this behaviour before.

Any idea what be going on?

Cheers

shamael
Compulsive Poster
Compulsive Poster
Posts: 583
Joined: Sat Oct 08, 2016 9:28 am

Re: No longer downloading on 2.0.3-12

Postby shamael » Fri Aug 28, 2020 1:10 pm

Hi,

Some answers at least: you've installed the the version 2.0.X package on the NAS, you need to update the GTK client on Windows the same version. They are not compatible. Check this topic for the unofficial version 2 Windows client: viewtopic.php?f=12&t=55463

The new version is multi-user by default, I guess it's the reason you have different torrent owners

The problem with download you face too seems at a first glance linked to the network part of your configuration. Maybe make some test by putting all torrent in pause state, revert to a config w/o proxy, and test the router port NAT with a public torrent like the one on the Ubuntu site. No risk with them. this way you can gradually test each part of the setup. Configuring the daemon log may help to of course (see the support section for how to)

drj555
New User
New User
Posts: 2
Joined: Fri Aug 28, 2020 8:47 am

Re: No longer downloading on 2.0.3-12

Postby drj555 » Fri Aug 28, 2020 11:35 pm

Thanks for that. It looks like there a were a few different issues.

I see the windows app is now out of date. I'll try the unofficial loader you linked. thanks.

There are now different "owners", so all newly added torrent will go under my username.

I have managed to get it working. There was some issue with the "auto manage" function. I turned that off and forced resume and they worked. I think I had too many open torrents, even though they weren't all active, and the auto manage was confused. This feature must handle things slightly differently than the last version as I have never seen this before even with 10s of torrents open. I've done a clear out and it's all working fine now.


Return to “Support”

Who is online

Users browsing this forum: No registered users and 6 guests