Page 1 of 1

Kernel 5.7.x: Torrent id not in torrents loading list -- Torrents never start after being added

Posted: Tue Jun 30, 2020 2:28 pm
by wingnut
Arch Linux, x86_64, this log came from kernel 5.7.6
Deluge works great in kernel 5.6.15

I have run into issues with all 5.7.x kernels I have tried. If I go into the /srv/deluge/.config/deluge directory and get rid of the various state files, I can get currently stalled torrents to start, but this only works on the ones that are already added. New torrents load and never start.

From the Deluge-WebUI, the status of the stalled torrents says that Deluge can't reach the tracker. I can't recall the exact words. If you need that I'll get the message for you.

I added a magnet from Firefox using the Xirvik extension and it worked fine. The other torrents were added by Sonarr.

Perhaps this has something to do with a Python library and kernel 5.7.x. Is there somewhere else I could look for logged errors?

I don't have Arch Linux installed anywhere else on an x86_64 machine; the other Arch installs have older versions. I might be able to test this in a Fedora installation.

The pertinent error seems to be "Torrent id not in torrents loading list:" but of course I may be mistaken.

Thanks for listening. Any help is appreciated.

Code: Select all

10:00:28.681 [INFO    ][deluge.core.daemon            :94  ] Deluge daemon 2.0.4.dev38
10:00:28.709 [INFO    ][deluge.core.core              :339 ] Successfully loaded session.state: /srv/deluge/.config/deluge/session.state
10:00:28.717 [INFO    ][deluge.core.core              :339 ] Successfully loaded session.state: /srv/deluge/.config/deluge/session.state.bak
10:00:28.719 [INFO    ][deluge.core.alertmanager      :148 ] Alert Queue Size set to 10000
10:00:28.788 [INFO    ][deluge.core.rpcserver         :402 ] Starting DelugeRPC server :58846
10:00:28.797 [INFO    ][twisted                       :154 ] Factory (TLS) starting on 58846
10:00:28.797 [INFO    ][twisted                       :154 ] Starting factory <twisted.internet.protocol.Factory object at 0x7fbc0b4fe8b0>
10:00:28.799 [INFO    ][deluge.core.daemon            :154 ] Deluge daemon starting...
10:00:28.807 [WARNING ][deluge.pluginmanagerbase      :132 ] Cannot enable non-existant plugin CopyMagnetURI
10:00:28.961 [WARNING ][deluge.config                 :405 ] Unable to open config file /srv/deluge/.config/deluge/web_plugin.conf: [Errno 2] No such file or directory: '/srv/deluge/.config/deluge/web_plugin.conf'
10:00:28.962 [INFO    ][deluge.pluginmanagerbase      :189 ] Plugin WebUi enabled...
10:00:28.962 [WARNING ][deluge.pluginmanagerbase      :132 ] Cannot enable non-existant plugin WebAPI
10:00:28.976 [INFO    ][deluge_label.core             :78  ] *** Start Label plugin ***
10:00:28.977 [INFO    ][deluge.pluginmanagerbase      :189 ] Plugin Label enabled...
10:00:28.978 [INFO    ][deluge.core.authmanager       :228 ] Opening auth for load: /srv/deluge/.config/deluge/auth
10:00:28.978 [INFO    ][deluge.core.authmanager       :236 ] Successfully loaded auth: /srv/deluge/.config/deluge/auth
10:00:28.979 [INFO    ][deluge.core.torrentmanager    :806 ] Loading torrent state: /srv/deluge/.config/deluge/state/torrents.state
10:00:28.979 [INFO    ][deluge.core.torrentmanager    :822 ] Successfully loaded /srv/deluge/.config/deluge/state/torrents.state
10:00:28.979 [INFO    ][deluge.core.torrentmanager    :1069] Opening torrents.fastresume for load: /srv/deluge/.config/deluge/state/torrents.fastresume
10:00:28.980 [INFO    ][deluge.core.torrentmanager    :1080] Successfully loaded torrents.fastresume: /srv/deluge/.config/deluge/state/torrents.fastresume
10:00:28.980 [INFO    ][deluge.core.torrentmanager    :885 ] Finished loading 0 torrents in 0:00:00.001731
10:00:32.256 [INFO    ][deluge.core.rpcserver         :171 ] Deluge Client connection made from:
10:02:13.638 [INFO    ][deluge.core.torrentmanager    :668 ] Torrent something.mkv from user "localclient" added
10:02:13.646 [WARNING ][deluge.core.torrentmanager    :1258] Torrent id not in torrents loading list: 'hash goes here'

Re: Kernel 5.7.x: Torrent id not in torrents loading list -- Torrents never start after being added

Posted: Fri Jul 10, 2020 11:35 pm
by wingnut
I'm not sure why Deluge never complained before about the missing plugins shown in my log, but they have been missing since Arch released their Deluge 2.0 package (they were for python 2.7) and I never had a problem until the 5.7 Linux kernel release.

It took a few edits of the Deluge core.conf file to make the changes stick. The plugins kept reappearing after I removed their entries from the file. Once I moved the various core.conf backup files out of the directory, the edit stuck and I was able to load Deluge without those annoying missing plugin errors in the log. After a restart and a reinstall of kernel 5.7.7, everything worked.

I'm not sure this will help anyone in the future or not, but I'd say if things aren't working, fix every error you see in your logs. They appeared to be minor errors but actually they were significant. And you can always dump the whole configuration directory and start over, but I'd stash it somewhere for later reference.

I guess I won't know for certain if this fix will stick but I was able to send a request from Sonarr and the torrent didn't stall.

That's it. Thanks for listening.

Re: Kernel 5.7.x: Torrent id not in torrents loading list -- Torrents never start after being added

Posted: Tue Jul 14, 2020 12:38 am
by wingnut
I finally noticed that the external IP address was marked as "n/a" in the web interface after a reboot.

Perhaps this should be in boldface red?

There must be a slight diffference in systemd and the unit loading order with my system and kernel 5.7.x. I use a VPN and the Internet wasn't accessible when deluged.service loaded. I have a firewall running, too, and it blocks outbound traffic except on the tun0 interface. It's strange that this didn't happen before.

I made deluged.service wait for my tun0 interface to come up. I followed this guide: ... g-systemd/

I hope this is the solution.