Usually it should be possible to simply rename the plugin's py version to 3.8, or alternatively remove it completely(as it's optional per spec). Py38 is for the most part downwards compatible with 3.7, except some deprecated functions I read, and I've tried it before with success of renaming py 3.6 plugins etc.
Sorry I don't know why you couldn't enable it. I haven't checked, but if your distro features a deluge 2.0.3 package and py3.8.x, then the deluge package mantainer there should have backported a commit from develop branch for py38 logging compatibility support, and use a newer twisted, e.g. 20.3.0, as you will atleast get erors shown during logging otherwise("3 args given, expected 2" messages repeatedly, etc), but I guess will still work, though haven't tried myself. I only have here, either deluge latest dev version, or a 2.0.3 stable with backported compatibility commit and newest twisted, but renaming latest yarss2 from 3.7 to 3.8, I was able to enable it in 2.0.3 and showed up fine, I just tested. Check debug log for errors otherwise, and make sure you're not trying use the v1.x yarss2 version obviously, so if building yourself, build from correct branch/source. Hope you can get it solved hopefully. Good luck.
General support for problems installing or using Deluge
I've not dig this part yet but a wrote womething that may help (really a maybe) viewtopic.php?f=7&t=55654&p=231516&hilit=2+plugin+yarss#p231516
Who is online
Users browsing this forum: No registered users and 11 guests