Deluge isn't seeing my plugin

General support for problems installing or using Deluge
sp00kie
New User
New User
Posts: 8
Joined: Sun Apr 12, 2020 2:23 pm

Deluge isn't seeing my plugin

Postby sp00kie » Sun Apr 12, 2020 3:21 pm

Hi, So I'm trying to add the autoremove plus plugin to my deluge (v.2.0.3). No matter what I do, Deluge just refuses to see the plugin. It copies just fine into the folder but it is not showing up in the list. I tried copying it manually. nope. Tried changing permissions to be the same as the other expernal plugin I have installed - YaRSS. nope.Tried various restarts. Tried creating and viewing the debug logfile. I don't see any errors. I'm totally out of ideas. I'm running Ubuntu 18.04 and I have 3 versions of python installed 2.7, 3.7, and 3.8. I really need that autoremove plus. It's sooooo good.

sp00kie
New User
New User
Posts: 8
Joined: Sun Apr 12, 2020 2:23 pm

Re: Deluge isn't seeing my plugin

Postby sp00kie » Sun Apr 12, 2020 4:29 pm

ok not sure what happened but installing the 0.66 version worked in terms of at least seeing the plugin in my list. The problem now is that it won't activate it.

It gives the following error

19:24:08 [ERROR ][deluge.pluginmanagerbase :1343] No module named 'past'
Traceback (most recent call last):

Cas
Top Bloke
Top Bloke
Posts: 3643
Joined: Mon Dec 07, 2009 6:04 am
Location: Scotland

Re: Deluge isn't seeing my plugin

Postby Cas » Sun Apr 12, 2020 10:31 pm

You will need to install the 'future' python module.

apt install python3-future

Or

pip3 install future

jerry1970
New User
New User
Posts: 6
Joined: Mon Apr 13, 2020 8:14 pm

Re: Deluge isn't seeing my plugin

Postby jerry1970 » Tue Apr 14, 2020 6:26 am

Deluge 2 won't install any plugin. Python version 2.7.17, Deluge version 2.0.3-2-201906121747-ubuntu18.04.1.
I tried AutoRemovePlus-0.6.1-py2.7.egg, CopyMagnetURI-0.2-py2.7.egg, and LabelPlus-0.3.2.2-py2.7.egg.
After installing, the eggs are copied from the Download folder to ~/.config/deluge/plugins, but the interface does not show any of them.
When I re-started deluge with this:

Code: Select all

deluge -L warning -l deluge-log.txt


that deluge-log.txt file remained empty but the terminal showed this:

Code: Select all

(deluge:803): Gtk-WARNING **: 08:21:46.155: Theme parsing error: gtk.css:1090:0: Expected a valid selector


(I have Xubuntu 18.04 with the 'dark-side' theme. I doubt this has anything to do with the plugins not loading.)

Any help would be greatly appreciated.

Thanks!

mhertz
Compulsive Poster
Compulsive Poster
Posts: 1092
Joined: Wed Jan 22, 2014 5:05 am
Location: Denmark

Re: Deluge isn't seeing my plugin

Postby mhertz » Tue Apr 14, 2020 7:01 am

https://github.com/bdutro/deluge-labelplus/releases
https://github.com/springjools/deluge-a ... 0.6.12.egg

You need py3 versions of plugins, and also forks of them for deluge2 support. Copymagneturi didn't work with py3 and deluge2 in official version posted on forum, but I didn't have time to see if there is updated fork. The first link, you need to download the version matching your python3 version. Not needed for latter link, so is direct link.

As Cas answered another user above, you need python3-future (or pip3 install future) for autoremoveplus plugin seemingly.

Edit: if downloading the release version of fork I linked to, of autoremoveplus, then you need future and requests installed, so probably named python3-future and python3-requests. Note, it needs configuring its settings under webui or from config file as not available for configuration from GTKUI. The newest develop version of said plugin, doesn't need future, only requests, and I linked a build I made off it in following ticket, if interested: https://github.com/springjools/deluge-a ... /issues/16


Return to “Support”

Who is online

Users browsing this forum: No registered users and 14 guests