Can't connected from client to server

General support for problems installing or using Deluge
sealse
New User
New User
Posts: 8
Joined: Fri Feb 07, 2020 9:47 pm

Re: Can't connected from client to server

Postby sealse » Tue Jan 26, 2021 5:33 pm

Hi !
with deluge 1.3.15 ubuntu has a big problem with ubuntu-desktop
if I set "sudo apt install ubuntu-desktop" then it install deluge 2.0.3
else if "sudo apt-mark hold deluge" then

Code: Select all

...
The following packages have unmet dependencies:
 deluge : Depends: deluge-gtk (= 1.3.15-2) but 2.0.3-3 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.


Why deluge 2.0.3 can't work with both servers versions? it's real uncomfortable

mhertz
Compulsive Poster
Compulsive Poster
Posts: 999
Joined: Wed Jan 22, 2014 5:05 am
Location: Denmark

Re: Can't connected from client to server

Postby mhertz » Tue Jan 26, 2021 6:56 pm

The RPC communication protocol is incompatible, as revised to support new features and optimizations in deluge2.

Have you tried the apt-pinning from linked instructions i.e running:

Code: Select all

 cat <<EOF | sudo tee /etc/apt/preferences.d/pin-deluge
Package: deluge
Pin: version 1.3.15-2
Pin-Priority: 1337

Package: deluge-common
Pin: version 1.3.15-2
Pin-Priority: 1337

Package: deluge-gtk
Pin: version 1.3.15-2
Pin-Priority: 1337

Package: libtorrent-rasterbar9
Pin: version 1.1.5-1build1
Pin-Priority: 1337
EOF

Though later poster there stated needing use 'sudo apt-mark hold deluge' to fix, as you tried, though unsuccessfully. If the apt-pinning doesn't work, then try instead 'sudo apt-mark hold deluge deluge-common deluge-gtk libtorrent-rasterbar9' i'd suggest.

sealse
New User
New User
Posts: 8
Joined: Fri Feb 07, 2020 9:47 pm

Re: Can't connected from client to server

Postby sealse » Thu Jan 28, 2021 6:03 pm

if sudo apt-mark hold deluge deluge-common deluge-gtk libtorrent-rasterbar9
then

Code: Select all

sudo apt install ubuntu-desktop
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 deluge-common : Depends: python-chardet but it is not installable
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.


Why it is impossible to collect both clients in one application and make a switch between them to use either 1 or 2 version of server?

mhertz
Compulsive Poster
Compulsive Poster
Posts: 999
Joined: Wed Jan 22, 2014 5:05 am
Location: Denmark

Re: Can't connected from client to server

Postby mhertz » Thu Jan 28, 2021 7:18 pm

If you have tried the pinning instructed and not helping, then seemingly you'll have to apt-mark hold every single package you installed previously i.e all the deluge deps too, or atleast im guessing as not really into apt internals. Again, I don't know anything about this, and don't have time troubleshooting this now, so don't know mind you.

It might be possible, sure, but this is not really have this works. The author has choosen this way and contributed his work, and if in disagreance about design-choices then of-course is free to make feature-requests, or fork it and add your own spin to it ;) Cas, lead-dev has been asked about this before and answered like I posted previously.

Last, you could also make a venv of deluge1 if wanted, as I described here for my distro, and another user posted adjusted ubuntu instructions I.e package-names there etc, though I'd guess much easier for you to just apt-mark hold all the relevant packages, if that works, but up to you: viewtopic.php?t=55488


Return to “Support”

Who is online

Users browsing this forum: No registered users and 14 guests