Page 1 of 1

Deluged and delugeweb both running but cant access via web browser

Posted: Sat Dec 28, 2019 12:51 am
by joey7415963
Hi all,

I've been playing around with this for a few days now and despite desperate attempts and many hours searching for an answer, I have not yet found one (that I understand well enough).

I've been following the HTPC guide (link below) for getting deluge to run via a vpn tunnel and have successfully got the vpn tunnel tested and working. I've also continued this guide to install deluge via the repos and run both deluged and deluge-web as a service. When I run systemctl status on them, they are both active and running.

However, when I go to localhost:8112 nothing shows up! No webui, no hint of deluge just that smart ass Microsoft "Hmmm, we can't reach this page" message appears! The most annoying part of it is I had this all working sweetly before I rebuilt my server!

This is all running on Ubuntu 18.04LTS, with my main user "joey", and my vpn traffic user "vpn". Both users are part of each others respective groups and I can confirm that the vpn user is running the two deluge services, deluged and deluge-web, oh and my conf file does use 8112 as the port, and this is forwarded on my router.

I did find one answer that suggested that both users are trying to run deluge at the same time but I'm not sure that's the one. As far as I'm aware I've set the correct folder permissions and ownerships on everything I need to.

If someone could give me some pointers, either in where to go with error checking, or how to implement a fix, I would so appreciate it.

Re: Deluged and delugeweb both running but cant access via web browser

Posted: Wed May 06, 2020 5:54 pm
by joey7415963
Ok, so far I've: Done a fresh install of 20.04, confirmed both deluged.service and deluge-web.service are active and running, checked my router has port 8112 forwarded to my server and I still cannot get access to the webui through http://localhost:8112. It's driving me crazy!

I have noticed there are 3 locations for config files:

/var/lib/deluged/ - this only contains one folder called config and its empty and its owned by the user Debian-deluged
/home/joey/.config/deluge - this contains all the files and folders you would imagine apart from the web.conf, its owned by the user joey
/home/vpn/.config/deluge - this contains all the files and folders as the one above, but with the web.conf file, its owned by the user vpn (the one I want to use deluge)

Please, can someone at least tell me if that's expected? Or if you know what I need to do as I've tried my little heart out to find a solution.

Thank you in advance, I really hope I can get this working again.

Re: Deluged and delugeweb both running but cant access via web browser

Posted: Thu May 07, 2020 7:35 am
by shamael

The configuration is user's profile dependants, multiple users may have different configurations this way. Your service contains a line for the user. When the service start, the configuration will by default be searched in the profile of this user

If "VPN" is the one to use, all settings have to be in its profile and the service have to be launched as vpn . The support section of the homepage as a "service" section with all the info and example ... rvice.html

Re: Deluged and delugeweb both running but cant access via web browser

Posted: Thu May 07, 2020 9:36 am
by joey7415963
Thank you so much for your help, I had to revert everything back to the original user joey in order to get access. :D

Ideally, I'd like to access it via my user called vpn, this has been setup with a split tunnel and is confirmed working. But when I change the user in my systemd files to vpn, I can no longer access the web ui locally, or remotely, although it still confirms it is running.

I have a feeling I'm being really stupid, both joey and vpn are part of each other's groups, can you think of any reason why this is happening?

Thanks so much for the help so far, just to see the web ui after the last few weeks is a massive step forward!

EDIT: Even when I remove all references to the split tunnel in my systemd files and only change the user from joey to vpn, it stops working again
EDIT2: If I include all references to the split tunnel, but keep the user as joey it works, if I change just the deluged.service user as vpn, I can access the webui, but cannot download - it doesn't seem point to a home directory in the webui, even though /home/vpn exists.

Re: Deluged and delugeweb both running but cant access via web browser

Posted: Mon May 11, 2020 9:44 am
by shamael
The webUI only ask for a password but has a configuration in the profile too. Changing the user switch the profile and you are back to default password except if the profile was copied will all daemon off

What if you change the systemd to user "vpn" with a copy of the .config/deluge to "vpn" profile? all with no Deluge daemon running of course, web or deluged

Ps: the .config directory is an hidden one (just to be sure It's stated). And be sure to not have multiple daemon running at the same time.

Re: Deluged and delugeweb both running but cant access via web browser

Posted: Sun May 17, 2020 12:50 pm
by joey7415963
Thanks for your reply... It worked! I moved the .config of my vpn user to another location as a backup and copied the .config of my joey user to the vpn profile. I then changed my systemd files to have the user and group vpn and it worked.

I've yet to test it properly as I need to reset the server - for some reason the VPN connection works after a reset but then stops working after a few days.

Currently though I'm on day 1 of a forecasted 6 day backup so will report back once I have reset.

Thanks again :)

EDIT: I couldn't wait, I restarted and everything looks great! Thank you so much, I've been wanting to fix this for a long time now! For those that run into a similar problem:

1) Stop both deluged and deluge-web services
2) Copy the entire folder: /home/[vpn user]/.config/deluge somewhere else as a backup
3) Copy the entire folder: /home/[main user]/.config/deluge to /home/[vpn user]/.config/deluge
4) Chown [vpn user]:[vpn user] /home/[vpn user]/.config/deluge
5) systemctl reload-daemons
6) Restart both services

Now to see if I can work out what causes my vpn to drop!

Re: Deluged and delugeweb both running but cant access via web browser

Posted: Wed Jul 08, 2020 1:47 pm
by Norawa
There are major differences between VPN services because there are different results every time. You can read more about VPN services here. Read the reviews and choose the best option for ya.