Can't start deluge [Ubuntu 19.10]

General support for problems installing or using Deluge
elRestaurador
New User
New User
Posts: 5
Joined: Thu Nov 28, 2019 4:50 am

Can't start deluge [Ubuntu 19.10]

Postby elRestaurador » Wed Dec 18, 2019 12:06 am

Hi, I can´t start deluge. I always get a

Code: Select all

double free or corruption (out)
Aborted (core dumped)


I've uninstalled it several times, installed from cli and downloading the file. Always same result.
Any ideas?

mhertz
Compulsive Poster
Compulsive Poster
Posts: 999
Joined: Wed Jan 22, 2014 5:05 am
Location: Denmark

Re: Can't start deluge [Ubuntu 19.10]

Postby mhertz » Wed Dec 18, 2019 1:07 am

When googling the error, I stumbled upon your old post regarding this issue. Have you tried removing the qbittorrent PPA, so only having libtorrent.org or deluge PPA for libtorrent, and trying again, reinstalling all?

(For others, in old thread Cas stated qbittorrent PPA's libtorrent builds have issues with python3 giving said error upon running deluge. Unless fixed in meantime of course, but not that old thread, about 5 month'ish: viewtopic.php?t=55392 )

elRestaurador
New User
New User
Posts: 5
Joined: Thu Nov 28, 2019 4:50 am

Re: Can't start deluge [Ubuntu 19.10]

Postby elRestaurador » Wed Dec 18, 2019 2:11 am

I've performed a

Code: Select all

sudo add-apt-repository --remove ppa:qbittorrent-team/qbittorrent-stable

Reinstalled deluge and nothing.
Then performed:

Code: Select all

sudo add-apt-repository ppa:libtorrent.org/1.2-daily
sudo apt-get update
sudo apt-get install libtorrent-rasterbar

Last line output was

Code: Select all

E: Unable to locate package libtorrent-rasterbar


Then tried to launch deluge and got

Code: Select all

double free or corruption (out)
Aborted (core dumped)

mhertz
Compulsive Poster
Compulsive Poster
Posts: 999
Joined: Wed Jan 22, 2014 5:05 am
Location: Denmark

Re: Can't start deluge [Ubuntu 19.10]

Postby mhertz » Wed Dec 18, 2019 2:58 am

Sorry I have no experience with Ubuntu, never tried it honestly. I just checked that libtorrent 1.1.13 is available in Ubuntu 19.10 by default(and deluge 2.0.3), so remove all PPAs regarding libtorrent, deluge and qbittorrent etc, and reinstall from default sources(deluge and libtorrent-rasterbar9).

bru_94
New User
New User
Posts: 1
Joined: Fri Feb 07, 2020 4:52 am

Re: Can't start deluge [Ubuntu 19.10]

Postby bru_94 » Fri Feb 07, 2020 5:04 am

I was having the same error with deluged (as a thin client) on ubuntu 19.10.
The solution that worked for me was add the PPA of libtorrent1.2-daily, then remove the qbittorrent PPA, and finally remove libtorrent-rasterbar9, that will automatically install libtorrent-rasterbar10 and some other stuff that i can't remember... sorry

Code: Select all

sudo add-apt-repository ppa:libtorrent.org/1.2-daily
sudo apt-get update
sudo add-apt-repository --remove ppa:qbittorrent-team/qbittorrent-stable
sudo apt-get remove libtorrent-rasterbar9


As far i can tell it didn't broke anything else.

Hope it work for you!

elRestaurador
New User
New User
Posts: 5
Joined: Thu Nov 28, 2019 4:50 am

Re: Can't start deluge [Ubuntu 19.10]

Postby elRestaurador » Sat Feb 08, 2020 12:16 am

It didn't work

fmar
Member
Member
Posts: 40
Joined: Sun Mar 08, 2020 5:34 pm

Re: Can't start deluge [Ubuntu 19.10]

Postby fmar » Sun Mar 08, 2020 7:45 pm

What version of deluge are you trying to run?
Could you please post the results of "apt-cache policy |grep http |awk '{print $2 " " $3}' |sort -u" and "apt-cache policy deluge" and "apt-cache policy libtorrent*"?
Thanks

pu5htiu
New User
New User
Posts: 3
Joined: Mon Feb 01, 2021 2:19 pm

Re: Can't start deluge [Ubuntu 19.10]

Postby pu5htiu » Mon Feb 01, 2021 2:27 pm

upgrade to 20.04 LTS
delete and purge all deluge ppa, as 20.04 has a working version of 2.0.3, maybe 19.10 has it too.

downgrade to deluged/focal,focal,now 2.0.3-2

and you will need to upgrade to libtorrent1.2:

sudo add-apt-repository ppa:libtorrent.org/1.2-daily
sudo apt-get update
sudo apt-get install python3-libtorrent

# deluged --version
deluged 2.0.3
libtorrent: 1.2.11.0
Python: 3.8.5
OS: Linux Ubuntu 20.04 focal


Return to “Support”

Who is online

Users browsing this forum: Google [Bot] and 9 guests