Notification not working

General support for problems installing or using Deluge
jsw10471
New User
New User
Posts: 8
Joined: Sun May 03, 2020 1:32 pm

Re: Notification not working

Postby jsw10471 » Sun Mar 28, 2021 10:36 pm

So tried it in the linuxserver/deluge docker and got the same result. Oh well i have lived without them for over a year as they have not been a priority to fix so guess i will either keep living without or start looking at a better torrent manager

mhertz
Compulsive Poster
Compulsive Poster
Posts: 1069
Joined: Wed Jan 22, 2014 5:05 am
Location: Denmark

Re: Notification not working

Postby mhertz » Sun Mar 28, 2021 11:39 pm

I just tested it additionally with binhex's delugevpn image, but just setup VPN_ENABLED to 'no' as quicker to test, without needing also setup VPN access also, and that works fine too, so this is now tested working by both me and OP, in two different docker images each, plus I tested it on real linux system + linux VM of other distro + windows 10 VM, all working fine, so i'd have to conclude something seemingly is wrong on your end. I did btw test it through openvpn also, several times on my local system, arch-linux like the delugevpn docker image is based upon, so VPN or not shouldn't be an issue.

If wanna persue this more, then please post the debug output relating to this, and i'd highly suggest that with docker closed i.e. 'sudo docker stop delugevpn/deluge', then copy/paste the contents of the notifications-core.conf I posted here previously: viewtopic.php?f=7&t=55458&start=10#p232822 and paste into said config file, change to your own user, pass and mail-address and start docker again i.e. 'sudo docker start delugevpn/deluge' and test again, with only notifications2 enabled.

You can also test the python email sending test commands/script from the docker directly, which you succesfully tested locally before, so with the docker running, enter it with 'docker exec -it deluge /bin/bash', and run script/test and see if you get mail sent as before - The OP in this thread found out he had an issue with the way he had setup his network, by doing this test which failed then untill he fixed it.
Last edited by mhertz on Sun Mar 28, 2021 11:48 pm, edited 1 time in total.

jsw10471
New User
New User
Posts: 8
Joined: Sun May 03, 2020 1:32 pm

Re: Notification not working

Postby jsw10471 » Sun Mar 28, 2021 11:47 pm

So maybe i spoke to soon...... all the sudden i got a completed email from both Deluge instances.... so i guess the AutoAdd notification is not working for me but the completion is which is really what i would want if I could only have 1 of the 2..... thanks

mhertz
Compulsive Poster
Compulsive Poster
Posts: 1069
Joined: Wed Jan 22, 2014 5:05 am
Location: Denmark

Re: Notification not working

Postby mhertz » Sun Mar 28, 2021 11:54 pm

Cool, you're welcome :) I didn't knew there where an autoadd possibility for mails i.e. I only see a TorrentFinishedEvent for mail scheduling(in this plugin here, I mean - don't know about autoadd plugin or if includes interactions between, never tried/looked), but honestly not much into this here, as never used this functionality myself(notifications or autoadd plugins). I'd guess/presume one could cook up a smtp mail sending script scheduled through the execute plugin, which I know has a TorrentAddedEvent, I believe if remember right. Anyway, I always get a mail in my tests right when finished, exactly at the point of changing from downloading to seeding.

Edit: Not important now, but before I stated you could test my python script in the docker, which I now reread you already had done before, sorry, as remembered wrong about you testing it locally Before. BTW, instead of linux-server image for usage without VPN, then I see binhex also has deluge docker without VPN, arch-deluge, so you get the newer deluge in both dockers, just in-case you wasent aware.

kevindd992002
Leecher
Leecher
Posts: 68
Joined: Thu Jun 13, 2019 2:56 pm

Re: Notification not working

Postby kevindd992002 » Tue Mar 30, 2021 8:28 am

mhertz wrote:Sorry, took some more hours than expected before could look into it.

Anyway, I tested linuxserver deluge docker image, and as OP correctly stated, then using my modded 0.4 notifications plugin doesn't work from docker - it shows 0.4 correctly, but mismatches files during actual running, so not a solution. However, if not using docker, then I again tested it working on regular setups, where it's the best solution to use imho. For docker, then my modded notifications2 plugin works fine and I also tested Cas's modification instead of mine also to be working fine, so heres reuploads with Cas's fix instead of mine:

0.4 for regular deluge users - drop in plugin folder and will be used automatically instead of buggy included 0.3 version:

Notifications-0.4.egg

Notification2 plugin, for docker users, configure with regular notifications plugin(if not already done), disable again and enable Notifications2, and done:

Notifications2-0.3.egg

(As previously said, strange errors happened previously when I had made notifications2 generate own new separate preferences menu and config file, since mismatched with original notifications plugin for some reason, despite not even enabled, so had to ditch all entry-points to fix except 'core', meaning original notifications plugin only useful for generating the conf if missing, nothing else when using notifications2, and both should never be left enabled simultaneously)

Since it works fine here, then are you sure that you're configuring it correctly? Btw, no need test this newer last version, since if the old mod of notifications2 didn't work, then this will neither for you, but just made to test Cas's fix and report back, plus release to public also. You need e.g. 'smtp.google.com', '587' and remember add recipient furthest down i.e. your own email, also go to next tab at top named Subscriptions and tick TorrentFinsihedEvent under Email, sorry not patrionizing you and just want to be sure were on same page here. You can also use my config file posted here previously, and just exchange with your own user, pass, and mail-address: viewtopic.php?f=7&t=55458&start=10#p232822 Remember always stop deluge docker and restart after having added new plugin or changed configs in general.

For logging, if you change the loglevel to debug then should get more output i'd presume, or atleast like that for normal runs - I forgot mess with that before when going into the VM and testing the above.


Replaced the Notifications2-0.3.egg for my LSIO docker image with this updated one (w/ Cas' code) and it seems that it still works! Thanks again!

What is the difference between this one and the one you had me previously use?

mhertz
Compulsive Poster
Compulsive Poster
Posts: 1069
Joined: Wed Jan 22, 2014 5:05 am
Location: Denmark

Re: Notification not working

Postby mhertz » Tue Mar 30, 2021 9:23 am

Glad to hear it, and you're very welcome mate :)

The difference in functionality is nothing, well, except the mail sent is only stating name of file downloaded and not additionally number of files in said torrent(num_files missing). I exchanged used function-call that originally failed with another one I had experience with using before myself, and deleted the number of files part as didn't work with that call, and Cas simply elegantly fixed the offending function call to work, by changing the keys requested to new syntax, without lame workarounds like me :) For end-users, no diff really, except that num_files missing in mine, but Cas's version should be used now by anyone interested, as no reason use mine anymore.

kevindd992002
Leecher
Leecher
Posts: 68
Joined: Thu Jun 13, 2019 2:56 pm

Re: Notification not working

Postby kevindd992002 » Tue Mar 30, 2021 9:51 am

mhertz wrote:Glad to hear it, and you're very welcome mate :)

The difference in functionality is nothing, well, except the mail sent is only stating name of file downloaded and not additionally number of files in said torrent(num_files missing). I exchanged used function-call that originally failed with another one I had experience with using before myself, and deleted the number of files part as didn't work with that call, and Cas simply elegantly fixed the offending function call to work, by changing the keys requested to new syntax, without lame workarounds like me :) For end-users, no diff really, except that num_files missing in mine, but Cas's version should be used now by anyone interested, as no reason use mine anymore.


Good to know. Thanks :)

mhertz
Compulsive Poster
Compulsive Poster
Posts: 1069
Joined: Wed Jan 22, 2014 5:05 am
Location: Denmark

Re: Notification not working

Postby mhertz » Tue Mar 30, 2021 12:03 pm

Lastly, here's a version of the fixed notifications plugin using Cas's fix, working on normal systems and also dockers, I just verified. It uses original plugin-name, so no notifications2 showing anywhere anymore, and in addition to upping version-number, then I also modified the entry-points and __pkd_data__, needed for dockers to not mismatch with old included buggy version. So in all setups this should just be dropped in own plugin folder and restart deluge and daemons, and will work and not look different than normal in preferences menu. Don't have to change though, if using a previous version and was just made to simply things a little.

Notifications-0.4.egg

kevindd992002
Leecher
Leecher
Posts: 68
Joined: Thu Jun 13, 2019 2:56 pm

Re: Notification not working

Postby kevindd992002 » Tue Mar 30, 2021 12:18 pm

mhertz wrote:Lastly, here's a version of the fixed notifications plugin using Cas's fix, working on normal systems and also dockers, I just verified. It uses original plugin-name, so no notifications2 showing anywhere anymore, and in addition to upping version-number, then I also modified the entry-points and __pkd_data__, needed for dockers to not mismatch with old included buggy version. So in all setups this should just be dropped in own plugin folder and restart deluge and daemons, and will work and not look different than normal in preferences menu. Don't have to change though, if using a previous version and was just made to simply things a little.

Notifications-0.4.egg


Ok, this is even better! Can I use the GUI now for my notification settings? If I remember correctly, I had to modify the conf file manually for your old egg version to work.

mhertz
Compulsive Poster
Compulsive Poster
Posts: 1069
Joined: Wed Jan 22, 2014 5:05 am
Location: Denmark

Re: Notification not working

Postby mhertz » Tue Mar 30, 2021 12:23 pm

Yes, that will work fine. It also should before btw, but just was little akward swicthing back and fourth between notifications and notifications2 in plugin-list to change settings(for the notifications2 version meant for dockers - the other notifications v0.4 for regular setups was working the same as this here new version, without awkwardness, just not working on dockers however. Of-course editing config-file directly was/is supported, but just not needed).


Return to “Support”

Who is online

Users browsing this forum: Baidu [Spider] and 11 guests