I have just about had it

General support for problems installing or using Deluge
ramicio
Member
Member
Posts: 26
Joined: Tue Jan 28, 2014 7:40 pm

I have just about had it

Postby ramicio » Sun Aug 18, 2019 11:53 pm

I tried version 2. Hated it. I was on Ubuntu 16.04. Today I upgraded to 19.04. Now I am forced to install version 2. I can't seem to even download the debs and install them. It just breaks so many dependencies and apt just forces 2 over 1.3.15 again.

User avatar
gderf
Seeder
Seeder
Posts: 136
Joined: Sat Jun 18, 2016 1:32 am

Re: I have just about had it

Postby gderf » Mon Aug 19, 2019 2:53 pm

I run Deluge in a docker. You can choose from numerous images available on Linuxserver.io. I am running the latest 1.3.15 image (5b398f77-ls22) which is about two months old.

bro
Top Bloke
Top Bloke
Posts: 359
Joined: Sun Aug 28, 2011 6:46 pm
Location: Norway

Re: I have just about had it

Postby bro » Tue Oct 01, 2019 4:07 pm

ramicio wrote:I tried version 2. Hated it. I was on Ubuntu 16.04. Today I upgraded to 19.04. Now I am forced to install version 2. I can't seem to even download the debs and install them. It just breaks so many dependencies and apt just forces 2 over 1.3.15 again.

May I ask why you hated v2?
When reporting issues, please include any relevant information such as OS (and version), python version (for Windows users this depends on which Deluge installer was used), Deluge version and plugin version.

ramicio
Member
Member
Posts: 26
Joined: Tue Jan 28, 2014 7:40 pm

Re: I have just about had it

Postby ramicio » Wed Jul 08, 2020 11:14 pm

For one, there is no more auto-add functionality. It's just not there! I just tried 2.0.3 again, screwing myself, totally forgetting the main reason I abandoned it after trying it nearly 2 years ago. Got a Windows version for a thin client. Doesn't remember how I size the panes and columns.

mhertz
Compulsive Poster
Compulsive Poster
Posts: 798
Joined: Wed Jan 22, 2014 5:05 am
Location: Denmark

Re: I have just about had it

Postby mhertz » Thu Jul 09, 2020 8:42 am

As said in previous post of yours, enable default-included 'autoadd' plugin from 'Plugins' section of GTK-UI/web-UI preferences dialog.

For the "not-remembering" issue, a workaround that atleast helps(sometimes you need restart deluge to pick it up though), is to write-protect the file gtk3ui.conf in deluge profile-dir after having made the changes wanted in GUI. Seemingly deluge can write to said file fine, but struggles at times to read it back at startup, for whatever reason.

ramicio
Member
Member
Posts: 26
Joined: Tue Jan 28, 2014 7:40 pm

Re: I have just about had it

Postby ramicio » Fri Jul 10, 2020 1:47 am

The whole issue I was having is that it's not even listed in the available plugins to enable. I did, however, get on github and download all of the source files, made my own egg, and it installed fine. On the actual "deluge" program ran on the machine, AutoAdd still wouldn't show in the left-hand pane of the preferences window. It is there in the WebUI and works. I have no desire to run the program from my server over X11 forwarding. Even on a 10 gig fiber connection, it's awfully slow. So the WebUI is just fine for now.

As far as the Windows version, I have no patience for even trying making that file read-only. It takes forever to open, it behaves just weird (like I will hover over the bottom most torrent, and a horizontal scroll bar will then appear. Unhover, scroll bar goes away), doesn't remember my columns, it stays on top of my taskbar when maximized, it has Windows 7 style minimize, maximize, and exit buttons, and it just crashes randomly.

Thank you.

mhertz
Compulsive Poster
Compulsive Poster
Posts: 798
Joined: Wed Jan 22, 2014 5:05 am
Location: Denmark

Re: I have just about had it

Postby mhertz » Fri Jul 10, 2020 6:45 am

What version do you use of deluge2 specifically and how you get it, as deluge 2.0.3 and 2.0.4.dev38(and several previous dev revisions) all features autoadd plugin by default. Sometimes all default plugins are missing when building/installing from source on windows specifically when using a deluge git branch as pip install command, so then need running extra build_plugins command thereafter.

Regarding windows deluge2 annoyances, then e.g before mentioned gtk3ui.conf write-protect workaround helps many of your listed items, plus e.g certain scenarios helps not using maximize, but resizing deluge window to still be maximized etc. To omit the win7 title-menu items, then don't use 'win32' theme and/or enable 'GTK_CSD=0'. I don't know about the "hoover/horizontal-scrollbar" issue, as never heard off, or seen it myself, but I also neither fully understand what the issue is about honestly, I must admit. It didn't open particularly slow for me when testing it previously, but I also only did test with few torrents, so possibly otherwise could make a difference, I dunno, but is however optimized in that aspect when compared to deluge1 specifically.
Last edited by mhertz on Fri Jul 10, 2020 7:21 am, edited 3 times in total.

ramicio
Member
Member
Posts: 26
Joined: Tue Jan 28, 2014 7:40 pm

Re: I have just about had it

Postby ramicio » Sat Jul 11, 2020 12:37 am

2.0.3, and sudo apt-get install deluge

mhertz
Compulsive Poster
Compulsive Poster
Posts: 798
Joined: Wed Jan 22, 2014 5:05 am
Location: Denmark

Re: I have just about had it

Postby mhertz » Sat Jul 11, 2020 1:41 am

Hmm, I'm guessing you're using Debian stable, and because e.g the unofficial deluge2 windows installer of petersasi, includes/uses py3.8.x internally, and Debian stable uses 3.7.x(Debian testing and sid/unstable use 3.8.x). In thinclient mode, deluge server and client both need have same py version of installed plugins(when hard-coded in file-name), so should be same also for default included ones I presume.

if the above indeed is the culprit, then you can rename '-py3.8' part away from default plugins under 'Lib\site-packages\deluge\plugins' and restart. I'm not sure if needs also renamed from both ends though(i.e. if a py3.8 client can work together with a "filename-hardcoded" py3.7 plugin on host - if not, then rename on both ends).


Return to “Support”

Who is online

Users browsing this forum: Baidu [Spider] and 7 guests