cannot compile 2.0.3

General support for problems installing or using Deluge
mooninite
New User
New User
Posts: 8
Joined: Sat Aug 22, 2015 4:05 am

cannot compile 2.0.3

Postby mooninite » Tue Jul 02, 2019 12:28 am

/usr/bin/python3 setup.py build
Traceback (most recent call last):
File "setup.py", line 55, in <module>
_version = get_version(prefix='deluge-', suffix='.dev0')
File "/builddir/build/BUILD/deluge-2.0.3/version.py", line 71, in get_version
raise ValueError('Cannot find the version number!')
ValueError: Cannot find the version number!

Cas
Top Bloke
Top Bloke
Posts: 3643
Joined: Mon Dec 07, 2009 6:04 am
Location: Scotland

Re: cannot compile 2.0.3

Postby Cas » Tue Jul 02, 2019 8:31 am

What source are you using?

mooninite
New User
New User
Posts: 8
Joined: Sat Aug 22, 2015 4:05 am

Re: cannot compile 2.0.3

Postby mooninite » Tue Jul 02, 2019 7:44 pm

https://git.deluge-torrent.org/deluge/s ... .3.tar.bz2

I had grabbed this as I had missed the '2.0' folder on your normal release repo. Using the https://ftp.osuosl.org/pub/deluge/sourc ... 0.3.tar.xz tarball results in a working compile. Sorry about that.


Return to “Support”

Who is online

Users browsing this forum: No registered users and 12 guests